Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Strange DNS Problem?


  • Please log in to reply
2 replies to this topic

#1 MilesT3hr4t

MilesT3hr4t

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:17 PM

Posted 25 November 2014 - 05:30 PM

Quite abruptly today, I encountered a problem. Google, Google+, Gmail, and youtube, would not connect. all other internet connections worked fine. this forum, bing, facebook, all totally fine, no lag or anything. 

I deleted my browsing data, thinking that was the problem, and it did nothing.  Let me go back a bit though.

yesterday, my roommate used my computer, and left a page open that looked to me like a bleepty attempt to get someone to download malware, it was some program for speeding up your computer, seemed really sketchy, so I closed it and I ran the following

Microsoft Security Essentials 
Malware Bytes
JRT
Hitman Pro (trial)
ADWCleaner.

they each found different tracking cookies, and a few trojans but that was it. 2 of them required a re-boot.

after running ADWCleaner and requireing a reboot, my computer was stuck on log-in for 10 minutes, had a black screen while loading windows for another 8, and when windows finally loaded it gave me an error that some processes had failed to load, would not tell me what those processes where, and my computer did not detect that it was plugged into a modem. so no internet. other than that it was fine and clean, and everything *else* worked. 

So, I frantically searched for how to load a restorepoint, and found out that "oh yeah, windows did a critical system update 2 days ago and made a restore point!". Said system restore fixed everything.

That was yesterday. 
after posting about that ordeal on facebook, my IRL friend said "hey, sounds like your computer was part of that botnet that hit cleveland's websites" (mind you, this guy is a car mechanic who thinks he's good with computers because he changed graphics themes on windows to look like something from the movie hackers)

I laughed it off, but then today, while browsing youtube videos, it abruptly stopped working. i had 144p for about 3 seconds, and then nothing. only youtube, google, G+, and gmail where effected. bing had no problems, here at bleepign computer, nothing.

After some digging around and trying to make an account here (except my email is GMAIL, and that took forever, more on that in a bit) I found an article on howtogeek. it said to use command prompt to ping the website. apparently i have a better connection to google than to bing, which is odd given that I could connect to bing and not google. Eventually I determined that it was DNS related.

I could connect to google by connecting directly to its IP, bypassing DNS, so typing http://74.125.224.72 worked, but www.google.com did not. 

So I figured, DNS on my end was blocking google, or google was somehow for some reason blocking me (such as being part of a botnet). I checked my router for DNS and realized I had no idea what I was doing. i figured out that DDNS was disabled, but I have no idea if that's normal or not. I didn't change anything on the router, and went back to just trying to go to google.com. still nothing, stuck on connecting. I did a system restore. still nothing. I started reading wikipedia, testeg google, still nothing. I started digging around on here, and then went back to google.com and it just worked.

google, Google+, Gmail, and youtube, now work, no problems at all, and I do not know why. I didn't fix it, it's like it happened on a timer, and simply enabled access starting at 5PM or so.

I do not appear to have any malware, or adware. I do not suspect I received a virus in the last 24 hours. I do not know what to scan with at this point, and my oldest restore point is from 11/22/2014 due to a critical windows update. I do not have a backup. I do not have an older restore point. I do not know why I couldn't connect to google owned sites, why it was ONLY google owned sites, nor do I know why I can connect now. 

I have never been more terrified for my computer. at least when I got other viruses could find out what they where to find a specific fix. Not knowing is a nightmare.


Edited by hamluis, 26 November 2014 - 12:16 PM.
Moved from Win 7 to Am I Infected - Hamluis.


BC AdBot (Login to Remove)

 


m

#2 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:10:17 PM

Posted 26 November 2014 - 07:04 AM

Well, since everything is working now, just some general info;

 

1. Sometimes a business just has problems responding to the demand.

 

2. The ping command is useful at times for troubleshooting, but some websites are set up to not respond to ICMP requests in order to prevent simple DDOS attacks. ICMP is the internet protocol that the ping command uses, more info here (it's quite dry) ... http://compnetworking.about.com/od/tcpip/g/bldef_icmp.htm . Keep in mind that Google IS set up to respond to ICMP requests, so "pinging" google.com is usually valid for troubleshooting the router or modem.

 

3. You don't need DDNS at your level, it's mainly at WAN and above level. More info here ... http://compnetworking.about.com/cs/domainnamesystem/g/bldef_ddns.htm .

 

Hope this helps.



#3 MilesT3hr4t

MilesT3hr4t
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:17 PM

Posted 26 November 2014 - 02:49 PM

--EDIT

 

I just got off the phone with my ISP and cannot stop laughing. Everyone was calling them yesterday, specifically about google. nobody could figure out what was wrong, and later that night, they actually called google, because they couldn't find what was wrong.

Turns out, google is doing firmware updates, which may still be in progress, and outages may or may not continue.


Edited by MilesT3hr4t, 26 November 2014 - 03:00 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users