Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with Backspace key in Firefox


  • Please log in to reply
7 replies to this topic

#1 forthedownfive

forthedownfive

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:46 AM

Posted 24 November 2014 - 08:24 PM

This is a very odd and very narrow issue, but it's been driving me mad lately.

 

When I hold down the Backspace key to delete multiple characters, it only deletes the first character and then hangs.

 

However -- the kicker -- this ONLY happens in Firefox, this has ONLY happened on one site so far (Facebook), and this ONLY happens when I am replying to a post and trying to backspace in the little comment box.

 

Repeatedly single backspacing works fine. Facebook in IE works fine. Other similar commenting platforms (Disqus, etc.) work fine. Malwarebytes came back clean. The problem persists when I disable all addons in Firefox, and the problem also persists when I change "Page Style" to "No Style" under the View menu.

 

I wonder if this would be some rendering bug between Facebook and Firefox, or if it might simply be time for a new keyboard. But if it were my keyboard, shouldn't this happen in all sites and shouldn't this affect single-Backspacing as well?

 

Any advice or leads for this very obscure issue would be greatly appreciated. This may seem like the tiniest nitpick of a problem, but it affects me multiple times daily.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,924 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:46 PM

Posted 24 November 2014 - 10:42 PM

Hello, and Welcome

 

I am not sure if this will cure your problem but give it a try.

 

In the address bar type about:config  then confirm

 

search for browser.backspace_action in the search bar.

 

Set the value to 2 instead of 0. Exit out and restart Firefox.



#3 forthedownfive

forthedownfive
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:46 AM

Posted 25 November 2014 - 09:04 PM

Hi John,

 

Thanks for the reply and for your suggestion.

 

Changing the about:config setting did not make a difference. However, as usual, I overlooked the simplest solution -- updating FF from 26.0 to 33.0 solved the problem immediately.

 

You'd think a browser not even a year old wouldn't have all these compatibility issues, but alas...

 

Thanks again for your help,

 

Josh



#4 JohnC_21

JohnC_21

  • Members
  • 22,924 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:46 PM

Posted 25 November 2014 - 09:29 PM

Glad you got it sorted out. Thanks for the update and the solution.

#5 Daisy24

Daisy24

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 25 November 2014 - 11:28 PM

I am having the same problem and have tried both of the above fixes with no result..... I did some Googling and also changed some settings of Sticky Keys which did nothing.....

 

Seems to work fine using Internet Explorer.....

 

Any other advice other then using IE....?

 

Cheers



#6 JohnC_21

JohnC_21

  • Members
  • 22,924 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:46 PM

Posted 26 November 2014 - 09:46 AM

This could also be due to a conflict with an add-on. Start Firefox in safe mode (no-addons). Help > Restart with addons disabled.

 

If the problem is fixed, restart firefox and disable each add-on until you find the one causing the problem.



#7 Daisy24

Daisy24

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:02:46 AM

Posted 28 November 2014 - 06:44 PM

Thankyou JohnC_21

 

I did this and it appears to be the Grammarly add-on.....so far so good anyway.

I love that add-on though :(  Shame I won't be able to use it any more... Still, it beat having to use IE.

 

THanks again :clapping:



#8 ddeerrff

ddeerrff

    Retired


  • Malware Response Team
  • 2,723 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Upper Midwest, US
  • Local time:11:46 AM

Posted 29 November 2014 - 08:44 PM

I see the same issue with FF 22, and I do not have the Grammarly add on.  I'd just write it off to a Facebook bug.  Wouldn't be the first...


Edited by ddeerrff, 29 November 2014 - 08:45 PM.

Derfram
~~~~~~




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users