Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

virtual memory is low


  • Please log in to reply
5 replies to this topic

#1 vacuum tube

vacuum tube

  • Members
  • 88 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:usa nj
  • Local time:01:22 PM

Posted 16 November 2014 - 12:24 PM

that is the warning i get [not very often] it says windows is increasing its size. i click on it [okay] and it goes away. been happening a few months or so. no big deal ? this putor has no games and no personal files [no  banking] so it should not be clogged up with junk. i clear out history once a week. thank you



BC AdBot (Login to Remove)

 


#2 Torvald

Torvald

  • Members
  • 366 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Antonio, TX USA
  • Local time:01:22 PM

Posted 16 November 2014 - 05:36 PM

From:  http://answers.microsoft.com/en-us/windows/forum/windows_xp-performance/my-xp-pc-is-slow-and-says-virtual-memory-is-low/8934079e-cc86-4ccf-9bb3-3aa17ebce036

 

If you mean you are seeing an informative message like this:

Virtual Memory Minimum Too Low: Your system is low on virtual memory.  Windows is increasing the size of your virtual memory paging file.

That means Windows XP is letting you know it is doing it's job.  The message is not an error message - it is an informational message.

If XP thinks the size of the paging file (usually c:\pagefile.sys) is too small to accommodate your current operations it will adjust the paging file to make the paging file larger and display that message as it does so.  It is not necessarily a "problem", but the message is annoying.

 

Unless you know more about managing memory that Windows XP, it is usually best to just let XP handle the size of your virtual memory paging file.

To see what your current settings are, right click My Computer, Properties, Advanced, Performance Settings, Advanced tab, Virtual Memory, then click the Change button.

Make a note of the current settings in case you need to change them back later.

The best setting for the Paging file size is usually going to be:

System managed size

Right click My Computer, Properties, Advanced tab, Performance... Settings, Advanced tab, Virtual memory... Change.

Make a note of the current setting so you can change things back later if you have a problem.

If it is not already, set the Paging file size to:

System managed size

Be sure to click Set (to set it), OK (several times) and then restart your computer.

Windows XP will try to allocate a paging file approximately 1.5 times the total amount of the RAM installed in your system.  Letting Windows XP handle the paging file size is adequate for most configurations.


Google is my friend. Make Google your friend too.


#3 vacuum tube

vacuum tube
  • Topic Starter

  • Members
  • 88 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:usa nj
  • Local time:01:22 PM

Posted 16 November 2014 - 07:05 PM

thank you.i just thought i was maybe seeing it too often 



#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,868 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:22 PM

Posted 17 November 2014 - 03:20 PM

Change your settings and Let Windows Manage Virtual Memory .

 

Louis



#5 vacuum tube

vacuum tube
  • Topic Starter

  • Members
  • 88 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:usa nj
  • Local time:01:22 PM

Posted 17 November 2014 - 03:54 PM

thank you



#6 Willy22

Willy22

  • Members
  • 945 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Planet Earth
  • Local time:07:22 PM

Posted 17 November 2014 - 05:32 PM

Yep. I used to get that messages as well when I still had a XP laptop with only 512 MB of memory. There're a number of things you can do to improve overall system performance:
- Some programs have a lousy memory management and won't give back used memory. Then you'll get messages like this. Install a free program called Cleanmem (from PcWinTech). It reduces memory usage and that reduces the need for Windows to write to the pagefile. And that means Windows can postpone or even eliminate increasing the size of the pagefile (which takes A LOT OF time).
- Install more memory.
 
- And let Cleanmem collapse the filecache as well.
 
Mod Edit:  Merged posts - Hamluis.

Edited by hamluis, 18 November 2014 - 10:50 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users