Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

bsod KERNEL_DATA_INPAGE_ERROR


  • Please log in to reply
27 replies to this topic

#1 paulos123

paulos123

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 13 November 2014 - 04:52 PM

bsod appeared three time in three days now.

KERNEL_DATA_INPAGE_ERROR was the name and was caused by this driver ntoskrnl.exe

i think its the hard drive cause its performance before three days was 99 and now is 95,and its health is 99 always.

but im leaving it to you guys the experts....

waiting for your help thanks anyway

 

here is the log of bsod

 

==================================================
Dump File         : 111314-25687-01.dmp
Crash Time        : 11/13/2014 10:44:21 AM
Bug Check String  : KERNEL_DATA_INPAGE_ERROR
Bug Check Code    : 0x0000007a
Parameter 1       : fffff6e0`00dbadf0
Parameter 2       : ffffffff`c0000185
Parameter 3       : 00000000`9a712880
Parameter 4       : ffffc001`b75be380
Caused By Driver  : ntoskrnl.exe
Caused By Address : ntoskrnl.exe+14f1a0
File Description  : NT Kernel & System
Product Name      : Microsoft® Windows® Operating System
Company           : Microsoft Corporation
File Version      : 6.3.9600.17328 (winblue_r3.140827-1500)
Processor         : x64
Crash Address     : ntoskrnl.exe+14f1a0
Stack Address 1   : 
Stack Address 2   : 
Stack Address 3   : 
Computer Name     : 
Full Path         : C:\WINDOWS\Minidump\111314-25687-01.dmp
Processors Count  : 4
Major Version     : 15
Minor Version     : 9600
Dump File Size    : 293,304
Dump File Time    : 11/13/2014 11:11:01 AM
==================================================
 
also i forgot to mention that the pc appeared more than 5times problem at windows startup and i tried with windows dvd to do startup repair but it said something like startup system cant be repaired.

Edited by paulos123, 13 November 2014 - 07:42 PM.


BC AdBot (Login to Remove)

 


#2 blueelvis

blueelvis

    Bleep Blop Bleep


  • Malware Response Team
  • 1,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:12:52 PM

Posted 14 November 2014 - 09:54 AM

Hi Paulos123 & Welcome to the forums ^_^,

 

I would need the Dump files in order to analyse the situation your system is in and help cure it ^_^.

Please note that without the Dump files, I can't help you out.

Kindly ZIP Up the dump files and then upload them to a File Hoster like Mediafire. The Dump files are located in "C:\Windows\Minidumps". You might need to copy them to some other folder before zipping them due to permission issues.

 

Once they are uploaded, paste back a link to it here and I would be glad to analyse them ^_^

 

 

-Pranav


Member of the Bleeping Computer A.I.I. early response team!


In case I have been helping you and you haven't received a reply from me in 48 hours, please feel free to PM me. Anything else? Still feel free to PM me :)

Did you read this? http://omgdebugging.com/5-tips-for-getting-the-best-bang-for-the-buck-at-fast-food-joints/

#3 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 14 November 2014 - 12:59 PM

thanks for the help,i appreciate that here the minidump files as you asked......

Attached Files



#4 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 14 November 2014 - 01:58 PM

i really need a quick help cause the performance of hard drive in an afternoon fall from 94 to 74.

 

but health still at 99


Edited by paulos123, 14 November 2014 - 06:46 PM.


#5 blueelvis

blueelvis

    Bleep Blop Bleep


  • Malware Response Team
  • 1,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:12:52 PM

Posted 15 November 2014 - 05:44 AM

Hi Paulos123 ^_^,

 

2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************
KERNEL_DATA_INPAGE_ERROR (7a)
The requested page of kernel data could not be read in.  Typically caused by
a bad block in the paging file or disk controller error. Also see
KERNEL_STACK_INPAGE_ERROR.
If the error status is 0xC000000E, 0xC000009C, 0xC000009D or 0xC0000185,
it means the disk subsystem has experienced a failure.
If the error status is 0xC000009A, then it means the request failed because
a filesystem failed to make forward progress.
Arguments:
Arg1: fffff6e80011f7e8, lock type that was held (value 1,2,3, or PTE address)
Arg2: ffffffffc0000185, error status (normally i/o status code)
Arg3: 00000000a6ef6be0, current process (virtual address for lock type 3, or PTE)
Arg4: ffffd00023efd000, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)
Debugging Details:
------------------

ERROR_CODE: (NTSTATUS) 0xc0000185 - The I/O device reported an I/O error.
DISK_HARDWARE_ERROR: There was error with disk hardware

 

All of your dump files report Failure with the Disk Hardware. I would suggest you to perform the Hardware Diagnostics over here -

 

http://carrona.org/hddiag.html

 

and report back with the results. I would also suggest you to check for loose connections to the HDD's. Also make sure that the cable is not damaged.

 

Let me know how it goes ^_^


Member of the Bleeping Computer A.I.I. early response team!


In case I have been helping you and you haven't received a reply from me in 48 hours, please feel free to PM me. Anything else? Still feel free to PM me :)

Did you read this? http://omgdebugging.com/5-tips-for-getting-the-best-bang-for-the-buck-at-fast-food-joints/

#6 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 15 November 2014 - 07:03 AM

thanks man im going to do that....fyi i run hdd regenerator and it found 1 delay in the first sectors of drive and 13 bad sectors in the end,

also as i told you i have the hard disk sentinel program and it says that the health is 99 but performance is 74 now and in smart the option reallocation event count is with yellow colour,its weird cause if the hard drive is going to be dead mostly it looses its health.its temperature is also good 38-42.

thats extra info that i thought its better if you know.......



#7 blueelvis

blueelvis

    Bleep Blop Bleep


  • Malware Response Team
  • 1,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:12:52 PM

Posted 15 November 2014 - 07:24 AM

thanks man im going to do that....fyi i run hdd regenerator and it found 1 delay in the first sectors of drive and 13 bad sectors in the end,

also as i told you i have the hard disk sentinel program and it says that the health is 99 but performance is 74 now and in smart the option reallocation event count is with yellow colour,its weird cause if the hard drive is going to be dead mostly it looses its health.its temperature is also good 38-42.

thats extra info that i thought its better if you know.......

Thanks for sharing the information ^_^.

 

That seems a failing driver, so kindly make sure that you backup all of your data so that there is no chance of data loss.

 

Let me know the results of those tests ^_^


Member of the Bleeping Computer A.I.I. early response team!


In case I have been helping you and you haven't received a reply from me in 48 hours, please feel free to PM me. Anything else? Still feel free to PM me :)

Did you read this? http://omgdebugging.com/5-tips-for-getting-the-best-bang-for-the-buck-at-fast-food-joints/

#8 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 15 November 2014 - 12:40 PM

i downloaded the iso for the hard drive and burn to dvd but when it boots the program cant find the hard drive....

so im doing a backup of hdd and diangose with programs from ultimate boot cd....


Edited by paulos123, 15 November 2014 - 01:32 PM.


#9 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 15 November 2014 - 04:04 PM

i did diagnostics with a program i found on ubcd and it stucks in the end where the bad sectors are,i dont know what to do know,for sure i need to use a program that is gonna provide me with details of the problem

 

also my friend blueelvis i have to be sure that the problem is from hard drive cause i dont want to give my laptop to warranty center and take it after 1 month.

 

fyi i run memory diagnosis for ram and its clear.

 

in the end im thinking that all these things are caused by software or a driver cause only the performance of the drive is falling and not the health,from the other hand hdd regenerator found 13 bad sectors and the hitachi diagnostics tool stuck in the end when it found them.

 

i ll be waiting for your answer and help,thanks anyway


Edited by paulos123, 15 November 2014 - 09:53 PM.


#10 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 16 November 2014 - 07:26 AM

useful info and report from hard disk sentinel.....

Attached Files



#11 blueelvis

blueelvis

    Bleep Blop Bleep


  • Malware Response Team
  • 1,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:12:52 PM

Posted 16 November 2014 - 07:45 AM

That seems a failing HDD to me :(

 

Also, what was the result of the other Hardware Diagnostics in the list?


Member of the Bleeping Computer A.I.I. early response team!


In case I have been helping you and you haven't received a reply from me in 48 hours, please feel free to PM me. Anything else? Still feel free to PM me :)

Did you read this? http://omgdebugging.com/5-tips-for-getting-the-best-bang-for-the-buck-at-fast-food-joints/

#12 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 16 November 2014 - 07:52 AM

the disk report as i told you is from hard disk sentinel

i scanned with hdd regenerattor and found 13 bad sectors

and another diagnostic tool from ubcd stuck the diagnosis(freeze)at 85% where the bad sectors are...


Edited by paulos123, 16 November 2014 - 07:52 AM.


#13 blueelvis

blueelvis

    Bleep Blop Bleep


  • Malware Response Team
  • 1,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:12:52 PM

Posted 16 November 2014 - 11:21 PM

the disk report as i told you is from hard disk sentinel

i scanned with hdd regenerattor and found 13 bad sectors

and another diagnostic tool from ubcd stuck the diagnosis(freeze)at 85% where the bad sectors are...

Hi Paulos123 ^_^,

 

I confirmed with my friend as well (Thanks Jared) that it seems a failing HDD. But before that, kindly remove Avast using this **TOOL** and make sure that you enable Windows Defender once you are done removing Avast.

 

If the issue is still there, then it is a failing Hard Disk.


Member of the Bleeping Computer A.I.I. early response team!


In case I have been helping you and you haven't received a reply from me in 48 hours, please feel free to PM me. Anything else? Still feel free to PM me :)

Did you read this? http://omgdebugging.com/5-tips-for-getting-the-best-bang-for-the-buck-at-fast-food-joints/

#14 paulos123

paulos123
  • Topic Starter

  • Members
  • 313 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:greece
  • Local time:02:22 AM

Posted 17 November 2014 - 06:00 AM

i will do that thanks for your efford and patience,i appreciate that.

also i want to say to you that i took out the hdd and clean the ports for dust and i cheched with hdd regenerator(didnt find bad sectors)

and hard disk sentinel(didnt find anything as well).so i ll uninstall avast and i ll wait some days to see if im gonna have bsod again and if i need new hdd.

have a nice day



#15 blueelvis

blueelvis

    Bleep Blop Bleep


  • Malware Response Team
  • 1,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:12:52 PM

Posted 17 November 2014 - 06:18 AM

i will do that thanks for your efford and patience,i appreciate that.

also i want to say to you that i took out the hdd and clean the ports for dust and i cheched with hdd regenerator(didnt find bad sectors)

and hard disk sentinel(didnt find anything as well).so i ll uninstall avast and i ll wait some days to see if im gonna have bsod again and if i need new hdd.

have a nice day

Bad connectors or loose connections may also cause this problem.

 

Let me know how it goes ^_^


Member of the Bleeping Computer A.I.I. early response team!


In case I have been helping you and you haven't received a reply from me in 48 hours, please feel free to PM me. Anything else? Still feel free to PM me :)

Did you read this? http://omgdebugging.com/5-tips-for-getting-the-best-bang-for-the-buck-at-fast-food-joints/




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users