Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need some help troubleshooting a port forward


  • Please log in to reply
12 replies to this topic

#1 Cybernetiks

Cybernetiks

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 11 November 2014 - 11:31 PM

Hi all, first post here.

I am trying to forward one of my ports for the game Unturned. I've researched how to do it, but I see some videos where people forward the port through windows, and some where they do it through the router. Which one should one use? Both?

I went into my router settings and gave my computer a dhcp reservation, which is working great. Then I go the port forwarding section and open port 25444 (Unturned) and assign the server IP to be my computer's dhcp reservation address. After this I use an open port tester and it is still not open.

This brings me to my next question, could my modem be screwing up my router's forwarded port? I have 2 separate devices. I read a little bit about double NAT and think that may be a possible issue. 

Router, modem, windows, what should I do next?

 

 



BC AdBot (Login to Remove)

 


#2 Cybernetiks

Cybernetiks
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 11 November 2014 - 11:41 PM

Here are some screenshots of my router settings:

https://imgur.com/a/IEiqH



#3 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 11 November 2014 - 11:46 PM

Did you double check that the IP address you reserved is assigned to the PC? not just what the router says

 

What is the make and model of the modem?


Edited by CaveDweller2, 11 November 2014 - 11:47 PM.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#4 Cybernetiks

Cybernetiks
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 11 November 2014 - 11:57 PM

Yes, I ran an ipconfig and my ipv4 address is indeed 192.168.1.100.

 

I did just also confirm that my modem has NAT enabled. Should I turn it off?

Modem is an Actiontec GT701D.



#5 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 11 November 2014 - 11:58 PM

hmmm modem and router doing NAT is not a good thing. I'd try turning it off.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#6 Cybernetiks

Cybernetiks
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 12 November 2014 - 12:03 AM

The thing is I'm not sure if my router has NAT. And no NAT at all is bad too, right?


Edited by Cybernetiks, 12 November 2014 - 12:03 AM.


#7 Cybernetiks

Cybernetiks
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 12 November 2014 - 12:05 AM

There is also a setting for forwarding ports on my modem software. Do I need to forward the port on both of them or should one be sufficient? What about forwarding the port through Windows?



#8 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 12 November 2014 - 12:36 AM

DHCP should only be on in one of them. Pick one and turn it off in the other. You can try turning off the windows firewall if you get the DHCP situation taken care of and it's still not working. 


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#9 Cybernetiks

Cybernetiks
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 12 November 2014 - 01:52 AM

Ok here is a list of my current settings on both the router and modem.

 

Modem settings:
DHCP: On

UPnP: Off

Firewall: Off

DMZ Hosting: Off

NAT: On

Dynamic Routing (RIP): Off

 

Router settings:

DCHP: On. I also have the DCHP address reservation for my computer set here.
UPnP: On

Firewall: The only option is to check a box by "Disable SPI Firewall". I currently have it checked, AKA the SPI Firewall is off. 

DMZ: Off

NAT: The only 2 options are "secured" and "open". I have it set to open. There is also an option to "Disable SPI ALG". Should I turn this off?
 

I know the problem lies in these settings somewhere. At least I hope.

I also have my ports forwarded via the router.

I am kind of afraid if I turn off my DCHP and/or NAT on my modem my internet will go out and I am REALLY trying to avoid that if at all possible. Doesn't my router get assigned its IP by the modem's DCHP? And if I turn it off it won't be assigned one which would mean no internet connection?

I used a utility found here: http://www.pcwintech.com/shanes-toolbox called detect routers which is meant to tell you if you have multiple routers on your network. I have 2. How can I make this show just 1? I really don't want to have to use DMZ as it is not very secure.

Edit: After some further reading here http://www.practicallynetworked.com/networking/fixing_double_nat.htm I'm convinced that double NAT is my issue. My router is being assigned a private IP address 192.168.x.x as its WAN address. This means that my modem is assigning it this address via NAT and that I have two NATs at work. I tried turning off the NAT on my modem but this resulted in loss of connection. I also tried to forward my modem's ports to my router's WAN IP, so it could then forward the ports as needed as explained in "The Remedy" section in the above link. But when I tried to make a new rule it said it was an "invalid port". HELP D:


Edited by Cybernetiks, 12 November 2014 - 03:18 AM.


#10 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 12 November 2014 - 10:42 AM

you can turn it off in the router and do the port forwarding in the modem it doesn't really matter which does it. I have a modem/ wireless router and another router I use for wireless cause the ISP supplied wireless part sucks. But the ISP's modem does the DHCP for my network. So while double NAT can get you online you have hit it's major issue...port forwarding. I guess you could forward the port in the modem to the router's IP and then see if it works. Just pick one and go with it. You can always undo what you did. The worst thing that you might have to do is reset everything and start over.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#11 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 12 November 2014 - 11:19 AM

You may be able to put your modem router into bridge mode which will allow the public wan ip address to end up on the last router.

 

I would suggest you do a tracert yahoo.com and post the results for review.

 

You can also hookup your last router per this article and only do port forwarding in the modem/router unit

http://www.techsupportforum.com/3001-connecting-additional-routers/

 

Otherwise you have to set a static ip on the last routers wan port for the modem/router to target for port forwarding



#12 Cybernetiks

Cybernetiks
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:08 PM

Posted 12 November 2014 - 07:18 PM

After hours on the phone with CenturyLink, Actiontec, and Netgear I finally forwarded my ports. I had to set my modem to bridged mode, and then had to enter my PPPOE information into my router's settings.



#13 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:08 PM

Posted 12 November 2014 - 07:51 PM

Ok, glad you got it sorted.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users