Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Not able to change permissions on system32 folder


  • Please log in to reply
1 reply to this topic

#1 Bob Frost

Bob Frost

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:16 PM

Posted 11 November 2014 - 02:35 PM

Hello and thanks for reading my post. The idea is that I want to run csc.exe without having to run it from it's folder location in cmd. So I tried using an elevated command prompt to make a hard symbolic link of csc.exe to my System32 folder. My OS is 8.1 pro.

 

In my Administrator Command Prompt:

 

>mklink /h c:\windows\system32 c:\windows\microsoft.net\framework\v4.0.30319\csc.exe

Access is denied.

 

So, I've checked my administrative privileges on my System32 folder. The permission is set to Special permission which is in this case is defined as Modify permission for the System32 folder, and Full control for all subfolders and files. Apparently I can't create a file within the system32 folder, but I can create a subfolder. When I try to modify the settings I just get greyed out options and can't do anything at all. I'm using Windows Defender, already tried changing permissions with WinDefender disabled.

 

If anyone has a solution I'll be very grateful.


Edited by Bob Frost, 11 November 2014 - 04:05 PM.


BC AdBot (Login to Remove)

 


#2 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:07:16 PM

Posted 13 November 2014 - 04:53 AM

You may have to enable the built-in Administrator to do this. See here ... http://www.eightforums.com/tutorials/9650-built-administrator-account-enable-disable-windows-8-a.html .






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users