Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Headset mic troubles


  • Please log in to reply
1 reply to this topic

#1 Steinbiz

Steinbiz

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:55 AM

Posted 10 November 2014 - 04:35 PM

SO I currently have the basic Logitech H390 headset. The mic picks up my voice easily from 1-2 feet away. But the cords are kinda starting to go bad that effect sound in the headphones. So I'm in the market for new a new headset. Get this, I bought Logitech G230, Logitech G430, Razer Carcharias, Razer Krazen USB and none of them could pick up my voice worth a damn. The only way they could detect my voice was if the mic was literally right in front of my lips. So I just gave up and bought another Logitech H390(same one that I currently have). The mic is doing the same thing!!! It's the SAME mic, but the mic won't work worth a damn. I find it hard to believe that 4-5 different headsets wouldn't work, but then again, could it be my computer? My current headset picks up my voice just fine.

 

I also tested the Logitech G430 on my iPhone and it could detect my voice from a long ways away. So it has to be something with my computers configuration that I must not know about.

 

Help Please? :)



BC AdBot (Login to Remove)

 


#2 Kilroy

Kilroy

  • BC Advisor
  • 3,408 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:12:55 AM

Posted 11 November 2014 - 07:16 AM

Have you tried to boost the microphone?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users