Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Starcraft 2 will not install, stuck at "Updating Battle.net Agent..."


  • Please log in to reply
1 reply to this topic

#1 whatthebleep1997

whatthebleep1997

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:37 AM

Posted 07 November 2014 - 04:13 AM

Hello.  For those among you who have time, patience, and indomitable will...I need your help.

 

My problem is that I cannot install Starcraft 2 or the Battle.net App. When I run the setup application, a small blue rectangular window appears saying "Starting Battle.net..." and progresses to "Updating Battle.net Agent..." when the load bar gets to about 45% and stops. Around 20 minutes later I receive an error message: BLZBNTAGT00000002 or BLZBNTBNA00000005 -- [https://us.battle.net/support/en/article/failed-to-run-a-required-program-agent] or [https://us.battle.net/support/en/article/cannot-communicate-with-battlenet-update-agent].

 

Battle.net Tech Support tried to help by giving me a myriad of fixes: dns flush, power cycle, Windows update, running a security scan, disabling security programs, enabling Secondary Logon, closing background applications, manually updating Agent, deleting Battle.net Tools folder, and opening ports for all Blizzard games.  I also tried game client installers in different languages and for different games (suggested by http://eu.battle.net/wow/en/forum/topic/12439453832?page=1).
 

I had Starcraft 2 Heart of the Swarm installed on this computer a year ago and uninstalled it.  Of course, a year later and Blizzard has new installer software that hates my computer and refuses to let me play warcraft in space.  I no longer have the game discs.

 

As requested by Battle.net Tech Support, I have created a "Looking-Glass" diagnostic for Battle.net Authentication, DxDiag, and MSInfo reports.  If you would like to see these reports or anything else let me know.  Whatever help anyone can offer is greatly appreciated!

 

 

**As previously stated, Battle.net Tech Support tried to help me and ended by saying "...I took a look at your system information that you sent us and it appears that there are some core services in your operating system that are crashing. This is likely the cause of StarCraft II not being able to be installed and I would recommend taking your computer to a local tech to see what may be causing these crashes. The name of the program crashing is the svchost.exe."



BC AdBot (Login to Remove)

 


#2 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:06:37 AM

Posted 10 November 2014 - 04:08 AM

The process "svchost.exe" is a frequent troublemaker. Before taking your PC to the shop I would do search on BC for "svchost.exe" and look at what has been tried before.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users