Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WINDOWS DOES NOT WANT TO SAVE SYSTEM SETTINGS


  • Please log in to reply
12 replies to this topic

#1 SYOB SYOT

SYOB SYOT

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 01 November 2014 - 03:31 PM

HAY,

I HAVE A PROBLEM WITH MY WINDOWS.

IT DOES NOT WANT TO SAVE SYSTEM SETTINGS.

IT SAVES NORMALLY ALL SETTINGS FROM THIRD PART PROGRAMS, AND USER SETTINGS.

BUT SETTINGS RELATED TO SYSTEM DOES NOT WANT TO SAVE.

FOR EXAMPLE, IT DOES NOT WANT TO SAVE STATUS OF THE WINDOWS SERVICES. FOR EXAMPLE I CHANGE STARTUP SETTINGS FROM SEVERAL WINDOWS SERVICES FROM DISABLED TO AUTOMATIC, AND IT DOES NOT SAVE THIS.

IT ALSO FOR EXAMPLE, DOES NOT SAVE SETTINGS WHEN I EDIT REGISTRY.

ALSO, MOST OF CONTROL PANEL SETTINGS. (THOSE USER SPECIFIC ARE SAVED, BUT SYSTEM SETTINGS ARE NOT).

AND SO ON.

IT SAVES SETTINGS ONLY IN SAFE MODE.

THIS LOOKS LIKE SOME THIRD PARTY APPLICATION PREVENTING WINDOWS FROM SAVING SETTINGS, BUT I DISABLED ALL THIRD PART APPLICATIONS (CLEAN BOOT), AND, DISABLED ALL WINDOWS SERVICES (EXCEPT 3 WHICH CAN NOT BE DISABLED BECAUSE THEY ARE ESSENTIAL) IN SAFE MODE, REBOOTED, AND TRIED TO ENABLE THEM IN NORMAL (CLEAN BOOT) MODE, BUT STILL, NOTHING. AFTER A RESTART, IT DID NOT SAVE THEM.

 

CAN SOMEONE TELL ME WHAT THIS MIGHT BE?

THANX

 

(POST SCRIPTUM: I AM AT THE MOMENT USING WINDOWS SERVER 2012, BUT IT IS THE SAME THING AS WINDOWS 8, WHERE I HAD THE SAME PROBLEM, SO CONSIDER THIS BEEING WINDOWS 8 QUESTION)


Edited by hamluis, 04 November 2014 - 07:30 AM.
Moved from Win 8 to Win NT - Hamluis.


BC AdBot (Login to Remove)

 


#2 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:12:44 PM

Posted 02 November 2014 - 04:24 AM

I suspect you're not logged in as an Administrator.



#3 SYOB SYOT

SYOB SYOT
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 03 November 2014 - 11:58 AM

NO I AM NOT LOGGED IN AS "ADMINISTRATOR" LITERALLY (BUILT IN ACCOUNT), BUT MY ACCOUNT HAS ADMINISTRATIVE PRIVILAGES (IT IS MEMBER OF ADMINISTRATORS GROOP), SO MY ACCOUNT IS SECOND ADMINISTRATOR ACOUNT ON COMPUTER.



#4 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:02:44 AM

Posted 04 November 2014 - 09:37 PM

mmm does sound weird and with all the caps it must be confusing for you!

 

Have you tried creating another account and giving it admin privllages?

it seems as though the System account is coreecting the settings every time it starts or another app like spybot (Tea timer what ever iots called) is just reapplying the settings upon startup.



#5 SYOB SYOT

SYOB SYOT
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 10 November 2014 - 03:18 PM

YES I HAVE.

I HAVE CURRENTLY 3 ADMINISTRATOR ACCOUNTS, BUT ON NONE OF THEM WINDOWS SAVE SETTINGS IN CONTROL PANEL.

JUST WHILE IN SAFE MODE.

 

I DO NOT KNOW.

I DO NOT HAVE AY APPS THAT I AM AWARE OFF CAPABLE OF DOING THIS.

I AM NOT SURE WHAT TO DO WITH SYSTEM ACCOUNT.



#6 starrouter

starrouter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Mexico
  • Local time:10:44 AM

Posted 10 November 2014 - 03:53 PM

Just curious, is this a domain controller ?  member server of a domain ? 

You might try logging on as THE administrator, not just an account with admin privileges.  If that account can make changes that are saved, then compare the "member of" listing with that account and the other accounts that have admin privileges and see if they all have the same group membership.  For example, in mine administrators are members of these groups:

 

Administrators

Domain Admins

Domain Users

Enterprise Admins

Schema Admins

Group Policy Creator Owners



#7 SYOB SYOT

SYOB SYOT
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 14 November 2014 - 03:35 PM

HAY,

NO, IT HAS THAT ROLE INSTALLED, BUT IT IS NOT SETTED UP. (SERVER 2012). AND 8 DOES NOT EVEN HAVE THAT ROLE INSTALLED, BUT THE SAME THING. BOTH SYSTEMS ARE JUST IN THE WORKGROUP, NOT IN HE DOMAIN.

 

YES I DID.

I HAVE 3 ACCOUNTS WITH ADMINISTRATIVE PRIVILEGES, FROM WHICH ONE OF THEM IS BUILT IN ADMINISTRATOR ACCOUNT. BUT NOWHERE SETTINGS ARE SAVED WHEN IN NORMAL MODE. JUST IN SAFE.

 

I ADDED ADMINISTRATOR ACCOUNT IN EVERY EXISTANT GROUP IN WINDWS (ABOUT 20 OR 30 GROUPS).



#8 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:02:44 AM

Posted 17 November 2014 - 07:26 PM

Almost sounds like something silly as read permissions on ntuser.dat but not write permissions on ntuser.dat!

What else do people think it is?



#9 SYOB SYOT

SYOB SYOT
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 29 November 2014 - 08:44 PM

HAY,

I CHECKED THAT.

IT SAYS "FULL CONTROL" FOR SYSTEM ACCOUNT. (FULL CONTROL IMPLIFIES READ, WRITE, EXECUTE, AND ALL OTHER PERMISIONS).

SO IT IS NOT THAT. :/



#10 Kirbyofdeath

Kirbyofdeath

  • Members
  • 459 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Somewhere on Earth
  • Local time:11:44 AM

Posted 01 December 2014 - 11:53 AM

Full Control must be set for "Everyone"

 

Example: 

 

14k9klx.jpg



#11 SYOB SYOT

SYOB SYOT
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 01 December 2014 - 02:39 PM

HAY,

 

NO, IT DID NOT HELPED.

AT LEAST NOT FOR WINDOWS SERVER 2012. I WILL CHECK IT ON WINDOWS 8, AND REPOST BACK WITH RESOULTS.

BUT YOU WERE RIGHT, "EVERYONE" DID NOT HAVE ANY PERMISSIONS ON THAT FILE.



#12 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:02:44 AM

Posted 01 December 2014 - 06:07 PM

The NTUSER.dat system file should never and i mean ever be shared with anyone other than the user which it belongs to and the system account along with computername\administrators account.

This issue seesm to be hanging around and if it where me i would have reinstalled the whole system by now if i hadnt solved it (After i imaged the server just in case)!



#13 SYOB SYOT

SYOB SYOT
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:YUGOSLAVIA
  • Local time:05:44 PM

Posted 04 December 2014 - 10:11 AM

YEA, I THINKS SO TOO. BUT, IT DID NOT COST ME ANYTHING TO TRY IT. AND IT DID NOT HELPED. NO METTER WHO HAS ACCESS TO IT.

I ONLY KNOW THAT TWO ACCOUNTS MUST HAVE ACCESS TO IT: SYSTEM, SO THAT WINDOWS IS ABLE TO EDIT IT AND LOAD MY PROFILE, AND MY OWN, SO THAT I AM ABLE TO MAKE CHANGES TO MY PROFILE. BUT I TRIED THIS WHAT LAST POSTER SUGGESTED, JUST FOR CASE.

 

YES, WELL, NOT INSTALLING IT, JUST REFRESHING IT. THIS WOULD SOLVE THE PROBLEM.

HOWEVER, I AM INTERESTED IN SOLVING IT MYSELF. BECAUSE I DO NOT LIKE APPROACH: "IF IT DOES NOT WORK, RESTART" OR "IF IT DOES NOT WORK, GET A NEW ONE", SINCE I AM ENGENEER. I LIKE FIXING IT MYSELF. (WITH HELP FROM OTHERS, OF COURSE) :)


Edited by SYOB SYOT, 04 December 2014 - 10:11 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users