Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Remote Desktop Windows 7 Pro


  • Please log in to reply
12 replies to this topic

#1 Uselesslight

Uselesslight

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Armstrong, BC
  • Local time:09:08 PM

Posted 29 October 2014 - 08:16 PM

Okay, probably a simple answer to this question, at least I hope.. But I have a PC running Windows 7 Professional that I'm using as a home media server...

The problem is, when I try to RDP into the "server" I am unable to log in unless I hook up a keyboard/mouse/monitor and log in at the "server" itself. After restarting the machine, waiting for upwards of 30 minutes, there is no reply from it.

I'm using a Cat5e cable for my connection and I've disabled my PCI WLAN card from device manager.. I can log in with no issues if I log in at the "server" with a keyboard/mouse/monitor, but not before... I'm wondering why this is, it's horribly inconvenient every time an update installs to drag a monitor out and hook up it and log in and then put the monitor back where it needs to go.

PLEASE HELP ITS DRIVING ME NUTS!!!


Edited by hamluis, 02 November 2014 - 05:03 PM.
Moved from Win 7 to Networking - Hamluis.


BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,239 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:02:08 PM

Posted 29 October 2014 - 10:09 PM

It could be a DNS issue. Does the problem occur if you RDP using the IP address also?



#3 tech@123

tech@123

  • Banned Spammer
  • 25 posts
  • OFFLINE
  •  
  • Local time:09:38 AM

Posted 30 October 2014 - 12:43 AM

I think check your firewall and registry to look if it is expecting RDP connections on a non-standard port.

 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber



#4 technonymous

technonymous

  • Members
  • 2,520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:08 PM

Posted 30 October 2014 - 02:05 AM

By default the registry tcp port is 3389 unless previously changed. However, I do suggest the port be changed if it's going to be opened up to WAN outside world. First thing to do is try connecting locally before trying remotely through the router. It could just be misconfigured on the firewall on the host/server. I also suggest going through this guide to help button up security. http://www.howtogeek.com/175087/how-to-enable-and-secure-remote-desktop-on-windows/ By default Administrators group has RDP access and by having it set to that hackers already know the first part of the authentication process. With a weak password they could get in. It's best to alter the security policies for RDP and remove Administrators groups entirely and specifiy a user only. Furthermore, include a strong password atleast 14 characters long and mix of numbers/letters/upper/lower/special.



#5 Uselesslight

Uselesslight
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Armstrong, BC
  • Local time:09:08 PM

Posted 30 October 2014 - 09:55 PM

Thanks for the tips everyone.

TsVk! - The problem does occur when I try to connect using the IP address and the PC name.

Tech@123 - it is not on a non-standard port. I've checked, it also doesn't really fit because I can log into the server via RDP after I log into it at it's physical location.

Technonymous - The registry port has not been changed, and it also will not be opened up to WAN. Connecting locally (assuming you're meaning on my LAN) is where I am having the issues. I'll read the guide you posted, but I am very aware of network security. I never thought of removing the Administrators group though, good call. It's probably also a good idea to remove the Everyone group as well then I'd guess?

#6 technonymous

technonymous

  • Members
  • 2,520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:08 PM

Posted 31 October 2014 - 06:45 AM

Thanks for the tips everyone.

TsVk! - The problem does occur when I try to connect using the IP address and the PC name.

Tech@123 - it is not on a non-standard port. I've checked, it also doesn't really fit because I can log into the server via RDP after I log into it at it's physical location.

Technonymous - The registry port has not been changed, and it also will not be opened up to WAN. Connecting locally (assuming you're meaning on my LAN) is where I am having the issues. I'll read the guide you posted, but I am very aware of network security. I never thought of removing the Administrators group though, good call. It's probably also a good idea to remove the Everyone group as well then I'd guess?

Yes, it's best to just configure a single user.



#7 Uselesslight

Uselesslight
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Armstrong, BC
  • Local time:09:08 PM

Posted 02 November 2014 - 04:31 PM

Sooo, nobody has any other ideas as to why I can't connect via RDP after the machine restarts? I've checked the ports, although they aren't actually pertinent in this situation because I'm only trying to RDP on my LAN for the time being...

#8 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,239 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:02:08 PM

Posted 02 November 2014 - 04:56 PM

Umm, not here. I don't have such a great knowledge of RDP.

 

What I would do is install a VNC application. Doesn't fix the problem, I know, but will achieve the objective.



#9 technonymous

technonymous

  • Members
  • 2,520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:08 PM

Posted 03 November 2014 - 12:49 AM

Tcp/ip netbios maybe?



#10 Kilroy

Kilroy

  • BC Advisor
  • 3,479 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:10:08 PM

Posted 03 November 2014 - 06:39 AM

Is the machine booting to Windows after you restart it, ie can you access  the files on it outside of RDP?  You might want to check  your BIOS settings on the problem machine and see if there is setting about halt on errors, but you can set it to not stop on errors, it usually has settings for keyboard and monitor.



#11 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:09:08 PM

Posted 03 November 2014 - 11:43 AM

Set the Remote Desktop service to start automatically in services.  You may need to create a service account that is can logon with so as to make the connection active.



#12 Uselesslight

Uselesslight
  • Topic Starter

  • Members
  • 146 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Armstrong, BC
  • Local time:09:08 PM

Posted 08 November 2014 - 06:22 PM

Wand3r3r thank you! OMG that was so obvious hahaha, I should've just checked that service to begin with. Feeling stupid

#13 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,239 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:02:08 PM

Posted 08 November 2014 - 07:18 PM

I facepalmed too, great call Wand3r3r :thumbup2:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users