Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HP Pavilion 23 boot order not changing?


  • Please log in to reply
20 replies to this topic

#1 mystic12

mystic12

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 29 October 2014 - 02:59 PM

Just got this unit, it is showing "Error: No boot disk has been detected or the disk has failed".

I went into the boot order trying to boot of a win7 disk, as this first pic shows

 

http://i493.photobucket.com/albums/rr298/mikehende/20141029_154511_zps66320613.jpg

 

the default is set to UEFI, I move the arrow down to "Legacy Boot Sources" as shown in pic 2 below but when I hit ENTER nothing is happening?

 

 

http://i493.photobucket.com/albums/rr298/mikehende/20141029_154529_zps7319f8e6.jpg



BC AdBot (Login to Remove)

 


m

#2 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 29 October 2014 - 05:56 PM

It's ok, I got it to work but now other problem sheesh. I had thought it was the wireless mouse which was not working but attaching a wired USB mouse is also not working, I am at the Install Windows screen but not seeing a mouse cursor, any ideas please?



#3 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 29 October 2014 - 06:19 PM

Ok, please let me start again, far as I am being told by the owner, this unit came with win7 but he upgraded to win8 and now wants to revert back to win7 after he started getting this error message on boot up: "Error: No boot disk has been detected or the disk has failed". So I am attempting to reload win7 now but seems the wireless mouse which came with it is not working, only the wireless KB works. I just tried a wired KB and that works too but not a wired mouse which I need to make the selection to install windows so that's where I am at right now.



#4 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 05:18 AM

I just tried knoppix, the mouse works fine so I am lost here, any ideas please?



#5 JohnC_21

JohnC_21

  • Members
  • 21,694 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 30 October 2014 - 07:35 AM

If this is the All-in-one, make sure you plug the mouse in the back and not the side. The side USB ports are USB 3.0 and the Windows 7 install disk does not have any drivers for USB 3.0. The four USB ports on the back are USB 2.0 which should work.

#6 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 12:35 PM

That worked [thanks!] but what I am not understanding is why the KB's works in the side slots? Shouldn't it be the same deal as the mouse?

 

Also, next issue I am seeing is every time I start this pc I have to select the boot order all over again, it always reverts back to UEFI, how can I get the boot order to stick?



#7 JohnC_21

JohnC_21

  • Members
  • 21,694 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 30 October 2014 - 12:50 PM

Not sure why the KB was detected in the USB 3.0 slot and the mouse wasn't. I would have thought the same would have been for the KB.

 

I am not that familiar with UEFI on HP. Maybe somebody on the forum can answer the question on that. Is the BIOS set to UEFI and not Legacy or CSM? Under UEFI is there a section called Boot Sources? You might be able to change the order there.

 

Other people seem to have problems with the UEFI. You might want to contact HP support.

 

Edit: Possibly a bad CMOS battery keeping the changes from sticking.


Edited by JohnC_21, 30 October 2014 - 12:52 PM.


#8 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 01:10 PM

There are two places and ways to change the boot order, by pressing F9 at startup and from within the BIOS and it's reverting back to UEFI in both situations



#9 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 01:17 PM

Actually now that win76 is loaded, it is booting straight from the HDD, will test it a few times to see if there are any changes and get back to you, thanks.

 

BTW, I am thinking the reason why only the wireless mouse and KB works in the slide slots should because they are 3.0?



#10 JohnC_21

JohnC_21

  • Members
  • 21,694 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 30 October 2014 - 01:51 PM

Are you talking about after Windows is installed or before? If the USB 3.0 drivers are installed then a USB 2.0 mouse and keyboard should work in the USB 3.0 port as it is backwards compatible with USB 2.0. Before install of Windows 7 I am not sure why the Keyboard worked in the USB 3.0 port.


Edited by JohnC_21, 30 October 2014 - 01:52 PM.


#11 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 01:57 PM

Before windows was installed



#12 JohnC_21

JohnC_21

  • Members
  • 21,694 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 PM

Posted 30 October 2014 - 02:55 PM

Not sure why that would be but in your post #3 you said the Wireless Mouse did not work when installing Windows 7, only the keyboard. Can't say why that is.

#13 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 02:59 PM

No worries, we can't beat ourselves up trying to figure out everything in the pc repair world, next issue are the drivers for this unit, I was able to get the ethernet and network drivers from the HP site here to work:

 

http://h10025.www1.hp.com/ewfrf/wc/softwareCategory?os=4063&lc=en&cc=us&dlc=en&sw_lang=&product=5362...

 

but I could not get the Chipset driver and graphics drivers to work? Also in the device manager these 3 items are yellowed out:

 

PCI Device

SM Bus Controller

Inversal Serial Bus

 

I am going to try the device id's now.



#14 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 05:00 PM

Her's where the problem lies, I just spoke to the owner of this unit, he said this unit originally came with win8 standard and he wants to go with win7 so I am thinking what we need are win7 drivers for the USB and graphics for this machine. He told me if this doesn't work then I can reload win8 but this is now coming back to finding the the proper ISO for win8 standard



#15 mystic12

mystic12
  • Topic Starter

  • Members
  • 1,452 posts
  • OFFLINE
  •  
  • Local time:08:00 PM

Posted 30 October 2014 - 05:21 PM

Well I guess I can try this:

 

http://getintopc.com/softwares/operating-systems/windows-8-core-free-download-iso-32-bit-64-bit/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users