Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with Microsoft Malware Protection Command Line Utility


  • Please log in to reply
3 replies to this topic

#1 Beryla

Beryla

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:18 AM

Posted 25 October 2014 - 10:30 AM

Hi Everybody, Have a 3 month old Inspirion M531R-5535 with windows 8.1. It has run ok until I paid a bill online yesterday. After that things slowed to a crawl. I ran my scanners, mallwarebytes, spyware hunter4. Did not get any redflags. I checked task manage rand found 4 lines of the MpCmdRun local service running with each one eating 25% of my cpu power. I have tried to end tasks but they are unresponsive. Where do I go from here? Everything else seems ok. Please advise. Thanks, Beryla 



BC AdBot (Login to Remove)

 


#2 dicke

dicke

    Paraclete


  • Members
  • 2,189 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:04:18 AM

Posted 25 October 2014 - 07:44 PM

MpCmdRun

mpcmdrun.exe is a process belonging to Microsoft Windows Defender Antispyware 

Using the installation CD I'd try to run a startup repair to see if you can regain control of the system

Keep us posted

 

Dick


Stay well and surf safe [stay protected]

Dick E


#3 Deadbug

Deadbug

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:18 AM

Posted 26 October 2014 - 11:24 AM

I have exactly the same problem since yesterday...have been researching the net to no real avail. The only way I could get this to stop was to rename the windows defender folder. That keeps defender, or whatever is initiating MpCmdRun.exe from finding the executable. The problem with this is that I had already disabled Windows defender as I use IOLO system mechanic pro, which includes System Shield, a great antivirus and anti-malaware program. For some reason, after the folder was renamed, My CPU was not bogged down at 98-99%, but IOLO's Sys Mech and System Shield crashes on startup, leaving no protection...and no protection from windows defender.

Let me say that I wanted to try to just remove or update that MpCmdRun.exe, to make sure it's not a camoflaged malaware, but In spite of many, many attempts to modify the Windows Defender folder and subfolder...I could not successfully change permissions and audit entrys to allow me to make any change.

So, I'm stuck in the mud until others with more expertise can help. Please keep us posted on any successes

#4 Deadbug

Deadbug

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:18 AM

Posted 26 October 2014 - 03:35 PM

Okay,

I was finally able to find something that works, at least for now, to stop this madness. But it does mean you wont have Windows Defender. Not an issue for me as I use another antivirus/antimalaware software.

I gave myself access to the MpCmdRun.exe file, and then simply changed the name (in a way that was obvious) so that it would never run...voila!!! After a reboot...no more problem. Until a better fix is available, This will do just fine for me.

Bill




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users