Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

“CLR initialization failed with error 800700c1.”


  • Please log in to reply
1 reply to this topic

#1 _Adi

_Adi

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 21 October 2014 - 01:41 PM

Hi,

 

  I have Windows 7 running in Parallels Desktop 10 for Mac.

 

Although things have worked in the past, recently, several application will not run and I get the following error:

CLR initialization failed with error 800700c1.

 

This includes chocolatey and powershell..

I couldn't find any solution to this.

Also, when I attempted "Control Panel->Troubleshooting->Fix Problems with Windows Update" I get an error dialog with the exact same code.

I also tried repairing and updating the .NET Framework installation, but to no avail.

More repair attempts:

  • chkdsk: Windows has checked the file system and found no problems.
  • SFC /scannow: Windows Resource Protection did not find any integrity violations. 

I get the same error with another user and also in Safe Mode.

I am truly baffled.

 

Update: I think it is related to the following DLL:C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9alel8e3b_8.0.50727.3053_x-ww_b80fa8ca\MSVCR80.dll. It is apparently corrupted.

When I try to open in in depends it gives an error: "No DOS or PE signature found. This file is not a valid 32-bit or 64-bit Windows module."

 

Please advise,

Adi

Also asked here.


Edited by _Adi, 21 October 2014 - 03:52 PM.


BC AdBot (Login to Remove)

 


m

#2 _Adi

_Adi
  • Topic Starter

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:21 AM

Posted 21 October 2014 - 04:20 PM

SOLVED!

 

I finally got it fixed.

As I suspected, it was related to a (possibly) corrupt 64-bit DLL MSVCR80.DLL.

I uninstalled all the "Microsoft Visual C++ 2005 Redistributable" packages (both 32 and 64 bit) via the regular uninstall screen from the Control Panel - I had 3 such packages.
After this, everything returned to working order.


Edited by _Adi, 21 October 2014 - 04:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users