Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Computer Not Enabling Wireless Adapter


  • Please log in to reply
26 replies to this topic

#1 Chaney

Chaney

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 09:28 PM

We've had this laptop for a couple years, no problems. It's a Toshiba laptop, Windows 7. 

My mother disabled the wireless adapter for some reason and now it won't enable again. Every time we try, it says the connection failed. I've tried the turn-it-off-and-back-on thing, but nothing changes. The minute I log on it searches for wireless networks and then says that none can be found (it has the little red x). It's been this way for four days.

I know I need to enable the adapter but it just won't let me.

Do you guys know what to do, because I'm at a loss.


Edited by Chaney, 11 October 2014 - 09:31 PM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,238 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:09:54 PM

Posted 11 October 2014 - 09:37 PM

Hello, and Welcome

 

First make sure your wireless switch on the laptop is set to on. What is the model number of the Toshiba?

 

Follow the steps here to enable your wireless adapter.

 

If the above does not work, do you have any yellow exclamation marks in Device Manager next to your wireless adapter?



#3 Chaney

Chaney
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 09:52 PM

The wireless switch is on. The model number is PSK0GU - 01Q021

I went to the link and followed the steps. It says Enabling... Connection Failed. 

The wireless adapter does not have a yellow excalmation mark in the Device Manager. However, the account I am on is not the administrator, and I haven't been able to log onto the administrator account in a while because it gives me an error message. The administrator password works when it asks for it though, so I haven't seen a reason to bother with it. 

I tried enabling it through Device Manager and I put in the admin password, but nothing happens. No error message - It just closes and doesn't do anything.



#4 JohnC_21

JohnC_21

  • Members
  • 23,238 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:09:54 PM

Posted 11 October 2014 - 10:11 PM

What is the error message when logging into the administrator account? Can you connect to the internet by using an Ethernet cable?

#5 Chaney

Chaney
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 10:15 PM

We only have a wi-fi hotspot, no router to connect to. 

The error message says "The User Profile Service service failed the logon. User profile cannot be loaded." and then it goes back to the log in screen.



#6 JohnC_21

JohnC_21

  • Members
  • 23,238 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:09:54 PM

Posted 11 October 2014 - 10:31 PM

It seems your adminstrator account is corrupted.  Perhaps that is why you cannot get connected.

 

You cannot add another administrator account because the account you are on now is not administrator.

 

Type CMD into the search box. Right click and select Run as Administrator

 

Type at the command prompt

net user administrator /active:yes <enter>

Log out of the account. You should see a new account called administrator. Log into that account and try to enable the network adapter in Device Manager or by the link I posted.



#7 Chaney

Chaney
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 10:41 PM

When I tried to run as administrator it gave me an error message saying "Windows cannot find 'C:\Windows\System32\cmd.exe'. Make sure you typed the name correctly, and then try again." 

I clicked on it when I wasn't an administrator and it was fine. 

:unsure: This is really not looking good. 

(Also, thank you for your help. You've been very kind and informative!)



#8 JohnC_21

JohnC_21

  • Members
  • 23,238 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:09:54 PM

Posted 11 October 2014 - 10:48 PM

If you go to that path C:\Windows\System32 do you see cmd.exe?

 

Does it allow you to get a command promt without using Right Click Run as Administrator?



#9 Chaney

Chaney
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 10:49 PM

Yes, I do, and yes, it does.



#10 JohnC_21

JohnC_21

  • Members
  • 23,238 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:09:54 PM

Posted 11 October 2014 - 10:58 PM

If you go to cmd.exe in C:\Windows\System32 and right click Run as Admininstrator, it gives the same error? The file cannot be found?



#11 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,001 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:09:54 PM

Posted 11 October 2014 - 10:59 PM

Chaney, Hi &  :welcome:   to BC Forums!

 

Just by chance I have a Windows 7 powered Toshiba, this is what regained my wireless. The direct link to the forum is having issues at the moment, but I found it elsewhere. 

 

The solution that solved my issue was this (I'm copy/pasting to save time). 

 

Go to the folder on your c drive "Program files\Toshiba\TBS. Then scroll down the list of program files and double click on the file named TBSWireless.exe and hey presto, the wireless communication will turn on (Amber Light will come on on the front bottom right panel of the computer). From now on the FN-F8 Key combination will turn it on and of.

 

Hope this will solve your issue also.  :)

 

Best of Luck,

Cat


Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 


#12 Chaney

Chaney
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 11:00 PM

Yes, it gives the same error whether or not I open it or if I don't. 



#13 Chaney

Chaney
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:08:54 PM

Posted 11 October 2014 - 11:03 PM

Chaney, Hi &  :welcome:   to BC Forums!

 

Just by chance I have a Windows 7 powered Toshiba, this is what regained my wireless. The direct link to the forum is having issues at the moment, but I found it elsewhere. 

 

The solution that solved my issue was this (I'm copy/pasting to save time). 

 

Go to the folder on your c drive "Program files\Toshiba\TBS. Then scroll down the list of program files and double click on the file named TBSWireless.exe and hey presto, the wireless communication will turn on (Amber Light will come on on the front bottom right panel of the computer). From now on the FN-F8 Key combination will turn it on and of.

 

Hope this will solve your issue also.  :)

 

Best of Luck,

Cat

Tried this right now, did not work. I already tried the FN-F8 key combo before when turning on the wireless. Thank you, though.



#14 JohnC_21

JohnC_21

  • Members
  • 23,238 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:09:54 PM

Posted 11 October 2014 - 11:05 PM

I would follow cat1092's advice. I am signing off. It's getting kind of late here. Good Luck. I will follow up tomorrow.



#15 cat1092

cat1092

    Bleeping Cat


  • BC Advisor
  • 7,001 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:North Carolina, USA
  • Local time:09:54 PM

Posted 11 October 2014 - 11:19 PM

Actually the solution I provided was to get the keyboard shortcut working again. It was also by chance today, on the same computer, on Windows 8.1, the wireless wouldn't work. Had to download the driver from the Intel site. 

 

What is your wireless card model? Many Toshiba's that shipped with Windows 7 also had a WiMax connection. It appears that we need to download & re-install the driver. The Toshiba ones are rather dated now, if Intel branded, has been 2-3 releases since. 

 

The Device Manager isn't correct 100% of the time, sometimes like us, it's not perfect. It'll say the driver is installed & OK & it isn't. I battled this for 30-45 minutes earlier today. What I don't understand, is that this happens from time to time. Should we find a solution, you may wish to bookmark it for future reference. 

 

Please post back with your wireless card details & I'll try to find something.  :thumbup2:

 

Cat


Edited by cat1092, 11 October 2014 - 11:49 PM.

Performing full disc images weekly and keeping important data off of the 'C' drive as generated can be the best defence against Malware/Ransomware attacks, as well as a wide range of other issues. 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users