Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Chrome font problem displaying all web pages


  • Please log in to reply
9 replies to this topic

#1 anonanon

anonanon

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 11 October 2014 - 07:51 PM

I am using a PC running Windows XP (SP3) and Chrome version 38.0.2125.101.

 

For a few months now, Google Chrome displays text in a hard to read way.  The problem is the spacing between letters, e.g. a bigger space after every "w" right now; not sure if the problem is stable (sometimes the "e"s get jammed next to whatever letter they're next to.

 

The problem is NOT unsharp rendering of fonts.

 

I have tried:  changing the font settings; updating Chrome; restoring all the settings to the default settings; enabling or disabling DirectWrite.  None of them affect the problem.

 

Oddly, no matter what I do, all text is displayed in Arial.  That's true even if I change the font setting to use Times New Roman for standard, serif, and sans-serif text.

 

Thanks for ideas,

Roger



BC AdBot (Login to Remove)

 


#2 anonanon

anonanon
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 18 October 2014 - 12:31 PM

It's been a week and no replies.  Does anyone have any ideas?

 

Roger



#3 TulsaRose

TulsaRose

  • Members
  • 367 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Tulsa OK
  • Local time:03:17 AM

Posted 19 October 2014 - 05:02 AM

Hi Roger, I don't know if I have the answer but I'll attempt to help you out.  Is Chrome your default browswer?

 

When you have tried to make changes to the font settings, are you going through the Chrome Settings \ Web Content section?  After making the changes, do you close-out the browser?  It seems like some settings won't take effect until Chrome is restarted.

 

I wonder if DirectWrite  is the problem since your OS is WinXP ?

 

Quote from DirectWrite:

 

Run-time requirements
  • Windows 7 or Windows Vista with Service Pack 2 (SP2) and Platform Update for Windows Vista
  • Windows Server 2008 R2 or Windows Server 2008 with Service Pack 2 (SP2) and Platform Update for Windows Server 2008

WinXP Pro sp3 \ Firefox, Panda, MBAM, SAS, SpywareBlaster


#4 anonanon

anonanon
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 19 October 2014 - 02:02 PM

Thanks for writing.

 

Chrome is not the default browser now.  But to see if that made any difference, I made it the default browser.  Same font issues.

 

Yes, I used Chrome Setting | Advanced Settings | Web Content | Customize Fonts to try to change the fonts.  It didn't change the fonts (everything is showing in a sans serif font that could be Arial) and it didn't fix the font display problem.

 

I had disabled DirectWrite (in chrome//flags) to see if that would help.  It made no difference.  I just re-enabled it.  That also makes no difference.

 

Oddly, the font problem varies over time.  E.g., sometimes there's extra space after every "m" and every "e" is jammed next to the letter before it. Not now; now there's extra space after every "r".

 

Any ideas?

 

Roger



#5 TulsaRose

TulsaRose

  • Members
  • 367 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Tulsa OK
  • Local time:03:17 AM

Posted 20 October 2014 - 06:43 AM

Hey Roger...just spent an hour stumbling through Chrome Help...what a nightmare. lol!  Seems the font problem began with the v.37 update but supposedly was cured with the release of v.38.  Read several references to disabling the DirectWrite add-on...in some cases, it conflicts with Windows settings.  There were also many suggestions about changing zoom value from 100% to 125%.  And, of course, the old standby, be sure to delete browser history, etc.

 

I have all Chrome font settings for Arial, Zoom is 110%, DirectWrite Disabled.  I've never had a font rendering problem so I am at a loss in finding a solution to help you.  It seems to be directly related to a Display problem of some sort.  

 

Have you checked \ changed any DPI settings in Windows?  Maybe that's the culprit?  Mine is set to Normal Size (DPI 96)

(Control Panel \ Display \ Settings \ Advanced) 

 

Have a great day!


WinXP Pro sp3 \ Firefox, Panda, MBAM, SAS, SpywareBlaster


#6 anonanon

anonanon
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 20 October 2014 - 07:50 AM

TulsaRose,

 

Thanks for looking.  My font problem began before v. 37 and continues even though I have v. 38.  I do have a custom DPI setting in Windows, so maybe that's the source of the problem.

 

Good news -- Changing the zoom setting to 125% or 110%, with history deleted afterwards (which I hadn't thought to do after each setting experiment in the past), does the trick for most websites.  Chess.com is somewhat resistant, for some reason, but I can live with that.  I don't do much reading there anyway!  The news sites nytimes.com, etc. now display correctly.  For some reason, changing the zoom causes those sites to go from Arial to the Times font that I had chosen in Customize Fonts.  Chrome is strange, I guess in interaction with Windows XP's DPI settings.

 

In my case, 125% zoom and DirectWrite enabled produces the best results.

 

Thanks again for your help.

 

Roger



#7 TulsaRose

TulsaRose

  • Members
  • 367 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Tulsa OK
  • Local time:03:17 AM

Posted 20 October 2014 - 10:56 AM

Glad to hear your "challenge" is mostly worked out.  I enjoyed helping. :)


WinXP Pro sp3 \ Firefox, Panda, MBAM, SAS, SpywareBlaster


#8 anonanon

anonanon
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 21 October 2014 - 08:34 PM

Thanks.  I'm just having the last word so this thread shows up as not active in my profile. ;)



#9 yvrao

yvrao

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:17 AM

Posted 26 October 2014 - 12:21 PM

Windows Registry editing fixed the font thickness issue for me completely, 
we can tune the font thickness/darkness by calibrating  FONTSMOOTHINGGAMMA  value to 
between 150 and 190 hexadecimal( 336 to 400 decimal )
 
  -   START  ->  RUN  ->  REGEDIT
  -   search for  FONTSMOOTHINGGAMMA   by  keying  "Ctrl F"
       ( will automatically take us to  CurrentUser\ControlPanel\Desktop  path)
  -   right-click mouse on  FONTSMOOTHINGGAMMA on the rightside, Modify... enter any 
      thing between 150 and 190 hexadecimal.
        (the Lower the value, the thicker the fonts.)
  -   close the REGEDIT tool
  -   LOGOFF and then LOGON
 
Now all the fonts are very thick & very dark in Chrome Browser.
 
But we must make sure that ClearType smoothing is enabled in Windows
( controlPanel  ->  personalization  ->  appearance
          ->   Effects  ->  ClearType smooth check (ticked box) )
 
                         OR  alternately in RegEdit ...
 
             FONTSMOOTHING=2
             FONTSMOOTHINGTYPE=2
             FONTSMOOTHINGORIENTATION=1  for LCD-screen,  0 for CRT-screen
 


#10 anonanon

anonanon
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:17 AM

Posted 26 October 2014 - 03:10 PM

yvrao,

 

Thanks.  That did make the font thicker on the pages that I was still having trouble on (e.g., chess.com).  It's good to be able to adjust the font thickness.

 

But it didn't change the problem of weird spacing between characters on those pages -- e.g., after every "r" there is extra space right now.

 

Roger






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users