Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Vista Repair


  • Please log in to reply
2 replies to this topic

#1 vadesigner

vadesigner

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:57 AM

Posted 11 October 2014 - 03:40 PM

Well, I seem to have really done it this time...

 

Background: I have a split" drive.  :/C & :/D.  I used to be set up so that C and D were completely mirrored.  This was "disconnected" a while ago.  Now :/C is where all my program files, etc. are stored.  D is just extra.

 

The Problem:  I was trying to speed up my machine... went through a host of things, including uninstalling some programs.  Perhaps I uninstalled somethign I shouldn't have.

 

Now, none of my office programs (Outlook, excel, etc.) work... when I click to launch, I get "Windows Installer not working." 

 

I read that I needed to repair Vista. Pulled out the disc, inserted and rebooted. It walked me through a process to install the OS (didn't see anything about repairing it.)  Since I did not have enough room on the :/C drive, I figured I'd just try it on the :/D.  Now C & D are switched, and I don't see any of my programs in the Start Up menu. And ALL my settings have been lost.

 

How do I go back to the previous configuration? Then what do I do to repair the windows installer?



BC AdBot (Login to Remove)

 


#2 vadesigner

vadesigner
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:57 AM

Posted 13 October 2014 - 11:53 AM

Since this is a partitioned drive - in theory, I should simply be able to make my c partition the active partition once again, and will have at least gone back to my original set up.

 

Will I lose data switching back to the other partition?



#3 roamincandl

roamincandl

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:57 AM

Posted 24 November 2014 - 11:38 PM

Technet article about disekpart :   http://technet.microsoft.com/en-us/library/cc766465%28v=ws.10%29.aspx

 

You could try running diskpart from the command prompt and select disk 0. Then list partition, and select the appropriate partition for the original install. Then enter active, and you should be back to an active C: drive with your original install.

   The link below is a standalone installer for windows installer 4.5 , which hopefully does not require a working windows installer to function as it is an executable file.

 

 

http://www.microsoft.com/en-us/download/details.aspx?id=8483






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users