Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ubuntu and Firefox Pending Crash Reports


  • Please log in to reply
3 replies to this topic

#1 JohnC_21

JohnC_21

  • Members
  • 21,637 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:16 PM

Posted 10 October 2014 - 08:05 AM

Has anybody figured out a way to stop Pending Crash Reports from generating in Firefox? I checked the option in Firefox to not send Crash Reports but unless I clean them out after each session, these Pending Crash Reports can get into the GB's. Open the your home folder, press Ctrl+h to unhide the files. Mozilla > Firefox > Crash Reports > Pending. I even added a line in Crashreporter.ini and set Enable to 0 and they still are generated.

BC AdBot (Login to Remove)

 


m

#2 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:16 PM

Posted 10 October 2014 - 08:21 AM

If I recall correctly, type about:config into your url, then it was either breakpad, or data health reporting service that could be disabled or deleted. I wish I was in front of my linux box. Also I was/am running an older version of ubuntu and firefox. Maybe this has changed.

 

Or maybe I did this:

 

Can I disable Crash Reporter?

Mozilla Crash Reporter is enabled by default and there is no user interface to disable it. Advanced users who prefer the standard application error notifications (e.g., the Windows error dialog "<application> has encountered a problem and needs to close" and Event Viewer record) can disable the Mozilla Crash Reporter by adding a system environment variable named MOZ_CRASHREPORTER_DISABLE and setting its value to 1

 

http://kb.mozillazine.org/Breakpad#Can_I_disable_Crash_Reporter.3F

 

 

This: http://techdows.com/2010/01/disabling-mozilla-crash-reporter-in.html was reported working as of Sep 14, it should be similar in linux.

 

It was so long ago I don't remember exactly what I did :(


Edited by zingo156, 10 October 2014 - 08:36 AM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#3 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:16 PM

Posted 10 October 2014 - 08:30 AM

I started up a virtual box ubuntu and I believe the new version in the about:config url you can change the datareporting.healthreport.service.enabled value to false.

 

Any changes you make, write down so you can reverse them. I just know it was something I changed there, I am not sure if I renamed it so it didn't work or if I just disabled it (I am not a big fan of deleting which is why I choose to rename most of the time). I may have had to add a new string there as well. Google didn't help much on this topic unfortunately.


Edited by zingo156, 10 October 2014 - 08:31 AM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#4 JohnC_21

JohnC_21
  • Topic Starter

  • Members
  • 21,637 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:16 PM

Posted 10 October 2014 - 08:43 AM

Thanks for those links zingo156. I changed the application.ini file and healthreport setting. I will see how it goes.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users