Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 8.1 startup


  • Please log in to reply
1 reply to this topic

#1 gmccarty

gmccarty

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:43 PM

Posted 01 October 2014 - 10:00 PM

I'm working on a windows 8.1 computer that had a virus that apparently attacked the boot record.  It restarts in a loop unable to find Windows. I created a Windows 8.1 repair disk on a different computer, and booted to the USB drive.  I tried the automatic repair but it would work.  I also tried running refresh but it said the drive was "locked" (what does that mean?!).  Finally I opened a repair console, and ran the following commands:

 

bootrec /FixMbr

bootrec /FixBoot

bootrec /RebuildBcd

 

If I leave the USB repair drive unplugged the computer continues to restart in a loop the same as before; however, now when the USB repair drive is plugged in and I tell the bios to boot to the USB drive it will actually boot into Windows 8.1!

 

I cleaned the virus (I think?!) and everything appears to be working well. 

 

Any idea how I can get the computer to boot normally without the USB repair disk?

 

I can re-install from scratch but I would like to avoid that process if possible.  I have a Windows 8.0 install DVD; however, apparently the repair function will not work since the computer has been upgraded to 8.1.

 

Thanks!  Gabriel

 

 



BC AdBot (Login to Remove)

 


m

#2 rockysosua

rockysosua

  • Members
  • 772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Caribbean
  • Local time:03:43 PM

Posted 01 October 2014 - 10:10 PM

It appears that you have written the MBR to the USB drive and now, you'd need to repeat the operation, making sure that you specify the correct disk and partition, to write the MBR to the correct location.

Once you get to the command prompt, perhaps you could remove the USB drive and not run the risk of re-writing the MBR to the wrong location.


All is well in Paradise.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users