Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Drive has CD Drive and Removable Disk Partitions


  • Please log in to reply
7 replies to this topic

#1 VistaBob

VistaBob

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:42 AM

Posted 30 September 2014 - 06:48 PM

I have a USB Drive I got at Wells Fargo bank several years ago. When I plug it in, I get a CD Drive (E:) and a Removable Disk (G:). The G disk is about 481 MB and the E drive is 8 MB, so this is old technology. On the E drive are 4 read only files, 2 of which are also hidden files. One of the files is 'autorun.inf'. How do I get rid of the CD Drive (E:) and the 4 files from Wells Fargo, so I can use the disk without their marketing garbage ruining my day? I'm using Vista.

Edit: Moved topic from Windows Vista to the more appropriate forum.~ Animal

BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,281 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:42 AM

Posted 30 September 2014 - 06:57 PM

Hello, and Welcome

 

I had this exact same problem with a WD passport drive. When attached it creates a virtual CD drive. Unfortunately for me this was in firmware and even when I wiped the drive it would still appear. The only way I could get rid of it was delete any files on the drive related to the Software then disabled it in Device Manager. Look through Device Manager under CD drives and look for the virtual drive. Then right click and select disable. Reboot the computer. Now when you attach the USB drive, the virtual CD drive will not appear. The only downside to this is that you have to do it to each computer you attach the drive to.



#3 VistaBob

VistaBob
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:42 AM

Posted 30 September 2014 - 07:08 PM

Thanks. I want to use it to transport small amounts of stuff, so buying a new drive might be my best option. Otherwise, I would run into the same problem on each computer I move to. The main reason for doing this is that I wanted to transport some records to my doctor and I wanted there to be no question in his mind that it wasn't a clean usb drive. It definitely looks suspicious when it comes up with an autorun and you get a cd rom drive you weren't expecting. Sometimes these marketers at banks defeat there purpose.



#4 JohnC_21

JohnC_21

  • Members
  • 23,281 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:42 AM

Posted 30 September 2014 - 07:15 PM

It is possible the virtual CD on the drive is not built into firmware but is on a separate partition. What happens when you delete the autorun.inf file? When you look at the external drive in Disk Management does it show more than one partition?

 

Edit: From your title it does have more than one partition. If that is the case you can try wiping the disk with Partition Wizard zeros quick fill and then partition and format the drive. If the virtual CD still opens when attached then it is in firmware and you cannot do anything other than disable it.


Edited by JohnC_21, 30 September 2014 - 07:54 PM.


#5 VistaBob

VistaBob
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:42 AM

Posted 30 September 2014 - 10:11 PM

I haven't been able to delete any of the files. I can't remove the read only nor the hidden attributes.

 

When I used Diskpart and did 'list disk', the removable showed as disk 2. When I did 'list volume', the CD drive was volume 1 and the Removable was Volume 4. When I did 'select disk 2' and 'list part' I get only 1 partition. I'm assuming that if the CD drive was implemented as a partition that I would see 2 partitions. When I do a 'detail volume' it says that Read-only is no. But when I do a 'format' I get the messages: "Virtual Disk Service error:/The media is write protected."

 

I think it has to be firmware. I can't seem to override the attributes or the write to the CD drive. If I could tell the system it is not a CD Drive, I might get a bit further.



#6 JohnC_21

JohnC_21

  • Members
  • 23,281 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:42 AM

Posted 30 September 2014 - 10:41 PM

After this explaination, I agree it is in the firmware just like mine. Now when I look for an external drive, I make sure it doesn't have this extra virtual CD firmware. If you are going to only transfer small amounts of data, you may want to look at a USB flash drive. You can get USB 16GB drives for fairly cheap now.



#7 riddle143

riddle143

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:42 AM

Posted 07 December 2015 - 05:22 AM

Realizing I'm a bit late to the party here, I had this same problem with a 2GB flash drive I picked up for free. After careful examination using the DISKPART tool I discovered that the E:/ CD drive attached to my flash drive was written as an attached volume formatted using CDFS, which limits what DOS tools can do considerably. However going through the options of DISKPART there is an argument for the "clean" command that removed this for me. The argument all, typed as such "clean all", wipes *all* bit values on the drive; resetting those values to zero. After running this command the volume disappeared for good. I've decided to add a step by step guide here below, in case anyone else stumbles across this thread

  • Press "Start" + R.
  • Type "cmd.exe", hit enter
  • In the new window, type "diskpart", hit enter
  • In the new window, type "list disk", find your flash drive in the list.
    IMPORTANT: Make sure the drive you find is in fact your flash drive, match drive letter, match size, match formatting, you do not want to wipe the wrong drive
  • Type, "select disk i" (replace i with your flash drive's disk number)
    IMPORTANT: Make sure the drive you find is in fact your flash drive, match drive letter, match size, match formatting, you do not want to wipe the wrong drive
  • Type "clean all", wait (This can take some time, my 2GB drive took about 30 minutes) Once finished, DISKPART will print a message confirming success
  • Remove the flash drive, then reinsert
  • Repeat steps 4 & 5.
  • Type "create partition primary", this is immediate.
  • At this point, you need to format the drive, "format fs=ntfs quick" will do the trick if you want to use DISKPART and want an NTFS drive, FAT32 is default, so "format quick" would yield a fat32 drive.  

Hope this helps somebody.



#8 VistaBob

VistaBob
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:12:42 AM

Posted 26 December 2015 - 12:58 AM

Thanks for posting this solution, Riddle143. I finally got around to trying it.

 

It didn't work, unfortunately. That darn CD drive (which shows up my computer as E:) is still there with 4 files that can't be erased.

 

I guess that means it is in the "firmware."

 

The time it took your Clean All to run on a 2G drive seems pretty high: While mine is only a 1/2 G drive, the Clean All returned in under 3 minutes.

 

I can still use the thumb drive to move data around, it is just kind of a nuisance because sometimes the auto file gets invoked. As long as I only use the data part of the drive, which in my case shows up as G:, it is fine. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users