Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot access shared files


  • Please log in to reply
6 replies to this topic

#1 Gregavi

Gregavi

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:04:46 AM

Posted 28 September 2014 - 03:23 PM

Hi, I have 3 computers setup in one network (HOMEGROUP). They are:

Office running Windows 7 Home Premium 64 bit Service Pack 1
Laptop running Windows 7 Home Premium 64 bit 
Server running Vista Business 32 bit Service Pack 2

All 3 are in my "HOMEGROUP" Network.

I can access shared files on "Laptop" from "Server" and vise-versa. I cannot access shared files on "Office" computer from "Laptop" or "Server". It says "Windows Cannot Access XXX". I can access files on the "Laptop" and the "Server" from the "Office" computer. I have turned off "Password Protected Sharing" on the "Office" computer. 

I turned off "Windows Firewall" and the result allowed me to access files on the "Office" computer from "Laptop" but not from "Server". I turned the firewall back on and I can still access shared files on "Office", but still not from "Server"

The "Office" Computer is the computer that I set up the original network and I joined the network on the 2 others. I'm not sure if that matters.

I use a networked Popcorn Hour (Media Player) that can access shared files on "Laptop" and "Server" but not ones on "Office". 

Any help appreciated. 

Thanks in advance.


Edited by Chris Cosgrove, 28 September 2014 - 05:47 PM.
Moved to 'Networking'


BC AdBot (Login to Remove)

 


m

#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:46 AM

Posted 28 September 2014 - 08:22 PM

Make sure file sharing is enabled on all the computers, and that the folders are all shared as well. In addition, check the file permissions as well. Right click on one of the files and select Properties. Under the Securities tab, make sure you have the proper users selected in Group or user names, and that your users have permissions to view these files.



#3 Gregavi

Gregavi
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:04:46 AM

Posted 28 September 2014 - 09:21 PM

I have all shared files set full permission full access. If that was the problem, I don't believe I would have access to the shared folders from my Win7 Laptop, as I now have. The only devices that I do not have access to these shared folders on my Win7 "Office" computer is from my Vista Machine (Server) and my Popcorn Hour. Every other scenario works.



#4 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:46 AM

Posted 28 September 2014 - 10:20 PM

Part of the issue appears to be that you've created a homegroup. Because two of the machines run Windows 7, and one runs Vista, Microsoft recommends you need to create a workgroup and place all those computers in the workgroup. http://windows.microsoft.com/en-us/windows/networking-home-computers-running-different-windows#networking-home-computers-running-different-windows=windows-7

 

You should also doublecheck the folder sharing and file permissions for the files on the Server Vista machine, and check to make sure the user profile you are using on Office exists on Server and has the same username and password. Try turning password protected sharing off on Server as well.



#5 Gregavi

Gregavi
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:04:46 AM

Posted 29 September 2014 - 12:07 AM

My bad. All 3 of my computers are in my "WORKGROUP" network.



#6 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:46 AM

Posted 29 September 2014 - 01:11 AM

Which computer's firewall did you turn off and back on?

If you scroll down to the bottom the page of the link I provided earlier, there are directions on making sure the proper firewall ports are open and the proper settings are in place. It will be a bit time consuming, but it could be a firewall setting that is blocking access.



#7 Gregavi

Gregavi
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Local time:04:46 AM

Posted 29 September 2014 - 11:20 AM

Which computer's firewall did you turn off and back on?

 

If you scroll down to the bottom the page of the link I provided earlier, there are directions on making sure the proper firewall ports are open and the proper settings are in place. It will be a bit time consuming, but it could be a firewall setting that is blocking access.

 

The "Office" computer running Win7. I also tried turning off the firewall of the "Server" computer running Vista. Neither solved the problem. 

 

I did read the firewall section of that page but disregarded it because I use windows firewall and it states: "If  you're using Windows Firewall, you can skip this section, because Windows Firewall automatically opens the correct ports for file and printer sharing when you share something or turn on network discovery.

 

Is it possible that there is some other second party firewall running that I'm unaware of? If so, how would I check?

 

Thanks


Edited by Gregavi, 29 September 2014 - 12:14 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users