Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

request timeout when pinging 2 computers


  • Please log in to reply
10 replies to this topic

#1 batman1

batman1

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:57 PM

Posted 27 September 2014 - 02:31 PM

hi there

 

I have an hp compaq 6200 pro mt, i5

i have a d-link dsl-2750u router

i am connected via adsl wired.

the router is 20cm from both my pc's

i am running windows 7 ultimate 64 on both pc's

 

now i only have a 4 port wireless router...........there is no switch nor other modems.........which i think is not necessary to connect 2 computers and to the internet.

 

so what i have done is i plugged the cat5 cable from the one pc behind one of the ports of the router

then did the same with the other pc behind the router on the second port.

now there is 1 cable from the one pc to the router

and another cable from the second pc to the router

the phone line from router to rj11 plug.

 

i went into the ipv4 properties and entered a manual ip address, 192.168.1.4

obtained dns automatically

 

did the same on the second computer but ip address , 192.168.1.5

obtained dns automatically

 

both computers can connect to the internet but cannot seem to communicate with each other.

 

when i ping the 192.168.1.5 then i get a ...........request timeout..........

i disabled both firewalls on each computer with same result

when i ping 192.168.1.4 then i get a ................request timeout

i even increased the length of the ping with the -w command but still same problem.

 

i checked everything like the nic's in system is working fine.

restarted pc, router...............

 

i can say that i could ping both computers just for a short time but then do not know what happened after that as i did not change anything.

 

what do i do? or what could be causing the problem?

thanks again....



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,233 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:57 PM

Posted 28 September 2014 - 08:51 PM

Windows 7 is configured by default to block incoming ping requests. You have to create a custom firewall rule enable them to respond.

Control Panel>System and Security>Windows Firewall>Advanced settings>Inbound rules>New rule>Custom rule. Detailed directions are here. I would recommend you scope it only for local IP addresses. http://www.sysprobs.com/enable-ping-reply-windows-7

 

If you have your firewall configured to allowing ping packets through, it could be your antivirus that is blocking those pings -- McAfee in particular has been known to block these.



#3 batman1

batman1
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:57 PM

Posted 29 September 2014 - 03:17 AM

hi

 

i have tried your steps and even disabled the windows firewall as well as any antivirus software....... 

what i have tried is then just to use Homegroup, with the firewall on as well as the anti virus i am now able to see both computers and share files, printer etc.

 

although it works now only via Homegroup as now i am assigned an ip address automatically as well as a dns automatically.

i am still curious as to why i cannot assign an ip address manually as well as the preferred dns .

 

could it be that the router is already assigning the ip address and dns automatically, 

and since i have chose to assign the ip and dns manually......could that cause a conflict with DHCP?

 

or would it have accepted the manual ip address and dns had i had a switch as well?

 

just to clarify im only using a wireless router and nothing else......and connecting both computers to the 4 ports behind the router of course only 2 ports is being used....

 

thanks for your answers though and any other replies.



#4 sflatechguy

sflatechguy

  • BC Advisor
  • 2,233 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:57 PM

Posted 29 September 2014 - 05:25 AM

If the preferred DNS being set by the router on your computers is outside your Local Area Network, you won't be able to ping computers on your LAN. You would need to set the IP addresses manually, and set the DNS server on your computers to the address of your default gateway, making sure the default gateway is pointing to DNS servers somewhere on the Internet.

 

If you've set your IP manually on the computers, leaving DHCP on shouldn't create a problem if there are no other devices on your network. Turning it off wouldn't hurt. It's possible the router itself is blocking internal ping packets. Check the configuration on the router.

 

If all you want to do is share files and printers between devices on your LAN, you can enable those features without having to ping each computer on your network. That feature isn't necessary to get those services to work internally.



#5 batman1

batman1
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:57 PM

Posted 29 September 2014 - 06:19 AM

thanks again much appreciated..........and just lastly i am playing around with my router just to check something.....so what i am trying to see is regarding dhcp just using the one computer, the other computer is off. what i have done is to turn off dhcp on my router interface......what i was expecting is that i would not be able to connect to the internet as i did not specify any manual ip address or dns address. i also checked in properties under ipv4 and the box is still tick to obtain ip automatically and dns automatically.......the question is if my dhcp is turned off on my router then how am i able to browse the internet if the job of the dhcp was to issue an ip address and dns address ?but its turned off.........

 

just something i am pondering

thanks



#6 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:57 PM

Posted 29 September 2014 - 07:46 AM

when you say you could ping then it stopped what does that mean? Why do you want DHCP off for your lan? You are connected to a switch, that is what the 4 ports are on the back of the router.


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#7 batman1

batman1
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:57 PM

Posted 29 September 2014 - 08:57 AM

well i did have an ip address manually entered and a dns address manually entered and that was my default gateway address i manually entered for the preferred dns.........i did so for both computers 192.168.1.4 first computer and 192.168.1.5 for second computer . and the preferred dns on both computers was the default gateway address i entered 10.0.0.2

 

now when i pinged from the 1 computer to the next it first worked then when i pinged again , it said that dhcp is not enable.....

then when i pinged the first computer from second computer , it worked at first then after it said request timed out.

 

later pinging both computers, reveived request time out message.

 

so how i resolved the issue was just to create a homegroup, but when i check in the ipv4 settings/properties , it showed that i was now obtaining my ip address and dns address automatically.......... which i wanted to do manually but request timed out.

 

 

the issue with turning my dhcp off on the router was just to check what was going to happen now with the one computer connected.

i would assume turning the dhcp off would not make me able to browse the internet as how am i receiving an ip address but i am still connected and browsing even though my dhcp is turned off........i wonder why?



#8 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:57 PM

Posted 29 September 2014 - 10:29 AM

Turn DHCP back on. Set them both to obtain IP and DNS automatically. Let the router do what it's supposed to do and it'll all work out =)


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#9 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:02:57 PM

Posted 29 September 2014 - 11:11 AM

Batman1 why do you think you need a 192.168.x.x network for file sharing? 

 

Let's see a ipconfig /all from each pc so we can see where you are at concerning ip addressing.



#10 batman1

batman1
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:57 PM

Posted 29 September 2014 - 12:34 PM

well i was just playing around and am trying to instead of doing everything automatic, i wanted to setup the network manually by entering ip addresses myself........

well the network is working now but its only working as i chose to obtain an ip address automatically and a dns address automatically.

and why i chose the 192.168 address is due to it being an address i can use for private networks..............



#11 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:02:57 PM

Posted 29 September 2014 - 02:03 PM

It was apparent from your post #7 that you are unfamiliar with tcp/ip addressing since you were trying to use 192.168.1.x subnet when your gateway was 10.0.0.2

As a rule of thumb the gateway has to be in the same subnet as the hosts which was not the case in this configuration and that is why it didn't work.

 

There are three private ip subnets available.  You are already using one with the 10.0.0.x subnet.  The other is 172.16.x.x

http://whatismyipaddress.com/private-ip

 

What you wanted to do is use ips in the 10x network like 10.0.0.4 and 10.0.0.5

Then your static assignments would have worked.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users