Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HP Deskjet D2460 Installation Issue - Windows 8.1


  • Please log in to reply
1 reply to this topic

#1 Ocelot14

Ocelot14

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:11:32 AM

Posted 13 September 2014 - 02:04 PM

Hi all,

 

I have had a HP Deskjet D2460 printer for a number of months and it has worked fine. After not using it for a number of months, it is now not listed in my printer list, and so I can't print to it.

 

I am running Windows 8.1 (64-bit), and the last time I used the printer was before the 8.1 update when I was running Windows 8, so I suspect this may be part of the problem.

 

I have tried seeking advice from the official HP support forum, but nothing that they have advised has worked.

 

Here is a summary of what I have tried (and that hasn't resolved the issue) so far:

  • Uninstalling and re-installing the drivers obtained via HP website
  • Using the HP Print and Scan Doctor to resolve the issue
  • Checking the USB connection
  • Turning off everything in the Terminate and Stay Resident (TSR) programs software group, as advised by HP
  • Performing a 'clean boot' and then re-installing the driver software
On each installation occasions, the installer appears to run fine, it detects the printer, and goes all the way through to completion, stating that the printer has successfully been installed.
 
Below are a selection of screenshots that will hopefully provide some insight:
 
2ag2m4i.png
jpajdd.png
 
I did some research on the installation status code above, and Microsoft website says the following:
 

3758096966 (0xE0000246) Device Installer Not Ready

Cause

A class installer or a co-installer for a device cannot run because a component on which it depends did not run.

 
Below is what the Print dialog box shows, even though the printer is listed in Control Panel and Device Manager:
 
5kk9z4.png
 

Please help!



BC AdBot (Login to Remove)

 


m

#2 Ocelot14

Ocelot14
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:11:32 AM

Posted 19 September 2014 - 12:02 PM

Managed to solve it thankfully. Turned up there was an issue with the Printer Spooler service not being automatically enabled.

 

Thanks anyway.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users