Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

UAC Not Accepting Administrator Password


  • Please log in to reply
14 replies to this topic

#1 djchaise

djchaise

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 12 September 2014 - 12:54 PM

There is a user in my office running Windows 7 Pro 64-bit. Her account is an admin account (the only account other than the given admin) but when prompted by User Account Control to enter an "admin user name and password" it does not accept her password. I either get "Logon failure:unknown username or bad password" or "requested action requires elevation".

 

Because of this, she can't complete any task where UAC is required (certain installs, updates, etc.) and I obviously can't turn off UAC either because it won't accept the un/pw. Is there a simple fix for this? I'm fairly computer illiterate. Any help would be greatly appreciated!

 

 



BC AdBot (Login to Remove)

 


m

#2 hamluis

hamluis

    Moderator


  • Moderator
  • 54,853 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:36 PM

Posted 12 September 2014 - 12:57 PM

Worth a read, IMO.

 

Louis



#3 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 12 September 2014 - 01:05 PM

Thanks Louis. Gave this a shot but was once again prompted by UAC before I could go any further to take ownership. 



#4 JohnC_21

JohnC_21

  • Members
  • 21,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:36 PM

Posted 12 September 2014 - 03:16 PM

See step 5 here.  Because you have Pro, you can use secpol  Disable Prompt for credentials on both admin and standard user. This would be done on the other admin account.

 

5%20secpol%20policy.jpg


Edited by JohnC_21, 12 September 2014 - 03:20 PM.


#5 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 12 September 2014 - 04:04 PM

I think I was wrong about her account being an Admin account. It looks like she is just a standard user with some admin privileges.  @JohnC_21 Would I need to activate the "hidden" admin first and then complete the secpol task? Thanks!



#6 JohnC_21

JohnC_21

  • Members
  • 21,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:36 PM

Posted 12 September 2014 - 04:16 PM

If she is a standard user than the user name/password would be those of the admin account. No, if you have another admin account on the computer, you do not have to enable the hidden admin account. Type secpol.msc in the search box and Right Click run as Administrator. Just use secpol and change the Prompt for credentials on the Standard user as shown in the above picture. No need to disable the admin account prompt unless you want to.

 

Edit: If it already shows as disabled, you may have to edit the registry key shown in the link I posted.


Edited by JohnC_21, 12 September 2014 - 04:17 PM.


#7 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 12 September 2014 - 04:25 PM

There is no other admin account on the computer (other than the one that is built-in Windows 7). I thought she was an admin because she's a part of the Administrators "Group", but when I tried to reach access some systems in Computer Management logged in as her, an error message popped up saying I was denied access because I was only a standard user. That's how I deduced that she was a standard user. So I guess my point is, there's only one account on the machine, other than the built-in admin and guest accounts, and I'm not really sure if it's an admin or standard user. Sorry for the convoluted response!

So that being said, my only option is to try and make changes from the current account (unless I enable the hidden Admin account)



#8 JohnC_21

JohnC_21

  • Members
  • 21,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:36 PM

Posted 12 September 2014 - 04:29 PM

Yes, you can enable the hidden account. Press F8 at startup. Open a command prompt using Safe Mode with Command prompt. Then at the command prompt type

net user administrator /active:yes

Reboot and login to the Administrator account.

I am not sure how it changed like this where a user name and password were required on a standard user account. Did you try using a blank user name and password? Does that work.



#9 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 12 September 2014 - 05:40 PM

Tried leaving it blank, no luck. Tried running that command you gave me in safe mode; attached are the two error messages I got.

Attached Files



#10 JohnC_21

JohnC_21

  • Members
  • 21,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:36 PM

Posted 12 September 2014 - 06:07 PM

Another way to activate the hidden account is to use a bootable disk. See this guide.

 

Only enable the administrator account. Do not reset any passwords. You can burn the iso file by right clicking it in Windows 7 and select burn image.

 

Once the administrator account is enabled then try secpol.



#11 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 16 September 2014 - 10:28 AM

Ok good news, Admin account enable and I got to secpol! The previous instructions regarding secpol seem to be for setting a prompt for UAC, not disabling one. My only options for standard accounts are to either automatically deny elevation or to prompt. I want the standard user to be able to install without any prompts.



#12 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 16 September 2014 - 10:32 AM

scratch that, I was able to bypass. THANK YOU!!!



#13 JohnC_21

JohnC_21

  • Members
  • 21,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:36 PM

Posted 16 September 2014 - 10:49 AM

Glad you got it sorted. How were you able to accomplish it? Did you disable UAC in the standard user account? I would recommend you hide the Administrator account again but first create a normal admin account if you have not done so. The hidden Administrator account is like a super user. After creating an admin account, open a CMD prompt > Right click run as Administrator and type

net user administrator /active:no


#14 djchaise

djchaise
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:36 PM

Posted 16 September 2014 - 11:11 AM

No I changed the standard account to an Admin account (which is what I really wanted all along). Then I changed the UAC policies to only "prompt for consent" when programs ask to elevate.  I didn't mind the UAC being enabled so long as the user didn't have to type a password each time. 

I will in fact disable the admin account. 



#15 JohnC_21

JohnC_21

  • Members
  • 21,655 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:36 PM

Posted 16 September 2014 - 11:15 AM

Okay, thanks for the clarification. Have a nice day.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users