Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Malware Bytes suddenly very slow to load on start-up - Holding everything up!


  • Please log in to reply
5 replies to this topic

#1 widewheels

widewheels

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:05:51 AM

Posted 10 September 2014 - 05:50 AM

Hello

 

This is my first post. It is an issue that I have read about on-line but without a solution so I was hoping that someone could assist me via the forum.

 

I run a custom built desktop: Win 7 Ultimate with a brand new Samsung SSD, ESET Smart Security and Malwarebytes Premium running in tandom. This has been my set up for 4 years or more without concern. Until now...

 

Yesterday evening I returned from work, turned on my desktop and I ran a threat scan. (Please note that this was the first ever threat scan with rook kit enabled since the installation of the SSD on Monday evening). Almost at the end of the Heuristic (last) part of the threat scan I got a BSOD. I restarted the PC and Malwarebytes failed to load at all at startup (no icon in tray, attempted manual load and nothing).

 

Prior to this (Monday, Tuesday and Wednesday since installation of the new SSD), MWB loaded instantly at start-up, a split-second before my connection status icon came 'on-line' - From Windows welcome screen to all programs loaded it used to take 5 seconds, it now takes around 40 seconds due to Malware Bytes holding everything up.

 

I uninstalled MWB using the clean.exe then re-installed it. I restarted the PC and MWB loaded this time but very very slowly. My network connection status icon also takes a lot longer to activate. The network connection is almost waiting for MWB to load. I ran another threat scan with rook kit scanning NOT activated and the scan completed fine this time.

 

Why is MWB suddenly taking so long to load at startup? It is literally an issue which began ever since the BSOD during a threat scan last night. I also run ESET and have set exclusions correctly in both MWB and ESET. Prior to the BSOD and subsequent re-install of MWB I noticed that upon startup, MWB and my internet connection would start up instantly, (MWB first, then a split-second afterwards I would be on-line) with all my other programs. The slow startup only began happening since the re-install of MWB. Why is this? It is very annoying.

 

Any help would be greatly appreciated.

 

Thanks !



BC AdBot (Login to Remove)

 


m

#2 quietman7

quietman7

    Bleepin' Janitor


  • Global Moderator
  • 50,606 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Virginia, USA
  • Local time:11:51 PM

Posted 10 September 2014 - 08:41 AM

A couple years ago I had a similar startup issue with ESET and Malwarebytes and used Winpatrol to delay it's startup. See Tools To Delay Program(s) At Startup. That seemed to work but later I since switched to Emsisoft Anti-Malware and now just manually start Malwarebytes before connecting to the net. Since this set up works well for my system I have left it alone.

You can delay Malwarebytes' startup through it's GUI if you are experiencing bootup problems. Launch Malwarebytes, click on Settings > Advanced Settings. There is a check box to Delay Protection at startup for xx number of seconds. You may need to experiment to find which delay time works best for your system.

MBAMAntiRootkit is now integrated into the scanner (under Detection Settings) in MBAM v2.0 but it is not enabled by default. If "Scan for rootkits" is enabled, this will add to the length of the average scan time from previous versions and sometimes causes the scanner to stall (hang).

If you want a more specific reason for what is going on then the Malwarebytes development team will need to investigate. They recommend you start a new topic in the Malwarebytes Anti-Malware Help Forum and report the problem there.
.
.
Windows Insider MVP 2017-2018
Microsoft MVP Reconnect 2016
Microsoft MVP Consumer Security 2007-2015 kO7xOZh.gif
Member of UNITE, Unified Network of Instructors and Trusted Eliminators

If I have been helpful & you'd like to consider a donation, click 38WxTfO.gif

#3 widewheels

widewheels
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:05:51 AM

Posted 10 September 2014 - 08:56 AM

The strange thing is that on Monday MBAM loaded at start-up in lightening speed (following SSD install). My desktop was up and running within 5/6 seconds and I thought, great! the SSD installed cleanly, everything working well. Then I tried the threat scan with root kit > BSOD > Un-install MBAM > Re-install MBAM > Scan now completes but MBAM at start up loads very slowly. Desktop now up and running within 45 seconds instead of the 5 or 6 seconds 1 day ago.

 

Basically, my PC worked perfectly prior to the SSD install (MBAM and ESET worked really well together) now I have the SSD, MBAM is playing up.

 

Please advise.

 

Cheers !



#4 quietman7

quietman7

    Bleepin' Janitor


  • Global Moderator
  • 50,606 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Virginia, USA
  • Local time:11:51 PM

Posted 10 September 2014 - 09:01 AM

To determine specifically what is going on, the development team will need to take a closer look at your system and investigate so you need to ask there. If one of the Staff or Honorary Members ask you to run some "Diagnostic Logs", please refer to this topic and post the logs in your original Malwarebytes topic, not here.
.
.
Windows Insider MVP 2017-2018
Microsoft MVP Reconnect 2016
Microsoft MVP Consumer Security 2007-2015 kO7xOZh.gif
Member of UNITE, Unified Network of Instructors and Trusted Eliminators

If I have been helpful & you'd like to consider a donation, click 38WxTfO.gif

#5 Scoop8

Scoop8

  • Members
  • 326 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas TX
  • Local time:10:51 PM

Posted 11 September 2014 - 07:38 AM

quietman7, thanks for that link (tools delaying startup).

 

I'm still running MBAM Pro but have been reading up on the Premium version and noticed that "delay startup" option in the Premium version.  I was glad to see they added that option in the new version.

 

I'm running a script file in my Win startup folder to delay my Pro version's startup but it's a crude script :lol:  . I've been looking for a utility that can delay items at startup.



#6 quietman7

quietman7

    Bleepin' Janitor


  • Global Moderator
  • 50,606 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Virginia, USA
  • Local time:11:51 PM

Posted 11 September 2014 - 08:14 AM

You're welcome Scoop8.
.
.
Windows Insider MVP 2017-2018
Microsoft MVP Reconnect 2016
Microsoft MVP Consumer Security 2007-2015 kO7xOZh.gif
Member of UNITE, Unified Network of Instructors and Trusted Eliminators

If I have been helpful & you'd like to consider a donation, click 38WxTfO.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users