Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Command.com Chkdsk not allowed


  • This topic is locked This topic is locked
17 replies to this topic

#1 Guest_PhoenixRisen_*

Guest_PhoenixRisen_*

  • Guests
  • OFFLINE
  •  

Posted 09 September 2014 - 10:34 PM

I may be nearing my breaking point. I ran Command.com. This prompt appeared in the beloved old window that everything ran from at one time.:

 

c:\users\\master>

 

I typed CHKDSK and the following message was returned:

 

Access denied as you do not have sufficient privileges. You have to invoke this utility in elevated mode.

 

Say what? This is my Bleeping Computer denying me access that I used to have until these problems started months ago. Not quite on my 19th nervous breakdown, but I will get there soon if this keeps up.

 

 

message-in-sand-help-stra-417291.jpg



BC AdBot (Login to Remove)

 


m

#2 rockysosua

rockysosua

  • Members
  • 772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Caribbean

Posted 10 September 2014 - 12:05 AM

Did you type in chkdsk in a command window with Admin rights?

chkdsk /r C:

You can copy and paste that text and then hit Enter.


All is well in Paradise.

#3 Guest_PhoenixRisen_*

Guest_PhoenixRisen_*

  • Guests
  • OFFLINE
  •  

Posted 10 September 2014 - 06:54 AM

Did you type in chkdsk in a command window with Admin rights?

chkdsk /r C:

You can copy and paste that text and then hit Enter.

Since the day I bought this computer I had sole and exclusive Admin rights. I did type in a command window opened by typing Command.com in the run box, lower left corner of the screen. I will try your advice. Thank you, rocky.

 

Just now tried. Same result.


Edited by PhoenixRisen, 10 September 2014 - 06:55 AM.


#4 jonuk76

jonuk76

  • Members
  • 2,095 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:08:31 PM

Posted 10 September 2014 - 07:19 AM

Command.com is going back a bit :)  It's cmd.exe on Windows NT based systems.  Anyway, you need to run the command prompt with administrator rights for chkdsk to work.  This is the cause of the error you are seeing.

 

There are several ways of doing it.

 

In Windows 8.1 Desktop Mode

 

Right Click the Windows logo ("Start" button) in the bottom left of the screen and choose "Command Prompt (Admin)" from the menu that opens up

 

Otherwise

 

Press Windows Key + Q to open the Search Charm

Search for Command Prompt

Right click the first result and choose "Run as administrator"


7sbvuf-6.png


#5 Guest_PhoenixRisen_*

Guest_PhoenixRisen_*

  • Guests
  • OFFLINE
  •  

Posted 10 September 2014 - 08:04 AM

Command.com is going back a bit :)  It's cmd.exe on Windows NT based systems.  Anyway, you need to run the command prompt with administrator rights for chkdsk to work.  This is the cause of the error you are seeing.

 

There are several ways of doing it.

 

In Windows 8.1 Desktop Mode

 

Right Click the Windows logo ("Start" button) in the bottom left of the screen and choose "Command Prompt (Admin)" from the menu that opens up

 

Otherwise

 

Press Windows Key + Q to open the Search Charm

Search for Command Prompt

Right click the first result and choose "Run as administrator"

Thank you jon. We are getting closer maybe. New message:

 

Microsoft Windows [Version 6.2.9200]

<c> 2012 Microsoft Corporation. All rights reserved.

 

C:\windows\system32>chkdsk /r C:

The type of the file system is NTFS.

Cannot lock current drive.

 

Chkdsk cannot run because the volume is in use by another

process. Would you like to schedule this volume to be

checked the next time the system restarts? <Y/N>

 

I will wait online until I get a response from you at this point.



#6 rockysosua

rockysosua

  • Members
  • 772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Caribbean

Posted 10 September 2014 - 08:06 AM

Hit Y for yes, then Enter, then reboot the machine for the diskcheck to begin.


All is well in Paradise.

#7 jonuk76

jonuk76

  • Members
  • 2,095 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:12:31 AM

Posted 10 September 2014 - 08:08 AM

That message is because you are using the /r switch (fixes any file system errors and performs a surface scan for bad sectors) which cannot be done on a system drive while it is in use by Windows.

 

If you want to perform a full check like this then you reply "Y" and it will be scheduled for the next restart.  These checks take a few hours to run generally.

 

If you just want to do a quick file system check then reply "N" and just run chkdsk without the /r switch which runs it in read only mode. No restart required for read only mode.  But it will only identify and not fix errors.


Edited by jonuk76, 10 September 2014 - 08:10 AM.

7sbvuf-6.png


#8 Guest_PhoenixRisen_*

Guest_PhoenixRisen_*

  • Guests
  • OFFLINE
  •  

Posted 10 September 2014 - 08:37 AM

That message is because you are using the /r switch (fixes any file system errors and performs a surface scan for bad sectors) which cannot be done on a system drive while it is in use by Windows.

 

If you want to perform a full check like this then you reply "Y" and it will be scheduled for the next restart.  These checks take a few hours to run generally.

 

If you just want to do a quick file system check then reply "N" and just run chkdsk without the /r switch which runs it in read only mode. No restart required for read only mode.  But it will only identify and not fix errors.

Thank you. It is running now in read only mode. It is now done and is not too terribly long. I will recreate it here:

 

Chkdsk cannot run because the volume is in use by another process. would you like to schedule this volume to be

checked the next time the system restarts? <Y/N> n and I got this:   

 

C:\windows\system32>chkdsk C:

The type of the file system is NTFS.

Volume label is OS.

WARNING!  F parameter not specified.

Running CHKDSK in read-only mode.

 

CHKDSK is verifying files <stage 1 of 3>...

    338944 file records processed.

File verification completed.

     7733 large file records processed.

     0 bad file records processed.

 

CHKDSK is verifying files <stage 2 of 3>...

    428908 index entries processed.

Index verification completed.

     7733 large file records processed.

     0 unindexed files scanned.

     0 unindexed files recovered.

 

CHKDSK is verifying security descriptors <stage 3 of 3>...

Security descriptor verification completed.

    44893 data files processed

CHKDSK is verifying Usn Journal...

    36357456 USN bytes processed.

Usn Journal verification completed.

 

Windows has scanned the file system and found no problems.

No further action is required.

 

961723391 KB total disk space.

130156932 KB in 249827 files.

      152620 KB in 44984 indexes.

                0 KB in bad sectors.

      671936 KB in use by the system.

        65536 KB occupied by the log file.

830741876 KB available on disk.

 

          4096 bytes in each allocation unit.

240430847 total allocation units on disk.

207685469 allocation units available on disk.

 

C:\windows\system32>



#9 jonuk76

jonuk76

  • Members
  • 2,095 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Wales, UK

Posted 10 September 2014 - 09:21 AM

That's good :thumbup2:   It looks normal and no errors were found.


7sbvuf-6.png


#10 rockysosua

rockysosua

  • Members
  • 772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Caribbean
  • Local time:08:31 PM

Posted 10 September 2014 - 12:06 PM

You forgot to type in some of the parameters, which is why it was read only and that it went through 3 stages only.

That's why you got this in the report.
 

WARNING!  F parameter not specified.

Running CHKDSK in read-only mode.

 

F or r are virtually identical. F stands for fix and R stands foir repair.

What you did had no repair capacities whatsoever.

 

You'll need to do it over again and this time put in the exact text as follows.

chkdsk /r c:


All is well in Paradise.

#11 Guest_PhoenixRisen_*

Guest_PhoenixRisen_*

  • Guests
  • OFFLINE
  •  

Posted 10 September 2014 - 12:17 PM

You forgot to type in some of the parameters, which is why it was read only and that it went through 3 stages only.

That's why you got this in the report.
 

WARNING!  F parameter not specified.

Running CHKDSK in read-only mode.

 

F or r are virtually identical. F stands for fix and R stands foir repair.

What you did had no repair capacities whatsoever.

 

You'll need to do it over again and this time put in the exact text as follows.

chkdsk /r c:

 

 

Access denied as you do not have sufficient privileges. You have to invoke this utility in elevated mode.  :radioactive: 



#12 rockysosua

rockysosua

  • Members
  • 772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Caribbean
  • Local time:12:31 AM

Posted 10 September 2014 - 01:03 PM

 

Access denied as you do not have sufficient privileges. You have to invoke this utility in elevated mode.  :radioactive: 

 

That is why we keep mentioning to open the command window with Admin rights.

Open the charms bar and type "command" into the search bar.

You will see "Command Prompt" appear below. Right click on it and hit "run as administrator".

Then it will all work fine.


All is well in Paradise.

#13 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,042 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.

Posted 10 September 2014 - 03:39 PM

Here's a much simpler way to open the Elevated Command Prompt.

 

Press the Windows key and the X key at the same time.  A menu will open, choose Command prompt (Admin).  You must be using an administrator account to do this.


Edited by dc3, 10 September 2014 - 03:39 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#14 rockysosua

rockysosua

  • Members
  • 772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Caribbean
  • Local time:12:31 AM

Posted 10 September 2014 - 05:11 PM

Here's a much simpler way to open the Elevated Command Prompt.

 

Press the Windows key and the X key at the same time.  A menu will open, choose Command prompt (Admin).  You must be using an administrator account to do this.

Nice shortcut DC3.

Thanks.

It appears that if I had given those instructions several posts ago, the OP wouldn't have had such a hard time getting the job done.

I'll know next time. Thanks again.


All is well in Paradise.

#15 Guest_PhoenixRisen_*

Guest_PhoenixRisen_*

  • Guests
  • OFFLINE
  •  

Posted 11 September 2014 - 05:47 PM

I have been quite busy with house issues and am almost there with the CHKDSK issue. I will post a couple of scree shots and follow up as I can. My schedule through the 16th of September looks insane. I will drop by to report as I am able. I am glad I took the time to search out the best forum for technical support, and a lot of just plain good people too. Every one of you deserve applause.

 

:clapping:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users