Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop screen display issue / split


  • Please log in to reply
4 replies to this topic

#1 moosefist

moosefist

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:08:47 AM

Posted 07 September 2014 - 01:52 PM

I am trying to figure out what could be wrong with my laptop screen. Here is what it looks like http://imgur.com/aYaHco8

The LCD was recently replaced. I had this immediately after replacing, but only on boot and not in windows. I replaced the old screen with the dead pixels and it did the same thing as the new screen. Now i have the issue present in the OS as well. I began troubleshooting and accidentally shorted the motherboard. Now I've replaced the motherboard and the LCD cable, but unfortunately the problem persists.

Is this sort of problem indicative of a particular issue? GPU, LCD, connections?

BC AdBot (Login to Remove)

 


#2 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:02:47 AM

Posted 08 September 2014 - 11:17 AM

The text is also reversed in some cases. Very, very weird.

 

What is the make and model of the laptop?

 

Have you also replaced the power inverter for the screen?


Edited by Netghost56, 08 September 2014 - 11:19 AM.


#3 moosefist

moosefist
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:08:47 AM

Posted 08 September 2014 - 12:19 PM

Its a dell xps 15z. The screen is a 1080p specifically: Generic 15.6 LCD Laptop Screen 1920x1080 WXGA++ HD LED DIODE B156HW03 v.0 for DELL XPS 15Z https://www.amazon.com/dp/B00JKAW68K/ref=cm_sw_r_awd_brEdub1T2T6HY

I tested the HDMI out and it works flawlessly. I don't assume the two cables I've tried are identically bunk. I've reached out to the seller of the LCD panel. I'm assuming it is DOA.
I'm am not sue what you are referring to with the power inverter.

#4 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:02:47 AM

Posted 08 September 2014 - 12:23 PM

nb-ACER_53159_Inverter.jpg

 

That's a power inverter. Most laptops have them. It may be stuck to the bottom of the screen case, or near the top of the laptop case, above the Function keys inside the case.



#5 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:47 AM

Posted 08 September 2014 - 12:51 PM

This is an led lit panel, it will not have an inverter.

 

My best guess is either somehow you still have a bad panel, bad cable, or bad board, beacuse the hdmi out is fine, I doubt it is an issue with the board but it is possible. I have had bad cables that were "new" actually I once had 3 in a row that had issues. Generally if the cable is the issue, you can wiggle the cable (carefully you don't want to disconnect either end when the computer is on and running), and you should see some kind of change in the behavior of the screen.

 

Also it should be said, ALWAYS disconnect the battery and the power adapter from the laptop before disconnecting the cable from the led panel or the mainboard, they are very easy to short out and destroy the board nearly instantly if they short.


Edited by zingo156, 08 September 2014 - 12:59 PM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users