Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Major Issue with laptop trackpad.


  • Please log in to reply
No replies to this topic

#1 bal53

bal53

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:37 PM

Posted 30 August 2014 - 04:12 PM

Hi,

 

I'm experiencing a strange problem with my trackpad. Although It is shown as installed under Programs and Features, it is absent from the Device Manager. I don't know how it can be possible but that's the reality. Alongwith that, I'm also unable to use the trackpad right now.

 

A little bit of history about this issue: Initially, in response to touch, the cursor started moving erratically. After sometime, it began to lock and unlock on its own. Sometimes even the left-click and right-click buttons also became unresponsive. Thinking of it as a driver issue, I unistalled and then reinstalled the trackpad drivers. After that everything seemed to work fine but that was not going to be for long. The problem appeared once again and this time, the cursor started moving and clicking on its own as well.

 

Suspecting some malware or something like that to be responsible for this, I decided to scan with Kaspersky Internet Security which was (and is) already installed on my system but it failed to detect anything. Thereafter I tried multiple security softwares like Eset, Malwarebytes, Trend Micro, F-Secure, Super Anti-Spyware, and some others as well but to no effect. I even scanned in safe mode but strangely, got the same problem in safe mode as well and no detection of any sort. Not to mention that both my Windows 7 and KIS 2015 are fully patched and updated.

 

But it was not going to stop at there and all of a sudden, the trackpad went completely dead. By dead I mean completely dead i.e. no response to touch, and neither the function key for trackpad nor the two buttons worked. I opened the device manager to see if I can find anything there and, to my utter surprise, there was no entry by the name of "Mice and Other Pointing Devices", under which my Dell trackpad drivers used to be visible. It meant that either the trackpad drivers were still on my system but device manager was unable to detect them, or that they were not on my system and that's why device manager was not showing them. I've also tried to install the previous versions of my Dell trackpad drivers, just in case the latest ones are faulty, but to no effect.

 

Despite all this, Dell Touhpad is still shown under Programs And Features as installed. I'm pretty much sure that this is a software issue and not a hardware one as a couple of times the keyboard also became unresponsive at the same time when the trackpad got jammed. Is there anything that I can do to test where the problem lies i.e. on the hardware or the software side? Or anything else that I should do to provide you with more info about this issue? I'm not a geek but can definitely understand the technicality of computer working. My english might not be that good so please excuse me for that. Any type of help would be highly appreciated so please feel free to express your views.

 

Dell Inspiron 5520 laptop

Windows 7 64-bit OS

8 GB RAM

500 GB HDD

Synaptics Elantech Touchpad Drivers

 

Thank You.


Edited by bal53, 31 August 2014 - 02:16 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users