Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB 2.0 Switch not recognising on Dell Precision 690


  • Please log in to reply
2 replies to this topic

#1 HughHill

HughHill

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:49 AM

Posted 26 August 2014 - 08:57 PM

I am trying to help my friend out he and his wife share an office they have a USB 2.0 Switch for sharing the printer but its not recognising not recognising on the Dell Precision 690 wont load a driver.

However on his wives much newer dell home system Desktop PC it recognises the switch and accepts the drivers.

there are no manufacturers details on the device so I opened it up hoping to find something I have included photos just in case anyone may recognise who made it or where I can locate relevant drivers for it.

Before anyone tells me to do a google search I just want to say that I have and it turned up nada.

I would like to think that I am at a good to an advanced level and hope that I can help others while here.

 

 

in the pictures you may not see the writing on the ICB but here it is -

 

On the integrated circuit board  at the top there are two usb 2  printer usb female connectors below them two green led lights in-between those is a black switch button. To the left side of the button the left light is a plastic orange cover with the letters 'EA2-5NU then NEC Japan then some numbers 'SD1244F' on the other-side of the circuit board in the bottom left corner the letteres "UHS210 04/12/20    ver 1.1    SA0111  1336"
 
(it say's that I am not allowed to use the image extension so I will just have to share a link instead. if you click the right arrow in the picture is should take you to the next there are 6 in total 
 
 
 
 
 
 
Thank you
 
 
Hugh


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,918 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:49 AM

Posted 27 August 2014 - 07:51 AM

The device is plugnplay so you will not find any drivers for it.

 

Try using one of the other USB ports on the computer. If that does not work download USBdview and delete any vendor specific drivers for things like USB flash drives except any devices required such as any USB network adaptors.  Sometimes a driver already installed will conflict with another. Cleaning out the drivers may let the computer detect the device. After deleting, reboot and then attach the switch.'

 

usbdeview.gif



#3 HughHill

HughHill
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:49 AM

Posted 27 August 2014 - 02:49 PM

Thank you JohnC_21

 

 

I will give it a go next time I go round to see him.

 

 

 

"thought I'd mention that it does give the found new item bell when first attached only to then be followed by the driver failed to load sound."

 

 

Best

 

Hugh






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users