Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

laptop plugged in not charging


  • Please log in to reply
2 replies to this topic

#1 vash2275

vash2275

  • Members
  • 30 posts
  • OFFLINE
  •  
  • Local time:05:51 AM

Posted 26 August 2014 - 01:50 PM

I have a toshiba satellite c655-s52006 and the laptop will not charge the battery despite being plugged in. I have tried new batteries and chargers but, neither of those are the problem and I have tried  unplugging the power cable, then removing the battery holding the power button for 30 seconds and then turning the laptop back over, plugging in the power cord, and trying to boot.  That did not work either.  Any ideas what the problem could be? I know it has to be an internal problem.  Thanks for any help or suggestions.



BC AdBot (Login to Remove)

 


#2 rotor123

rotor123

  • Moderator
  • 8,093 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:05:51 AM

Posted 26 August 2014 - 02:41 PM

Hi

There is a possibility that the cable between the DC in Jack and the Motherboard has gone bad.

 

      When You look at Yours does the end where the AC Adapter plugs in look OK like the example above and is it pushed into the laptop? These have a groove on them that keeps them where they should be. The Jack being pushed in was a common problem for a while. What would happen is that the ears on the jack would break off. I replaced a fair amount of these under warranty and off warranty in the past.

 

I would call tech support at Toshiba and see if they have extended the warranty for this problem. I have seen that happen in the past.

 

I searched Google using this as the search c655-s52006 DC in jack

 

Good Luck

Roger


Fortune Cookie says: Fortune not Found: Abort, Retry, Ignore?

Sent from my All-In-One Desktop. Perfect for Internet, Not for heavy usage or gaming however.

How Does a computer get Infected? http://www.bleepingcomputer.com/forums/t/2520/how-did-i-get-infected/
Forum Rules,    The BC Welcome Guide

167 @ June 2015


#3 Kilroy

Kilroy

  • BC Advisor
  • 3,442 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:04:51 AM

Posted 26 August 2014 - 02:49 PM

It could be an issue with the charging port.  If you have a docking station you could try charging on the docking station.

 

Other than that there may be an internal board that has failed.  Either way, this is above the skill level of the average user.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users