Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

.NET Framework 3.5 will not install on my Win 8.1 machine


  • This topic is locked This topic is locked
4 replies to this topic

#1 tb39

tb39

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:05:51 PM

Posted 23 August 2014 - 09:32 PM

Good day all,
 
Have not logged in here in some time.
 
Since I have been able to get answers here for other problems, thought I would give it a try here.
 
Apologies for the long post.  I want to give you as much detail as possible.
 
On 8.16.2014 I did a fresh install of Windows 8 on my PC.  I bought a new motherboard, CPU & memory and since I like to do a fresh install of everything on occasion, I thought I would do it then.  Installation was a breeze and I was up and running in a very short time.
 
Installation of most of the programs I use went off without an issue either until I came to The Sims 3 (one of the few games I like to play).  I was able to install the base game even though I got a message from Windows Features:
 
An app on your PC needs the following Windows feature: .NET framework 3.5 (includes .NET 2.0 & 3.0)
The two options are to Downloand and install this feature or Skip this installation.  So I select Download and install this feature.  This way Windows will get the files it needs from Windows update and complete the installation.  Not so in my case... It searches and attempts to download the needed files and it comes back with the follwoing message:  The following feature couldn't be insalled: .NET framework 3.5 (includes .NET 2.0 & 3.0).  Windows could not connect to the internet to download the necessary files.  Make sure you're connected to the internet, and click "Retry" to try again. Error code 0x800F0906  Needless to say... but I am connected to the internet.
 
I then decide to do some research and try many suggested methods form Microsoft and other sites.  First and foremost most suggest going into Windows Features and adding it that way by checking the .NET framework 3.5 box.  That did not work.  I end up with the same messages as above.  Another suggestion is to open an elevated command prompt and type the following: DISM  /Online  /Enable-Feature  /FeatureName:NetFx3  /All  /LimitAccess  /Source:x:\sources\sxs.  I obviously had to change the source drive from X to whatever my optical drive letter was.  In this case it was Y. The process gets to 66.5% and falters with the following message: Error: 0x800f081f - The source files could not be found. Use the "source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see   I also tried copying the sources\sxs folder to a local drive (in this case G) and it came up with the same error in the elevated command prompt.
 
I have also tried some solutions from forums and youtube videos and all have been unsuccessful.  All involve some offline way to get it installed but when the command prompt window opens and it runs the same DISM command I tried, the result is the same.  It stalls at 66.5% with the same message as above.
 
I tried uninstalling my 3rd party antivirus / firewall program (iolo System Mechanic) and disabling windows Defender and Firewall thinking that might help but it did not either.
 
I thought the last thing I tried was absolutely hilarious... I was able to locate the 231 megabyte .NET 3.5 installer package and when I tried executing it, it opens up the Windows Features window with the following message: 
An app on your PC needs the following Windows feature: .NET framework 3.5 (includes .NET 2.0 & 3.0). So, I need .NET framework 3.5 to install .NET framework 3.5. I don't even know what to say to that????
 
I have contacted MS support on a couple of occasions and have been unsuccessful on both occasions. They pointed me to several forums and liinks and nothing has worked. All they want to do is charge me to get it fixed... and that is not happening.  This seems like an easy thing to do but it has turned into a nightmare for me and many hours of lost time.
 
I think that about covers most of it.  I have included a couple of pictures and logs to assit. If you need any other type of log or such, please let me know.
 
Thank you


I got the full 231 megabyte installer package from MS.  This package I had not come across.
 
Just tried to get the x64 package since I have the 64 bit version of Win 8 and received this message:
The update is not applicable to your computer.

Attached Files


Edited by Queen-Evie, 24 August 2014 - 09:22 AM.
Moved from Win 8 to Malware Removal Logs - Hamluis.


BC AdBot (Login to Remove)

 


m

#2 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,550 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:51 PM

Posted 28 August 2014 - 09:35 PM

Hello and welcome to Bleeping Computer!

I am HelpBot: an automated program designed to help the Bleeping Computer Staff better assist you! This message contains very important information, so please read through all of it before doing anything.

We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help. No one is ignored here.

To help Bleeping Computer better assist you please perform the following steps:

***************************************************

step1.gif In order to continue receiving help at BleepingComputer.com, YOU MUST tell me if you still need help or if your issue has already been resolved on your own or through another resource! To tell me this, please click on the following link and follow the instructions there.

CLICK THIS LINK >>> http://www.bleepingcomputer.com/logreply/545471 <<< CLICK THIS LINK



If you no longer need help, then all you needed to do was the previous instructions of telling me so. You can skip the rest of this post. If you do need help please continue with Step 2 below.

***************************************************

step2.gifIf you still need help, I would like you to post a Reply to this topic (click the "Add Reply" button in the lower right hand of this page). In that reply, please include the following information:

  • If you have not done so already, include a clear description of the problems you're having, along with any steps you may have performed so far.
  • A new DDS log. For your convenience, you will find the instructions for generating these logs repeated at the bottom of this post.
    • Please do this even if you have previously posted logs for us.
    • If you were unable to produce the logs originally please try once more.
    • If you are unable to create a log please provide detailed information about your installed Windows Operating System including the Version, Edition and if it is a 32bit or a 64bit system.
    • If you are unsure about any of these characteristics just post what you can and we will guide you.
  • Please tell us if you have your original Windows CD/DVD available.
  • Upon completing the above steps and posting a reply, another staff member will review your topic and do their best to resolve your issues.

Thank you for your patience, and again sorry for the delay.

***************************************************

We need to see some information about what is happening in your machine. Please perform the following scan again:

  • Download DDS by sUBs from the following link if you no longer have it available and save it to your destop.

    DDS.com Download Link
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explanation about the tool. No input is needed, the scan is running.
  • Notepad will open with the results.
  • Follow the instructions that pop up for posting the results.
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet.

Information on A/V control can be found HERE.

As I am just a silly little program running on the BleepingComputer.com servers, please do not send me private messages as I do not know how to read and reply to them! Thanks!

#3 tb39

tb39
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:05:51 PM

Posted 28 August 2014 - 10:22 PM

I received a message from Helpbot. Attached is the DDS.txt log per the instructions.  I know I posted a hijack this log so maybe that is why this topic ended up in the Virus, Trojan, Spyware, and Malware removal logs forum.  I only included it as maybe it would help along with the other attachments I included.

 

Any help on this topic is appreciated.  I am at a loss why I can not install a game I had on this Win 8.1 system before the motherboard, memory & cpu upgrade.

 

Thanks

Attached Files

  • Attached File  dds.txt   21.4KB   1 downloads


#4 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,550 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:51 PM

Posted 02 September 2014 - 09:35 PM

Hello again!

I haven't heard from you in 5 days. Therefore, I am going to assume that you no longer need our help, and close this topic.

If you do still need help, please send a Private Message to any Moderator within the next five days. Be sure to include a link to your topic in your Private Message.

Thank you for using Bleeping Computer, and have a great day!

#5 hamluis

hamluis

    Moderator


  • Moderator
  • 54,865 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:51 PM

Posted 03 September 2014 - 08:31 AM

Issue resolved by OP.

 

 

Good day,

I have received a message from the help bot regarding my post and it states to send a PM to a moderator. Since it was edited / moved by you, I thought it best to PM you.

http://www.bleepingcomputer.com/forums/index.php?showtopic=545471&view=getnewpost

I think this might have been moved to the wrong section because I attached a hijack this log. It really had nothing to do with malware.  I just wanted to include as much information as possible to assist any would be helpers.

I wanted to let you know that I have solved the issue. I just happened to come across a suggestion that I had not tried and it worked like a charm.... allowing me to install the .NET framework 3.5 (and its counterparts 2.0 & 3.0). If anyone else comes across this issue, this is the website where I found the solution:

http://www.smart-arab.com/2013/12/dotnet-2-0-dotnet-3-5-offline-and-standalone-installer-for-win-8-and-win-8-1/#comment-832

 

Thanks for your time.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users