Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Bad Image & Couldn't Load XPCOM


  • Please log in to reply
1 reply to this topic

#1 initium

initium

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:19 AM

Posted 23 August 2014 - 06:15 PM

When trying to start up Firefox I get a series of two errors.

 

The first reads:

firefox.exe - Bad Image

C:\Windows\System32\srvcli.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc000012f.

 

After closing the first another opens immediately.

The second simply reads: Firefox Couldn't load XPCOM.

 

I have scanned a number of threads that say to reinstall Firefox and I have done some numerous times. Both manual and automatic uninstalls don't seem to correct it. I have also tried to install Google Chrome and I receive an indentical error complaining about srvcli.dll. Oddly enough Internet Explorer seems to work perfectly (as perfect as IE can work that is). I have also ran CCleaner to fix registry errors to no avail.

 

Edit: I forgot to mention this error began this morning after an automatic Windows update installed. I have already tried to restore the PC to an earlier date with no success.


Edited by initium, 23 August 2014 - 06:17 PM.


BC AdBot (Login to Remove)

 


#2 dicke

dicke

    Paraclete


  • Members
  • 2,196 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:02:19 AM

Posted 23 August 2014 - 09:15 PM

Welcome,

It sounds like the update didn't do its thing correctly. Rather than do a restore to an earlier time you might just do an uninstall of the update and let it try again. That should mess up fewer things [fingers crossed]

Keep us posted


Stay well and surf safe [stay protected]

Dick E





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users