Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

iTunes was unable to load data class information from Sync Services


  • Please log in to reply
2 replies to this topic

#1 Guest_NipNip1964_*

Guest_NipNip1964_*

  • Guests
  • OFFLINE
  •  

Posted 21 August 2014 - 12:15 PM

Hello

 

 

Can anyone help a fairly non-tech savvy person please?

 

• Dell Inspiron 7720 laptop.

• Windows 8.1 64-bit, all MS updates applied.

• iTunes 11.3.1.2

• iPhone 5s, with iOS 7.1.2

 

After connecting the iPhone to the laptop via USB, iTunes displayed the error message above and I was unable to sync.  The only thing I'm aware of doing since the last sync is changing my Apple ID password.

 

Having looked at numerous sites, I've tried the following:

 

• Rebooting the laptop and iPhone and reconnecting both several times

• Ensuring iTunes and iOS are the latest versions

• In iTunes, going to Edit > Preferences > Devices > Reset Sync History

• Opening Task Manager and stopping any Apple service.  Then go to C:\users\%username%\appdata\roaming\apple computer and renaming the SyncServices folder to SyncServices_old

• Searched for files called sqlite3.dll (or similar) in Windows\System32 and Windows\SysWOW64 to rename them to '.old' but was unable to find them

• Uninstall all Apple programs (iTunes, iCloud, Bonjour, etc).  Remove any folders with 'Apple', 'iTunes' or 'iCloud' in the name.  Reboot laptop.  Run CCleaner cleaner and Registry sweep.  Download and install iTunes.

• Update and run antivirus scan (Windows Defender) and Malwarebytes.

 

 

Many thanks :)

 

 

 

 

 

 

 



BC AdBot (Login to Remove)

 


m

#2 Guest_NipNip1964_*

Guest_NipNip1964_*

  • Guests
  • OFFLINE
  •  

Posted 22 August 2014 - 12:38 PM

By the way, the iPhone has not been jail-broken.

 

Other things I have tried:

 

• Tried resetting my Apple ID password back to the previous version, but Apple does not allow this.

• Several sites mention Xcode as being a possible cause.  I don't know what Xcode is, but I'm fairly sure I don't have it.

• Some sites mention having more than 1 user logged in as being a cause.  I am the sole user/administrator.

• Ran services.msc and stopped Apple Mobile Device, then restarted it.

In program files\common files\apple\mobile device support, added .old to any .dll files

• Turned off internet connection on laptop and iPhone before connecting the two.

• Running iTunes repair from control panel > uninstall programs.  This caused an error message regarding Registry errors when i ran iTunes, so uninstalled and reinstalled iTunes (again!).

• On the iPhone, ran settings > general > reset > erase all contents and settings.  Then restored from iCloud.

 

Any ideas please guys? :)


Edited by NipNip1964, 22 August 2014 - 12:39 PM.


#3 Guest_NipNip1964_*

Guest_NipNip1964_*

  • Guests
  • OFFLINE
  •  

Posted 23 August 2014 - 06:21 AM

Well...

 

While setting up the laptop and iPhone ready for the Apple rep to call, it worked!  After asking to authorise my computer, the pair synced and backup proceeded OK.  No idea why!

 

Thanks to all of you who read and pondered :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users