Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Preferred DNS server sets to 127.0.0.1 automatically


  • Please log in to reply
2 replies to this topic

#1 stan5582

stan5582

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:29 AM

Posted 20 August 2014 - 04:59 AM

My problem is with the IPv4 properties; I get connection when DNS is set to 'obtain automatically' but a few minutes after setting this, it changes to a preferred server called 127.0.0.1, the reroute to nowhere! Now i have to go back there every few minutes and change this setting if I want to connect.

Google was useless, I ran anti-malware, rebooted and reset all connections to both WiFi and Ethernet connection to the modem, tried all the command prompt tricks and nothing works.



BC AdBot (Login to Remove)

 


m

#2 scotty_ncc1701

scotty_ncc1701

  • Members
  • 520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:29 PM

Posted 20 August 2014 - 09:07 AM

Although there are many trains of thoughts for this, one solution is not to use DHCP, and just put your DNS servers into your workstation.  If you want to try this:

1.  Call your ISP and ask them for the primary and secondary DNS servers.

2.  Open the control panel.

3.  Click on the appropriate Network Connection (e.g. WiFi).

4.  Click properties.

5.  Scroll down and find Internet Protocol Version 6 (TCP/IPv6).

6.  Double click on Internet Protocol Version 6 (TCP/IPv6).

7.  Enter your primary DNS in the primary DNS box.

8.  Enter your secondary DNS in the secondary DNS box

9.  Click OK.

10.  Repeat the above for Internet Protocol Version 4 (TCP/IPv4).

11.  Repeat 3-9 for the other connections you may have (e.g. Ethernet).

12.  Reboot your computer.

13.  See how things go.

Best of luck!
:bananas: :bounce:
 



#3 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:07:29 PM

Posted 20 August 2014 - 01:41 PM

Since the issue is the reverting to a invalid dns server ip the usual reason for this is a malware or virus infection.  This does assume you have not misconfigured your dhcp server to give the wrong dns record.

 

You would want to update and run your malware checker or antivirus software.

 

You may also want to consider going to a system restore point to before this began.  This will undo any registry changes the malware/virus may have added.

 

Here's a little more detail in setting the dns servers vs the autoassigned dns server.  You can use your ISP's dns servers or if in the US you can use Google's at 8.8.8.8 and 8.8.4.4

 

Start by going here:

 

Control Panel

Network and Internet

Network Connections

 

Right mouse click on the wifi or lan icon and go to properties

 

Double click on ipv4

Select "use the following dns server addresses"

put in the ipv4 ip addresses and click OK

 

For ivp6 you want to do the same as ipv4 but use these addresses instead since they are the ipv6 ips for Google in this case

2001:4860:4860::8888 and/or 2001:4860:4860::8844

and again say OK.

 

You don't need to reboot if using Win7 or 8

 

Let us know how it works out.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users