Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Keyboard screwed up since restoring to factory setting


  • Please log in to reply
3 replies to this topic

#1 Violette

Violette

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:25 AM

Posted 14 August 2014 - 05:30 PM

Please help me...i'm bout to pull my hair out.

 

I did a factory reset due to trojans, selected UK at every option on the reinstall yet the keyboard is stuck on what I assume to be a US setting. Tried changing it via control panel but everything was already set to UK except that under keyboards and languages>change keyboards>general>installed services it has a US keyboard as well as the UK one. So I removed it...which did nothing. Tried to update the driver for the keyboard via device manager, did nothing. So then I tried un-installing the keyboard driver via device manager then restarted which also failed to correct it. Time zone etc. is on the UK setting. Finally I restored to factory settings for a second time which did squat. 

 

The keyboard was working fine before this, had absolutely no problem with it. I ran a version of Puppy on it thinking that it wouldn't be affected by whatever's happened to vista but had the same issue. 

 

I can only get capitals and @ etc. via onscreen keyboard - I have stuff to do, this is a damn nightmare!

 

*Vista: home premium 32 bit


Edited by Violette, 14 August 2014 - 05:34 PM.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,439 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:25 AM

Posted 14 August 2014 - 06:13 PM

Hello, and Welcome

 

In the search box type

 

Regedit  > right click > Run as administrator

 

Navigate to the following key

 

HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

 

Double click "1" and change the value to 00000809. 

 

From your post the value may be 00000409

 

Navigate to the following key

 

HKEY_USERS\.DEFAULT\Control Panel\International\

 

Double click "locale" and change the value to 00000809.

 

Exit out of Regedit and reboot. 

 



#3 Violette

Violette
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:25 AM

Posted 14 August 2014 - 06:27 PM

hi johnc, 

 

that figure is already there in both locations

 

thx



#4 JohnC_21

JohnC_21

  • Members
  • 24,439 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:25 AM

Posted 14 August 2014 - 06:59 PM

I am not sure this would work but Add the US keyboard back in Services. When done move the UK keyboard to the top of the list. In the Language Bar tab, Select dock to taskbar. When you reboot you should see the keyboard icon in the taskbar. Click that and make sure UK keyboard is selected.

 

Under the General tab, Engish (UK) is the default input language, correct?

 

What confuses me is that linux had the same problem.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users