Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Games need opening twice to start, please help


  • Please log in to reply
2 replies to this topic

#1 Kerr Avon

Kerr Avon

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Local time:05:54 AM

Posted 14 August 2014 - 12:24 PM

I have a problem with a laptop I've been asked to fix. The laptop (Windows 7, 6GB RAM, 1.6 GHZ AMD Quad-Core A8-3520M APU) has no malware, and everything (hardware and software) seems fine, except that when you first try to open (load) a game, you have to do it twice or the game does not open. I.e.:
 
 
 
1. The laptop is turned on, boots, goes to the Windows desktop, everything is fine.
 
2. To start, say, Unreal Tournament 2004, I double click on the game's icon.
 
3. Nothing happens. 
 
4. If I then double click on the icon again, then the game loads and plays as it should.
 
 
Experimentation shows that the first time you double click on the icon, two new processes appear in the Task Manager;
 
rundll32.exe *32
UT2004.exe *32
 
but the game does not load, nor do I get any error messages, until I again double click on the icon.
 
 
 
It does the same for other games, such as if I try to start Morrowind, then exactly the same thing occurs; nothing at all visibly happens, no error message, no system warning beep, and the game does not load. But if I look in Task Manager then two new processes have been added;
 
rundll32.exe *32
Morrowind Launcher.exe *32
 
and the game only loads if I then double click again on the icon.
 
It does this with many of the games on the machine, but even so, I uninstalled Unreal Tournament 2004 and installed my copy (original!), plus the patch and extra levels, and yet it still needs opening twice before it starts up though of course it works fine on my laptop and desktop.
 
When a game does load, then it works fine, and I can't find any other problems at all. But this is a new one, at least to me, and any help or advice would be appreciated. 
 
Thanks for reading, and for any advice.
 


BC AdBot (Login to Remove)

 


#2 twobleepsandabloop

twobleepsandabloop

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:54 AM

Posted 14 August 2014 - 02:41 PM

Just a thought, but have you tried running the executable the shortcut on your desktop points to directly? Is the result the same?



#3 Kerr Avon

Kerr Avon
  • Topic Starter

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Local time:05:54 AM

Posted 15 August 2014 - 07:14 AM

Just a thought, but have you tried running the executable the shortcut on your desktop points to directly? Is the result the same?

 

I'm pretty sure I tried that, with the same results (I'm at work now, so I can't check). Thanks for the suggestion, though. Anyway, I've found the cause, thanks to a post on another forum, and it turns out that this isn't a 'problem', Oh no, it's a 'feature'...

 
Apparently it's down to Game Explorer, a 'feature' of Windows Vista onwards that, when you click on a recognised game, then Game Explorer loads in the background, counts how often you've loaded the game, and does other things, including going online to check with some database if there's a patch for the game. Oh, and if the PC is offline (which this laptop is) then the process just, er, hangs. Apparently this problem has been known about for years, Microsoft has been bombarded with requests to fix it, and have done nothing.
 
 
To quote from the first thread I list below:
 
 

As we all know, Vista introduced the Game Explorer (GameUX.dll) which incorporates update checking and game information.
 
What most  on't know, is that the instant a game is launched, Rundll.exe is spawned with the GameUX.dll,gameshim parametre and constantly polls the dns, network and domain functions in the OS.
 
The problem here, lies in the fact that if this process does not receive a response, the Game's process will sit frozen until a response is recieved.
 
Now the Rundll process actually acts as a mask for the games executable until the response from the servers is received, that said closing the rundll.exe prior to the handover being made will also close the Games executable.
 
You can work around this in a way by killing the actual game executable, which will keep the rundll open, and then opening the game executable again. However as it is polling the net api's (Wininet), Rundll will consume a full core (13% for my i7), until you close it. which can cause a number of issues in single core games, and the like.
 
 
Various user found fixes are listed on the 'net, but (again from the first thread I link to):
 

Just wanted to necropost to update the record on how much of a failure this is 
==OVER A YEAR LATER AND ITS STILL BROKEN==
best part is, with updates it re-enables itself every so often
absolutely glorious
 
actually it's even worse than that now, it's been updated so that none of the above solutions work anymore 
if you unregister the dll as per qwadrwr then rundll32.exe will get stuck in limbo trying to load, same if you deny read permissions to the files (albeit it doesn't consume 100% of the core it's running on, it just sits there)... only solution is for those that need it:
 
run one instance of the software, it will get stuck
run a second instance of the software, gameux is busy doing it's thing so this will launch
taskkill rundll32 responsible for the first instance
enjoy
 
So I'm not confident that any easy fix will work. Thanks, Microsoft.
 
 
 
 
 
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users