Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to connect to the internet


  • Please log in to reply
18 replies to this topic

#1 D_Light

D_Light

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 09 August 2014 - 05:59 PM

Hi
I have an old eMachines laptop that I received with a faulty power button, I fixed the problem and did a clean windows install on it, installed every single driver on it and it works splendidly but when I try to connect to my wireless network it gives the following error "Windows was unable to connect to ...", I tried connecting it with a cable to the router and it works, and made a hotspot with my phone and connected it that way and the same no problems except when I try with the wireless on the router. Other devices connected to it work perfectly.

Any idea what the problem might be ?

Thank you



BC AdBot (Login to Remove)

 


#2 dicke

dicke

    Paraclete


  • Members
  • 2,189 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:02:05 AM

Posted 09 August 2014 - 07:45 PM

Welcome,

Do you have a username and password set for your router? When you go into the control panel and try to establish a wireless connection can you see the router?

Keep us posted


Stay well and surf safe [stay protected]

Dick E


#3 D_Light

D_Light
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 09 August 2014 - 08:27 PM

Yes i can see it , it establishes a connection to the router and after i enter the passkey it gives me that error, i even tried to disable the security on it and it still didn`t work.



#4 Digityz

Digityz

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:05 AM

Posted 09 August 2014 - 09:03 PM

Have you tested it on any other wireless network like starbucks or anywhere? Dont know what model your router is?



#5 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 09 August 2014 - 09:45 PM

A few things to check:

 

Make sure you are entering the passkey correctly, and that you are entering the correct passkey (that is, not the admin password for the router itself but the passkey to access the WiFi). Log into the router's admin section and double-check what the passkey is.

 

Check the WiFi settings on the computer to make sure you are using the same security type as the router -- WEP, WPA or WPA2. Personally, I don't recommend WEP. The encryption was cracked several years ago so using it is like not using any encryption at all.

 

Is MAC filtering enabled on the router? If so, disable it, connect the eMachine via WiFi, have the router discover the eMachines' MAC address and then turn MAC filtering back on.



#6 JohnC_21

JohnC_21

  • Members
  • 23,248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 09 August 2014 - 09:48 PM

Check your wireless security setting in your router. It should be set to WPA2-PSK with AES encryption. On the laptop right click the connection you cannot access. Select properties. Under the Security tab make sure it's set to WPA2-PSK  or  WPA2 Personal under Security Properties  and AES under encryption type and put your key in. Then press okay.

 

Is there any yellow exclamation marks in Device Manager?



#7 D_Light

D_Light
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 10 August 2014 - 09:22 AM

A few things to check:

 

Make sure you are entering the passkey correctly, and that you are entering the correct passkey (that is, not the admin password for the router itself but the passkey to access the WiFi). Log into the router's admin section and double-check what the passkey is.

 

Check the WiFi settings on the computer to make sure you are using the same security type as the router -- WEP, WPA or WPA2. Personally, I don't recommend WEP. The encryption was cracked several years ago so using it is like not using any encryption at all.

 

Is MAC filtering enabled on the router? If so, disable it, connect the eMachine via WiFi, have the router discover the eMachines' MAC address and then turn MAC filtering back on.

 

I checked the passkey  from the router and it was correct and there is no MAC filtering, the router security mode is WPA-Personal and authentication

WPA/WPA2

 

Check your wireless security setting in your router. It should be set to WPA2-PSK with AES encryption. On the laptop right click the connection you cannot access. Select properties. Under the Security tab make sure it's set to WPA2-PSK  or  WPA2 Personal under Security Properties  and AES under encryption type and put your key in. Then press okay.

 

Is there any yellow exclamation marks in Device Manager?

 

When i right click on the connection there is only the "connect" tab, i tried with my phone hotspot and the security type was WPA2-Personal, Encryption type AES, and no there aren`t any yellow exclamation marks all drivers are installed

My laptop wireless network adapter is ''qualcomm atheros ar5007eg'' and the router is "Technicolor TC 7200.u" i got it from my internet provider.



#8 JohnC_21

JohnC_21

  • Members
  • 23,248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 10 August 2014 - 11:01 AM

I would download and install the AR5007eg driver. It is here. Click the green download button and not the inf link. It may take a bit before you see the download dialog window. It's about a 8MB file.

 

You should have a security tab in your Properties window. If the above driver does not work, set up the connection manually. Network name is the SSID of the Router.

 

There is also the possiblity the emachines does not support WPA2 and only WPA.



#9 D_Light

D_Light
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 10 August 2014 - 12:03 PM

I would download and install the AR5007eg driver. It is here. Click the green download button and not the inf link. It may take a bit before you see the download dialog window. It's about a 8MB file.

 

You should have a security tab in your Properties window. If the above driver does not work, set up the connection manually. Network name is the SSID of the Router.

 

There is also the possiblity the emachines does not support WPA2 and only WPA.

Well that driver made the system BSOD perpetually until i removed it in safe mode, and i set up the connection manually with the security mode WPA-Personal and encryption both TKIP and AES and it didnt work. I even disabled the security on the router...and the same result and its driving me creazy.



#10 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 10 August 2014 - 12:15 PM

Not sure that was the proper driver. The website states it's the "unofficial" Atheros Czech driver site.

 

The AR5007EG driver is usually pushed out through Windows Updates, or can be downloaded from Qualcomm.

 

Try downloading the official driver and see if that works.

 

It may be the case that the wireless card itself is shot and needs to be replaced.



#11 D_Light

D_Light
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 10 August 2014 - 12:58 PM

Well i guess the card is shot because even with the latest driver from the manufacturer it gave me a BSOD, so i`ll try to change it, maybe....

the thing that i didn`t understand is why it would connect to my phone hotspot with no problems because that too is a wireless connection no ?



#12 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 10 August 2014 - 01:03 PM

That is odd. But the computer shouldn't blue screen when the correct drivers are installed.

 

You might want to go into Event Viewer, or use Blue Screen View, to have a look at the error messages that were generated. That might provide some answers.

http://www.bleepingcomputer.com/forums/t/40108/how-to-use-event-viewer/

http://www.nirsoft.net/utils/blue_screen_view.html



#13 D_Light

D_Light
  • Topic Starter

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:05 AM

Posted 10 August 2014 - 01:26 PM

Here is the latest BSOD report with the manufacturer driver

==================================================

Dump File         : 081014-14055-01.dmp
Crash Time        : 8/10/2014 8:52:18 PM
Bug Check String  : IRQL_NOT_LESS_OR_EQUAL
Bug Check Code    : 0x0000000a
Parameter 1       : 0x0000001c
Parameter 2       : 0x00000002
Parameter 3       : 0x00000001
Parameter 4       : 0x82a1c71e
Caused By Driver  : halmacpi.dll
Caused By Address : halmacpi.dll+371e
File Description  : Hardware Abstraction Layer DLL
Product Name      : Microsoft® Windows® Operating System
Company           : Microsoft Corporation
File Version      : 6.1.7601.17514 (win7sp1_rtm.101119-1850)
Processor         : 32-bit
Crash Address     : ntkrnlpa.exe+415cb
Stack Address 1   : halmacpi.dll+371e
Stack Address 2   : athr.sys+12f2f6
Stack Address 3   : athr.sys+15f89f
Computer Name     : 
Full Path         : C:\Windows\Minidump\081014-14055-01.dmp
Processors Count  : 1
Major Version     : 15
Minor Version     : 7601
Dump File Size    : 146,112
Dump File Time    : 8/10/2014 8:53:03 PM
==================================================


#14 sflatechguy

sflatechguy

  • BC Advisor
  • 2,200 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 10 August 2014 - 01:38 PM

That's the wireless card driver causing the crash.

 

As I pointed out earlier, Windows Update normally pushes out the driver for your Atheros card. Try going to Control Panel>Windows Updates, and check for new updates.

 

If that doesn't resolve it, and because updates tries to install the wireless driver for you, you'll need to remove the existing driver and replace it with the new one, which you'll need to download and save somewhere on your PC. The instructions here are for Vista, but will work on Windows 7. In your case, the driver you'll want to remove is athr.sys. Ignore the references to the CD, as you'll just navigate to where you saved the new driver. http://www.tp-link.us/article/?id=201

 

If that doesn't resolve it, it's time to replace the wireless card.



#15 JohnC_21

JohnC_21

  • Members
  • 23,248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:05 AM

Posted 10 August 2014 - 01:50 PM

It's interesting the driver I linked to bluescreened the computer. I never had a problem with drivers from the unofficial site. Just to verify that it is a 5007EG. Right click the wireless adapter in Device Manager. Select Properties and under the details tab select Hardware ID's. Copy and paste the first line in your next post. What is ironic though is that the only wireless driver I had bluescreen on a laptop was the one provided by Windows Update. I had to roll the driver back in safe mode.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users