Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Word 2003 - 'Check Spelling as you type' no longer works correctly


  • Please log in to reply
8 replies to this topic

#1 HairCut

HairCut

  • Members
  • 235 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:57 AM

Posted 07 August 2014 - 06:59 PM

Hi all,

 

Earlier this year "Check Spelling as you type" in Word 2003 worked fine. Now it does not and the red wavy line does not appear under wrongly spelled words. (unless I click Spelling and Grammar first).

 

I have tried every suggestion on this web page with no luck.

The registry item named '1' mentioned in the article was missing.

 

It's a real mystery as the 'check spelling as you type' still works in PowerPoint and also in Windows Live Mail.

 

I can reactivate 'check spelling as you type' in a document If I choose to run a spell check via the 'Spelling and Grammar' icon on the toolbar or from the 'tools' menu item. Only then does 'check spelling as you type' begin working again for the current document.

 

I tried a system restore to June which is our earliest restore point for 2014. (I have restore points for 2012 but inexplicably none for 2013. I'd rather avoid going that far back in time)

 

I re-installed Microsoft Office 2003

 

any other ideas?


Edited by hamluis, 08 August 2014 - 10:11 AM.
Moved from Win 7 to Business Apps - Hamluis.


BC AdBot (Login to Remove)

 


m

#2 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 34,279 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:09:57 PM

Posted 07 August 2014 - 07:22 PM

You have have tried everything I would have. Unfortunately Microsoft no longer supports Office 2003 products. So you're not going to get much help from them. Office 2003 support ended the same time that XP support ended.

http://office.microsoft.com/en-us/help/support-has-ended-for-office-2003-HA103306332.aspx

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+

#3 CheshireCat

CheshireCat

  • Members
  • 348 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 AM

Posted 07 August 2014 - 09:07 PM

Hi HairCut.

 

That is pretty strange. Other people on various forums have reported similar problems, so maybe some of their "solutions" might work for you.

Make sure of this:

 

1.) Click "select all."

2.) Then on the review ribbon click "Proofing" and then "Set Language."

3.) Make sure "Do not check spelling and grammar" is not selected.

If that isn't the problem, try downloading an additional language. Switch that to the default language and then switch back to your original default (i'm assuming it's English US).

Post back with any updates.

 

Regards,

Daniel.


 



#4 HairCut

HairCut
  • Topic Starter

  • Members
  • 235 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:57 AM

Posted 08 August 2014 - 04:19 AM

Having tried everything suggested I guess 'the user' going to have to remember to click 'Spelling and Grammar' > 'Cancel' each time they open Word.

I wonder what other annoyance will creep in to an unsupported version of Word and of course it's a security hole in the making.

 

There are many alternatives to this old version of Word but the User is averse to new software. :/



#5 Scoop8

Scoop8

  • Members
  • 326 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Dallas TX
  • Local time:11:57 PM

Posted 08 August 2014 - 06:53 AM

HairCut

 

After reading your thread, I checked my Word 2003 auto spell-check (the red line) and also the auto-correct spelling feature.

 

Both are working ok on my Win 7x64 PC.Desktop PC.  I'm using SP3 with Office 2003.

 

I checked this on my Win 7x64 Toshiba Laptop and it's also working ok on the Laptop.

 

One thing that may explain why I'm not seeing the problem is that I'm using the "Students and Teachers" Office '03 edition (the version that wasn't upgradable and was less expensive) and not the retail version.



#6 HairCut

HairCut
  • Topic Starter

  • Members
  • 235 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:57 AM

Posted 08 August 2014 - 10:35 AM

Thanks for testing.

This system is also Win 7 - 64bit - and Office with SP3

and it is also the Student and Teacher version.

It should be a completely clean installation as I've re-installed it and deleted normal.dot to let it reset.

 

So something about this laptop ....

 

Have since tested it in Safe Mode .. same problem.

......



#7 CheshireCat

CheshireCat

  • Members
  • 348 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 AM

Posted 08 August 2014 - 10:51 AM

Haircut,

 

This is very interesting. Can you try and "add word to dictionary" (e.g. woodcut or something that makes sense) and then misspell it on purpose to see if you get the spellchecker red line?

 

Regards,

Daniel.



#8 HairCut

HairCut
  • Topic Starter

  • Members
  • 235 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:57 AM

Posted 08 August 2014 - 11:45 AM

I typed speeling it did not get underlined.
I clicked 'Spelling and Grammar' on the tool bar and it was underlined in red and I then added it to the custom dictionary.
I then closed and re-opened Word and I misspelled it thus: speeeling. It was not underlined until I again clicked 'Spelling and Grammar' in the toolbar.
 
I then deleted speeling from the custom dictionary, restarted Word and then added the misspelled word speeling before clicking 'Spelling and Grammar'. It was not underlined as it wouldn't be (being in the dictionary) but other misspelling were not underlined either until ..... I click 'Spelling and Grammar' in the toolbar.
 
My options in the Spelling and Grammar tab look like this:
 
https://www.dropbox.com/s/1top9e9ac21slaa/options-spelling.png
 
I had to link to dropbox as the attachment button I'm sure I've used in this forum before has disappeared - but that might be for another thread ;)



#9 CheshireCat

CheshireCat

  • Members
  • 348 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:57 AM

Posted 09 August 2014 - 05:56 PM

Hmm... can you try and unclick everything in the spelling options except for "Always suggest corrections" and "Suggest from main dictionary only"? Then close windows, open it again, and see if the options were saved. Let me know if it affects anything.

 

Regards,

Daniel.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users