Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

having trouble with socket programming, could have rootkit


  • Please log in to reply
No replies to this topic

#1 icealys6

icealys6

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:42 AM

Posted 06 August 2014 - 11:13 PM

hi, i recently created an IRC server and debugged it. It worked good but then when i closed it it returned a large signed integer. Then when I ran it again the bind function returned with WSAerror 10048 which means the socket is still open. So I used netstat -a -n -o to view the process IDs associated with the socket, and I found that the port was still in use. So I went into task manager to find the process and it didn't even exist! I have to restart my system for the socket to be freed and then my program works again. Could this be caused by a rootkit in my system?


Edited by hamluis, 07 August 2014 - 09:27 AM.
Moved from Win 7 to Am I Infected - Hamluis.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users