Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Google Chrome constantly Lags, making it almost unusable


  • Please log in to reply
6 replies to this topic

#1 wthChrome

wthChrome

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:56 AM

Posted 03 August 2014 - 12:50 PM

I am running Windows 7 32bit, Core 2 Duo T9600 2.8ghz, 4gb ram (2.46 usable). I just started having this problem a few weeks ago and I do not have the problem in IE or Firefox.

 

Chrome lags when I'm typing, highlighting text, scrolling, and loading pages. It's extremely frustrating and I've tried uninstalling and reinstalling with no luck. I've been using chrome for years and have never had this happen before. I've also scanned with Avast and Malwarebytes and my system comes up clean.


Edited by hamluis, 03 August 2014 - 03:09 PM.
Moved from Win 7 to Web Browsing/Email - Hamluis.


BC AdBot (Login to Remove)

 


#2 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:08:56 AM

Posted 03 August 2014 - 05:44 PM

One thing that seems to work for this kind of Chrome problem is to uninstall and reinstall. Chrome will detect your settings when you reinstall. Also, it could be an extension problem. Maybe you have one that isn't working anymore and it's slowing Chrome.



#3 rp88

rp88

  • Members
  • 3,048 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:56 PM

Posted 04 August 2014 - 02:45 PM

in chrome, even if it is running fine i advise setting all plugins to be "click to play" this means loads of cra*py adverts you see on websites won't automatically load and this reduces the data that needs to be sent across the web to your computer and then displayed by your computer. it will help speed up the browser whether the problem is due to the connection or the computer on which the browser runs. disable all extensions and use chrome://plugins to disable any plugins you never use, make sure those you sometimes use are all set for "click to play".

also try a antivirus scan with this tool http://www.kaspersky.com/virus-scanner  click the link for "kaspersky virus removal tool". when you scan MAKE SURE IT IS SET ONLY TO DETECT THREATS AND PROMPT, NOT TO REMOVE OR DISINFECT THEM. i use it as a third opinion scanner sometimes, but it is very sensitive so it might make false positives of things and if you let it disinfect something it could attack a legitimate and important file. ask around for advice if there are any settings you are uncertain of before running it. 


Back on this site, for a while anyway, been so busy the last year.

My systems:2 laptops, intel i3 processors, windows 8.1 installed on the hard-drive and linux mint 17.3 MATE installed to USB

#4 TulsaRose

TulsaRose

  • Members
  • 367 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Tulsa OK
  • Local time:07:56 AM

Posted 05 August 2014 - 06:26 AM

in chrome, even if it is running fine i advise setting all plugins to be "click to play" this means loads of cra*py adverts you see on websites won't automatically load and this reduces the data that needs to be sent across the web to your computer and then displayed by your computer. it will help speed up the browser whether the problem is due to the connection or the computer on which the browser runs. disable all extensions and use chrome://plugins to disable any plugins you never use, make sure those you sometimes use are all set for "click to play".

 

 

 

 

I don't find "click to play" option in the Chrome Plug-ins list.  I'm given the options to Enable\Disable or Always allowed.  Using v.36.0.1985.125.


Edited by TulsaRose, 05 August 2014 - 06:27 AM.

WinXP Pro sp3 \ Firefox, Panda, MBAM, SAS, SpywareBlaster


#5 rp88

rp88

  • Members
  • 3,048 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:01:56 PM

Posted 05 August 2014 - 12:15 PM

i'll explain how to do it, click to play is easier to get to than manually editing all the plugins.

 

click on the "hamburger" button in chrome, then "settings" then scroll down and click "show advanced settings", click on the box for "content settings". this brings up a pop up box within the chrome settings tab, scroll down within this popped up box to "plugins" and "tick" the circle marked "click to play". do that first then go to chrome://plugins to disable those you never use AT ALL, those you use sometimes will have been automatically set to "click to play" so that when you open a web page with a plugin on it the plugin is greyed over until you click it. you can test this by going to a video site(not youtube as many of it's videos are html 5 these days), the videos(as long as they are flash videos) should not play until you click on the grey box where the video would usually be. this WILL improve your speed somewhat. this way the only videos(high bandwidth and large memory use for your pc) that can play are those you want, not the cra*py ads round the corners of pages.


Back on this site, for a while anyway, been so busy the last year.

My systems:2 laptops, intel i3 processors, windows 8.1 installed on the hard-drive and linux mint 17.3 MATE installed to USB

#6 wthChrome

wthChrome
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:56 AM

Posted 05 August 2014 - 09:40 PM

in chrome, even if it is running fine i advise setting all plugins to be "click to play" this means loads of cra*py adverts you see on websites won't automatically load and this reduces the data that needs to be sent across the web to your computer and then displayed by your computer. it will help speed up the browser whether the problem is due to the connection or the computer on which the browser runs. disable all extensions and use chrome://plugins to disable any plugins you never use, make sure those you sometimes use are all set for "click to play".

also try a antivirus scan with this tool http://www.kaspersky.com/virus-scanner  click the link for "kaspersky virus removal tool". when you scan MAKE SURE IT IS SET ONLY TO DETECT THREATS AND PROMPT, NOT TO REMOVE OR DISINFECT THEM. i use it as a third opinion scanner sometimes, but it is very sensitive so it might make false positives of things and if you let it disinfect something it could attack a legitimate and important file. ask around for advice if there are any settings you are uncertain of before running it. 

Thank you very much for the advice, however I did both things that you said here, and still no change :/ Kaspersky scan came up clean just like all the other scans I've done. This is getting so frustrating. I don't want to have to go and buy a new laptop, because I love my Thinkpad.  Basically makes doing anything in Chrome a royal pain.



#7 wthChrome

wthChrome
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:09:56 AM

Posted 06 August 2014 - 06:40 AM

UPDATE:

 

So I found out that it was the version of Chrome that was giving me the problem. I was using the latest version 36 of Chrome. I found an older version online to download (26) and it worked great, no lag. However, I don't want to use such an outdated version of Chrome.

 

So I found a browser called SRWare Iron, which is like a clone of Chrome that is supposed to have better privacy. It looks and works just like Chrome, but runs super fast with no lag.  Guess I'll be using this for now.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users