Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Need Driver For Superpen Tablet


  • This topic is locked This topic is locked
1 reply to this topic

#1 King Camel

King Camel

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Location:Chicago
  • Local time:08:59 PM

Posted 01 June 2006 - 11:54 PM

Hello. This is my first post, so I'll try to get this right. I recently purchased a "new" UC-LOGIC SuperPen
Tablet, Model #PP3333 on ebay. Unfortunately, I assumed it would be compatable with XP Media Edition(Pro?)OS. The software(driver?) that was included was on a floppy, and the info it came with stated it was for "Dos, Windows 3.1, Windows 95/98 & NT". I contacted the manufacturer in Thailand via email, and all I could get from them was that this item is about 10 years old and they were surprised I found a new one to purchase. They no longer support this product and told me that, basiclly, I'm on my own and good luck. Here are my questions:

1- Can this device be upgraded to work with XP?
2- I found a site that has a ton of driver downloads, but I can't get signed up to it. I think they may be having problems with their site. It is called DriverGuide.com. Has anyone else had problems with this site?
3- I got it for $9.00. Should I just give up? I'd really like to get it working, if at all possible.

Sorry for rambling on. Any help would be appreciated.
Thanks, Roger

BC AdBot (Login to Remove)

 


m

#2 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:08:59 PM

Posted 02 June 2006 - 12:03 AM

Here's another place to try:
Drivers Database
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users