Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Port Forwarding Blocked


  • Please log in to reply
1 reply to this topic

#1 Jack Langston

Jack Langston

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:40 PM

Posted 29 July 2014 - 12:10 PM

Goal: Forward a call to my public IP address to an IP address in my local network using the port forwarding capabilities of my router. I would like to do this in order to access a file server system from anywhere (not just my local network) that is stored on a retrofitted laptop running FreeNAS.
 
Problem: No matter what I try, I cannot seem to get any ports to open (as checked by both http://www.canyouseeme.org/ &  Advanced Port Scanner 1.3  & from trying to call the IP & port from an external network).
 
Hardware / Set-up: Bright House Networks ISP > Cable Modem (Motorola SB6141) > Router (Netgear Nighthawk R7000) > Simple Switch (Netgear 24 Port Gigabit JGS524) > FreeNAS System (Gateway Laptop)

 

*All connections are made by <2' Cat5e cables (except ISP to modem)

 

Diagnostics:

 

FreeNAS System

 

1. I have set up the FreeNAS system so that it is accessable via my local network with no issues at all.

 

2. I have assigned it the static IP of 192.168.1.10.

 

3. On the router I have reserved the IP of 192.168.1.10 for the FreeNAS system as to prevent any DHCP conflicts from the router.

 

Switch

 

1. I just bought this switch. Netgear assured me that port forwarding should work on this switch. It is a plug & play model.

 

Router

 

1. I followed the exact steps indicated here (Netgear's own FAQ for this particular router model). I chose my port at 176 although this was completely arbitrary.

 

2. I opened NAT filtering.

 

3. Firmware is updated.

 

4. Just in case someone brings this up, I know that my router does not support reverse NAT lookups so I cannot type in my public IP while connected to the local network.

 

***If I turn Default DMZ on and point it at the 192.168.1.10, I am able to access the FreeNAS server by typing in my public IP address (with no ports attached). However, this is not the end all solution as I have more than one server that I would like to use port forwarding to access. The Default DMZ will only allow me to pick one internal IP address as you all probably know.

 

***I have tried three different routers and talked to support for Netgear, so I can say with a large degree of certainty that this is not a router problem.

 

For convenience, I have included this pictures of the router setup:

 

Attached File  Optimized-Netgear Port Forwarding Diag.bmp   123.8KB   2 downloads

Attached File  Optimized-Netgear Port Forwarding Diag 2.bmp   127.44KB   1 downloads

Attached File  Optimized-Netgear Port Forwarding Diag 3.bmp   118.05KB   0 downloads

 

Modem/ISP

 

1. I went ahead and connected a laptop directly to the modem to ensure that my modem/ISP were not the source of this problem. This is where things get interesting. The computer connects to the internet after I power-cycle the modem, but when I run the port checking software and scan all 65,535 ports, the only ports that are listed as open are 135, 139, and 445. The other 65,533 ports are all closed. As the modem was provided by my ISP, I went ahead and contacted their support staff to see what this was about. They told me that they were not blocking any ports to my IP from their routers and that their modems do not come with any built-in firewalls to prevent ports from being opened. Of course, I then double checked by redoing that port test, yet the results were the same: all ports on the connection coming from my modem are closed except for the above three.

 

Current Status:  I am waiting for the technical supervisor for Bright House Networks to call me and hopefully elaborate on the modem/ISP section of this post. However, I am about 10 hours of troubleshooting in and at this point I would really appreciate any help from the community at large if there are any ideas. I would try ANYTHING. Thanks guys!

 

 


Edited by Jack Langston, 29 July 2014 - 12:12 PM.


BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:08:40 PM

Posted 30 July 2014 - 03:08 PM

First issue is if you set a ip reservation in the router the workstation must be set to dynamic ip.  Doing a reservation AND a static ip is pointless in that they are redundant.  I would suggest you stick with the ip reservation and set your workstation to auto assigned concerning ip address.

 

" I chose my port at 176 although this was completely arbitrary."

 

This is completely wrong.  You can't pick a port out of thin air.  Something has to be LISTENING on that port which in your case is the FreeNas box.  Normally you would choose a port beyond the known 1024 ports.

 

Though when I search on freenas listening port I am not finding one.  It appears freenas wants you to use FTP instead

http://doc.freenas.org/index.php/FTP

 

Might want to do a netstat via command prompt on the freenas server so you can identify what port or ports its listening on.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users