Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Samsung Galaxy Tab 2 digitizer doesnt respond to touch.

  • Please log in to reply
No replies to this topic

#1 Blufx


  • Members
  • 70 posts
  • Gender:Male
  • Location:Upstate South Carolina
  • Local time:11:09 AM

Posted 26 July 2014 - 01:42 PM

Galaxy Tab 2 model # GT-P5113TS.  The screen was smashed when I got it, but it worked perfectly. I ordered a new digitizer and installed it (which I've done many times on phones, iPods, and other tablets). It's a simple job on this tablet, very easy to open and access the connectors, but when done it had absolutely no response to touch. I tried resting to factory but that didn't help. I assumed I had bought a bad digitizer. Ordered another and have the same result. Connection's good and tight on the ZIF. There's no damage, kinks, or bends in the ribbon cable.

Does anybody have an idea what this could be?

Looking back....I should have been a lot more specific when I said I wanted to be somebody.albertavatar.jpg

BC AdBot (Login to Remove)



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users