Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unknown Avira-defeating Malware


  • This topic is locked This topic is locked
3 replies to this topic

#1 Schwarzmaler255

Schwarzmaler255

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 25 July 2014 - 02:12 PM

Hello,

 

I have Windows 7 Home Premium 64bit, Avira Internet Security, Spybot S&D and Malwarebytes (free).  Avira and Malwarebytes are currently non-operational (details below), and Spybot S&D picks up nothing.

 

My problems began yesterday, not long after logging on to my computer. I was on the internet reading a news article and using Google maps. First, my PC got very sluggish, then Avira's services turned off. I attempted to turn them back on via the Avira control panel, and when that failed I unplugged my computer. 

 

 

The malware disables Avira's realtime protection, updating ability and the ability to run a scan (a "The Feature Control File could not be loaded" error appears for scans).  I ran a Malwarebytes, it identified 1 object, but then failed to fix the problem.  If I try to activate Avira's Firewall, Mail or Internet services via the task manager, I get an access denied message.  If I tell Avira to update nothing happens, but in ProcessExplorer, I can see the avira update turn on, but them be terminated immediately.

 

 

After a bit of struggling and trying to do a system restore using two different dates (all with no effect), I found two items with long alpha-numeric names in the Windows/System folder (they had no file type listed and had been created less than 12 hours ago). I restarted in safe mode and then did a 7-pass delete on those two files. Interestingly, with this malware on my PC, Avira acts the same way in safe mode & normal mode (open umbrella icon, but reveals it is rife with problems in the control panel).  Normally, Avira will make it abundantly clear that it does not work correctly in safe mode (closed umbrella, various other indicators).

 

 

Then, I restarted again, and the malware was still seemingly effective, had recreated the two files I deleted, and Windows began alerting me that I needed to register my copy of Windows 7 and that my copy was not genuine (but it is genuine). I have not re-entered my Win7 product key for fear that the malware may attempt to hijack it, etc.
I am still able to work on my computer though.

 

Since attempting the system restores, I have not been able to get Malwarebytes to operate correctly, so I do not know how to retrieve its log.

 

I ran a RogueKiller scan:

RogueKiller V9.2.3.0 [Jul 11 2014] by Adlice Software
mail : http://www.adlice.com/contact/
Feedback : http://forum.adlice.com
Website : http://www.adlice.com/softwares/roguekiller/
Blog : http://www.adlice.com

Operating System : Windows 7 (6.1.7601 Service Pack 1) 64 bits version
Started in : Normal mode
User : Der Chef [Admin rights]
Mode : Scan -- Date : 07/24/2014  20:35:26

¤¤¤ Bad processes : 1 ¤¤¤
[Suspicious.Path] mylbx.exe -- C:\Users\Der Chef\Desktop\My Lockbox\mylbx.exe[7] -> KILLED [TermProc]

¤¤¤ Registry Entries : 9 ¤¤¤
[Suspicious.Path] (X64) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run | mylbx : C:\Users\Der Chef\Desktop\My Lockbox\mylbx.exe /a  -> FOUND
[PUM.Policies] (X64) HKEY_USERS\S-1-5-21-1129176906-220587917-378845204-1001\Software\Microsoft\Windows\CurrentVersion\Policies\System | DisableRegistryTools : 0  -> FOUND
[PUM.Policies] (X86) HKEY_USERS\S-1-5-21-1129176906-220587917-378845204-1001\Software\Microsoft\Windows\CurrentVersion\Policies\System | DisableRegistryTools : 0  -> FOUND
[PUM.Policies] (X64) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System | DisableRegistryTools : 0  -> FOUND
[PUM.Policies] (X86) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System | DisableRegistryTools : 0  -> FOUND
[PUM.DesktopIcons] (X64) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel | {20D04FE0-3AEA-1069-A2D8-08002B30309D} : 1  -> FOUND
[PUM.DesktopIcons] (X64) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel | {59031a47-3f72-44a7-89c5-5595fe6b30ee} : 1  -> FOUND
[PUM.DesktopIcons] (X86) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel | {20D04FE0-3AEA-1069-A2D8-08002B30309D} : 1  -> FOUND
[PUM.DesktopIcons] (X86) HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel | {59031a47-3f72-44a7-89c5-5595fe6b30ee} : 1  -> FOUND

¤¤¤ Scheduled tasks : 0 ¤¤¤

¤¤¤ Files : 0 ¤¤¤

¤¤¤ HOSTS File : 1 ¤¤¤
[C:\windows\System32\drivers\etc\hosts] 127.0.0.1       localhost

¤¤¤ Antirootkit : 0 (Driver: NOT LOADED [0xc000036b]) ¤¤¤

¤¤¤ Web browsers : 0 ¤¤¤

¤¤¤ MBR Check : ¤¤¤
+++++ PhysicalDrive0: Volume0 +++++
--- User ---
[MBR] 4a234ddf0cd3ac2ed5d1644db3bfcab0
[BSP] 1ec40e4f0fc04db2fad0138c3947ff35 : Windows Vista/7/8 MBR Code
Partition table:
0 - [XXXXXX] ACER (0x27) [VISIBLE] Offset (sectors): 2048 | Size: 12288 MB
1 - [ACTIVE] ACER (0x27) [VISIBLE] Offset (sectors): 25167872 | Size: 100 MB
2 - [XXXXXX] NTFS (0x7) [VISIBLE] Offset (sectors): 25372672 | Size: 566116 MB
3 - [XXXXXX] NTFS (0x7) [VISIBLE] Offset (sectors): 1184778240 | Size: 375369 MB
User = LL1 ... OK
Error reading LL2 MBR! ([57] The parameter is incorrect. )


============================================
RKreport_DEL_07242014_164607.log - RKreport_DEL_07242014_165311.log - RKreport_DEL_07242014_181956.log - RKreport_SCN_07242014_164405.log
RKreport_SCN_07242014_165228.log - RKreport_SCN_07242014_173530.log - RKreport_SCN_07242014_174128.log - RKreport_SCN_07242014_180753.log
RKreport_SCN_07242014_181725.log

(My Lockbox is a legitimate program, but I believe the PUM values to be malware).

 

 

I have also run an OTL scan with settings & custom scans (as directed by an expert on the Avira forums when I had a previous malware problem):

http://pastebin.com/BNLDzitX  (OTL log)

http://pastebin.com/1E1Mndgj  (OTL 'Extras.txt')

 

I am currently running an ESET Online scan, but it is at 80% and has been going for 19+ hours.

 

EDIT:  I have attached the DDS log.

Also, I have attached a screenshot of the Avira Control Panel.  Normally, green squares should be in place of the gray squares next to the real-time protection, firewall, web protection and mail protection.  At a minimum, they would be red if I had turned them off (then, you could click them to turn them back on and they would go back to green).  The message talks about upgrading my product, but my product is a best product Avira sells, and my subscription expires in 2016.  My wallpaper also disappeared, this occured some after the alerts about my Win7 needed to be registered (but, again, it is a legitimate product, and I've never had problems like this before).

 

EDIT:  The ESET scan finally finished and found nothing.

 

Thank you for any assistance.

 

UPDATE/EDIT:  I was able to reinstall malwarebytes, but it detected nothing when I scanned in safe mode.  I shut down my pc just to wait and give it a break, but now I essentially cannot login outside of safe mode.  When not in safe mode, I click my account, enter my password, then the welcome screen displays for ~2min, then my cursor on a field of black appears.  I have waited there for more than 7min on 3 tries, then I get impatient and force a shutdown.  Normally, my desktop takes no more than 30 seconds to appear after entering my password.

Attached Files

  • Attached File  dds.txt   23.99KB   4 downloads
  • Attached File  001.png   349.03KB   0 downloads

Edited by Schwarzmaler255, 25 July 2014 - 08:22 PM.


BC AdBot (Login to Remove)

 


#2 Schwarzmaler255

Schwarzmaler255
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 26 July 2014 - 07:02 PM

Update:  I reimaged my computer, reinstalled Windows and seem to have regained control of my PC.

Also, I believe I found the culprit:

" C:\Windows.old\Users\*Account Name*\AppData\Roaming\Real\Update\UpgradeHelper\RealPlayer\10.90 " has had the ownership and security details modified by some unknown source (the '.old' used to not be there). 

The malware took away control from Admins and System and left two long strings (beginning with S, each containg many numerals and three dashes) with full control of that folder.  I am attempting to regain ownership of that folder now.  I have been able to delete and run scans on all other old data, but my reinstalled Avira Internet Security encounters a runtime error and crashes when attempting to scan that folder.


Edited by Schwarzmaler255, 26 July 2014 - 07:04 PM.


#3 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,769 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:38 PM

Posted 30 July 2014 - 02:15 PM

Hello and welcome to Bleeping Computer!

I am HelpBot: an automated program designed to help the Bleeping Computer Staff better assist you! This message contains very important information, so please read through all of it before doing anything.

We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help. No one is ignored here.

To help Bleeping Computer better assist you please perform the following steps:

***************************************************

step1.gif In order to continue receiving help at BleepingComputer.com, YOU MUST tell me if you still need help or if your issue has already been resolved on your own or through another resource! To tell me this, please click on the following link and follow the instructions there.

CLICK THIS LINK >>> http://www.bleepingcomputer.com/logreply/542229 <<< CLICK THIS LINK



If you no longer need help, then all you needed to do was the previous instructions of telling me so. You can skip the rest of this post. If you do need help please continue with Step 2 below.

***************************************************

step2.gifIf you still need help, I would like you to post a Reply to this topic (click the "Add Reply" button in the lower right hand of this page). In that reply, please include the following information:

  • If you have not done so already, include a clear description of the problems you're having, along with any steps you may have performed so far.
  • A new DDS log. For your convenience, you will find the instructions for generating these logs repeated at the bottom of this post.
    • Please do this even if you have previously posted logs for us.
    • If you were unable to produce the logs originally please try once more.
    • If you are unable to create a log please provide detailed information about your installed Windows Operating System including the Version, Edition and if it is a 32bit or a 64bit system.
    • If you are unsure about any of these characteristics just post what you can and we will guide you.
  • Please tell us if you have your original Windows CD/DVD available.
  • Upon completing the above steps and posting a reply, another staff member will review your topic and do their best to resolve your issues.

Thank you for your patience, and again sorry for the delay.

***************************************************

We need to see some information about what is happening in your machine. Please perform the following scan again:

  • Download DDS by sUBs from the following link if you no longer have it available and save it to your destop.

    DDS.com Download Link
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explanation about the tool. No input is needed, the scan is running.
  • Notepad will open with the results.
  • Follow the instructions that pop up for posting the results.
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet.

Information on A/V control can be found HERE.

As I am just a silly little program running on the BleepingComputer.com servers, please do not send me private messages as I do not know how to read and reply to them! Thanks!

#4 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,769 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:38 PM

Posted 31 July 2014 - 12:20 PM

You have stated that you no longer need help with this issue, therefore I am closing this topic. If that is not the case and you need or wish to continue with this topic, please send any Moderator a Personal Message (PM) that you would like this topic re-opened.

As I am just a silly little program running on the BleepingComputer.com servers, please do not send me private messages as I do not know how to read and reply to them! Thanks!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users