Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Mouse Question(s)


  • Please log in to reply
13 replies to this topic

#1 MelissaPleases

MelissaPleases

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Now in the Heartland of the USA
  • Local time:09:47 PM

Posted 23 July 2014 - 04:16 PM

Hi, all. I recently purchased a new optical mouse - GearHead MPT4100RDF 2.4GHz wireless. I haven't been able to locate a manual for it anywhere online - and there was no manual when I bought it. I've noticed a couple of annoyances that I hope someone can help me address. My computer is in a powered on and running state the vast majority of the time. I do a regular full shutdown every day or two, but beyond that, it's usually running.

 

The first issue I have is that from time to time, and for no apparent reason, the mouse begins to act as though it's "fighting" running applications for system resources - the cursor jerks across the screen, rather than moving smoothly. This is random, and doesn't seem to be related to any running programs.

 

Second, when I leave the computer for anything more than say, a half hour, when I come back, the mouse is "frozen" for several seconds. I can move it all I want, click on either button, but it takes 10 - 15 seconds for it to begin responding again. I've never had an issue like this.

 

I've made sure that the drivers are updated to the latest version. The receiver is not plugged into the back of the tower, it's plugged into a USB 3.0 port on the top front, so I can't imagine that it's having trouble receiving signals from the mouse. One thing that just occurred to me, and I will try this to see what happens, is that perhaps the receiver should not be plugged into a USB 3.0 port. I've just moved it, and if that corrects the problem, I'll report back. In the meantime, if anyone has any idea what else might cause this, I would appreciate the help. :)


Snowden03.png

~   Notorious Thread Killer   ~
Case: CoolerMaster Storm Trooper Full ATX | Motherboard: GIGABYTE GA-Z170X | CPU: Intel Core i7-6700K 8M Skylake Quad-Core | GPU: MSI Radeon R9 390X 8GB 512-Bit | PSU: EVGA 80 PLUS GOLD 850 W | RAM: Corsair Vengeance DDR4 SDRAM [4x8GB] Audio: Integrated Creative Sound Core 3D 5.1 | Internal Storage: Samsung 2 TB HDD | Seagate 1 TB HDD | Samsung 500GB SSD [x2] | Mushkin 500GB SSD | External Storage: Seagate 2TB | Optical Drive: Lite-On iHAS324 Dual Layer

Display 1: AOC I2757Fh 27" | Display 2 & 3: LG 24MP57HQ-P 24" | Operating Systems: OS 1: Windows 10 Professional | OS 2: Linux Mint Cinnamon | OS 3: Windows 7 Ultimate x-64 | Antivirus: MS Security Essentials | Firewall: Windows Firewall


BC AdBot (Login to Remove)

 


#2 wpgwpg

wpgwpg

  • Members
  • 1,149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US of A
  • Local time:11:47 PM

Posted 23 July 2014 - 04:32 PM

 Your computer is probably going into sleep mode when unattended for a while, and it's normal for it to take a few seconds to come out of that.  I think moving that mouse adapter to a USB 2 port is a good idea.  FWIW I personally don't like wireless mice.  The batteries go out at the most inconvenient times, and it's too easy to drop them on the floor.  With a corded mouse, if you drop it, the cord stops it before it can hit the floor.


Everyone with a computer should back his system up to an external hard drive regularly.  :thumbsup:

#3 MelissaPleases

MelissaPleases
  • Topic Starter

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Now in the Heartland of the USA
  • Local time:09:47 PM

Posted 23 July 2014 - 05:45 PM

I have mixed feelings about wired vs. wireless. My main objection to wired, at this point, is the tangled mess of cables I already have...

 

As far as going into sleep mode: I thought that I had Win 7 configured to never go into sleep mode. I'll have to check that. Thanks for the tip.

 

Oh, and switching USB ports hasn't resolved it, but I also have to note that the mouse receiver is USB 2.0, not 3.0. So, it does make sense to leave it in a 2.0 port.

 

Edit: I've checked, and Win 7 is set to never sleep or hibernate, so I don't think that's the problem.


Edited by MelissaPleases, 23 July 2014 - 05:58 PM.

Snowden03.png

~   Notorious Thread Killer   ~
Case: CoolerMaster Storm Trooper Full ATX | Motherboard: GIGABYTE GA-Z170X | CPU: Intel Core i7-6700K 8M Skylake Quad-Core | GPU: MSI Radeon R9 390X 8GB 512-Bit | PSU: EVGA 80 PLUS GOLD 850 W | RAM: Corsair Vengeance DDR4 SDRAM [4x8GB] Audio: Integrated Creative Sound Core 3D 5.1 | Internal Storage: Samsung 2 TB HDD | Seagate 1 TB HDD | Samsung 500GB SSD [x2] | Mushkin 500GB SSD | External Storage: Seagate 2TB | Optical Drive: Lite-On iHAS324 Dual Layer

Display 1: AOC I2757Fh 27" | Display 2 & 3: LG 24MP57HQ-P 24" | Operating Systems: OS 1: Windows 10 Professional | OS 2: Linux Mint Cinnamon | OS 3: Windows 7 Ultimate x-64 | Antivirus: MS Security Essentials | Firewall: Windows Firewall


#4 wpgwpg

wpgwpg

  • Members
  • 1,149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US of A
  • Local time:11:47 PM

Posted 23 July 2014 - 06:12 PM

 Windows has the ability to steal memory from dormant applications and page it out to the paging file.  This could easily be what's happening, causing a delay when you start using the computer again, and then it has to page things back in.  Since the hard drive is close to a million times slower than RAM, this can cause a delay.  That could be what's going on.


Everyone with a computer should back his system up to an external hard drive regularly.  :thumbsup:

#5 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:11:47 PM

Posted 23 July 2014 - 06:21 PM

 The batteries go out at the most inconvenient times,

 

That is true for older wireless mouse. The new technology in mouse (even wireless keyboard) don't require you to change the batteries for at least 6 months unless you use it heavily for gaming. I have a Microsoft Exlorer Touch Wireless mouse that I bought last christmas and I haven't changed the battery since then. Here's the specs (look at the bottom):

 

mousebattery.jpg

 

 

 

 

But I agree with you. The OP's computer is probably going into a deep sleep and it takes time before the mouse reacts to any movement. The OP should also try plugging the USB receiver on the front end of the CPU where there is a direct line of communication between the mouse and the receiver.

 

 

Cheers!

 

 

....


sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 


#6 old rocker

old rocker

  • Members
  • 467 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:East Tennessee
  • Local time:11:47 PM

Posted 23 July 2014 - 07:05 PM

You may want to check these settings and see if anything improves.

Open Control Panel > Power Options

Select the Change plan settings link corresponding to the Power plan you have selected.

Select the Change advanced power settings link on this window.

Scroll down and expand the + sign next to USB selective suspend setting. If enabled set to disable click Apply and OK and close all windows.

Next

Open Control Panel > System

Select Device Manager Link

Expand Universal Serial Bus controllers

Right click each hub reference and left click Properties

Go to the Power Management Tab and uncheck Allow the computer to turn off this device to save power.

 

P.S. Most USB 3.0 ports are backwards compatible with USB 2.0



#7 Kilroy

Kilroy

  • BC Advisor
  • 3,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:10:47 PM

Posted 24 July 2014 - 07:56 AM

P.S. Most USB 3.0 ports are backwards compatible with USB 2.0

 

This partly depends on the devices.  I have a video camera that will not work on a USB 3 port that works just fine on a USB 2.

 

I think you're on the right track with the USB power settings.



#8 MelissaPleases

MelissaPleases
  • Topic Starter

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Now in the Heartland of the USA
  • Local time:09:47 PM

Posted 24 July 2014 - 08:27 AM

@badr0b0t: I'm a bit confused - I have the computer configured to never enter sleep or hibernation modes. Is there something I'm missing regarding sleep, other than the settings in the Power Plan options?

 

@old rocker: USB selective suspend was enabled; I've disabled it and will report back to let you know what happens. Regarding the USB Power Management tabs, none were set to Allow computer to turn off the device; however, something to note: In Device Manager, under Other devices, there is an entry labeled Universal Serial Bus (USB) Controller that Windows is telling me has no driver installed. Attempting to have Windows update the driver fails, and since I have no idea what device this entry is referring to, I'm not sure how to proceed. Apparently, I'll have to disconnect each USB device one at a time until I track down the culprit.


Edited by MelissaPleases, 24 July 2014 - 08:28 AM.

Snowden03.png

~   Notorious Thread Killer   ~
Case: CoolerMaster Storm Trooper Full ATX | Motherboard: GIGABYTE GA-Z170X | CPU: Intel Core i7-6700K 8M Skylake Quad-Core | GPU: MSI Radeon R9 390X 8GB 512-Bit | PSU: EVGA 80 PLUS GOLD 850 W | RAM: Corsair Vengeance DDR4 SDRAM [4x8GB] Audio: Integrated Creative Sound Core 3D 5.1 | Internal Storage: Samsung 2 TB HDD | Seagate 1 TB HDD | Samsung 500GB SSD [x2] | Mushkin 500GB SSD | External Storage: Seagate 2TB | Optical Drive: Lite-On iHAS324 Dual Layer

Display 1: AOC I2757Fh 27" | Display 2 & 3: LG 24MP57HQ-P 24" | Operating Systems: OS 1: Windows 10 Professional | OS 2: Linux Mint Cinnamon | OS 3: Windows 7 Ultimate x-64 | Antivirus: MS Security Essentials | Firewall: Windows Firewall


#9 JohnC_21

JohnC_21

  • Members
  • 23,663 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 PM

Posted 24 July 2014 - 10:51 AM

The Device Manager setting for USB controller could possibly be your USB 3.0 controller. Here is the support page for your motherboard.



#10 old rocker

old rocker

  • Members
  • 467 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:East Tennessee
  • Local time:11:47 PM

Posted 24 July 2014 - 11:18 AM

Open Control Panel > Open System

On the left side Open Advanced system settings

Click on Enviornmental Variables

Click the New... button under the System variables

In the Variable name: type this... DEVMGR_SHOW_NONPRESENT_DEVICES

In the Variable value: type the number... 1

click OK and reboot the system.

 

Open Control Panel > Open System

On the left side Open Device Manager

On the toolbar at the top of the window click View

On the dropdown click Show hidden devices.

 

This little trick will show you every device (including ghost devices) that has ever been connected to your system.
We used it in the XP days when Computer Manufacturers were using a common image to install Operating Systems on
Intel and AMD Systems to remove erroneus hardware.

The Icon for Devices not connect to your system will be lighter display slightly greyed out compared to a connected device. It will not harm your system to
uninstall these devices (especially if it is something you no longer use.) Right click and choose uninstall.

 

(You may be prompted to uninstall the drivers for the device. Only Do This For Devices You No Longer Have!)

 

You can also uninstall the USB controller under Other Devices.

 

When you are finished, Highlight the first entry in the list (usually the PC name.)

Go to the toolbar and click Action > Scan for hardware changes. Your system will attempt (and 99.9% succeed) to properly configure all present devices.



#11 MelissaPleases

MelissaPleases
  • Topic Starter

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Now in the Heartland of the USA
  • Local time:09:47 PM

Posted 24 July 2014 - 01:08 PM

@JohnC_21: The driver download corrected the issue - it was, as you thought, the USB 3.0 controller. The driver is now installed and I have no warnings in device manager.

 

@old rocker: Thanks for that - I love learning about little tricks like this. I've copied and pasted your post to a text file for future reference. I'll go through the process when I return from taking the cat to see the vet - he's not going to be happy with me!

 

As an aside, I never stop being surprised by the fact that the more I learn about computers, the less I find that I truly know... That's why this site is such an invaluable resource.


Snowden03.png

~   Notorious Thread Killer   ~
Case: CoolerMaster Storm Trooper Full ATX | Motherboard: GIGABYTE GA-Z170X | CPU: Intel Core i7-6700K 8M Skylake Quad-Core | GPU: MSI Radeon R9 390X 8GB 512-Bit | PSU: EVGA 80 PLUS GOLD 850 W | RAM: Corsair Vengeance DDR4 SDRAM [4x8GB] Audio: Integrated Creative Sound Core 3D 5.1 | Internal Storage: Samsung 2 TB HDD | Seagate 1 TB HDD | Samsung 500GB SSD [x2] | Mushkin 500GB SSD | External Storage: Seagate 2TB | Optical Drive: Lite-On iHAS324 Dual Layer

Display 1: AOC I2757Fh 27" | Display 2 & 3: LG 24MP57HQ-P 24" | Operating Systems: OS 1: Windows 10 Professional | OS 2: Linux Mint Cinnamon | OS 3: Windows 7 Ultimate x-64 | Antivirus: MS Security Essentials | Firewall: Windows Firewall


#12 JohnC_21

JohnC_21

  • Members
  • 23,663 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:47 PM

Posted 24 July 2014 - 02:52 PM

If you still get the jerky movement, it could be interference with the wireless router if it and the bluetooth are on the same frequency. Another thing you can try is disable "Enhance Pointer Precision" in Mouse Settings and move the slider two clicks to the right.

#13 MelissaPleases

MelissaPleases
  • Topic Starter

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Now in the Heartland of the USA
  • Local time:09:47 PM

Posted 24 July 2014 - 10:48 PM

It's always the simple answer, isn't it? Changing the mouse settings as you suggest fixed the jerkiness, but it still takes a few seconds to respond after sitting for a while. I'm wondering if it's just a bug with this particular make and model...


Snowden03.png

~   Notorious Thread Killer   ~
Case: CoolerMaster Storm Trooper Full ATX | Motherboard: GIGABYTE GA-Z170X | CPU: Intel Core i7-6700K 8M Skylake Quad-Core | GPU: MSI Radeon R9 390X 8GB 512-Bit | PSU: EVGA 80 PLUS GOLD 850 W | RAM: Corsair Vengeance DDR4 SDRAM [4x8GB] Audio: Integrated Creative Sound Core 3D 5.1 | Internal Storage: Samsung 2 TB HDD | Seagate 1 TB HDD | Samsung 500GB SSD [x2] | Mushkin 500GB SSD | External Storage: Seagate 2TB | Optical Drive: Lite-On iHAS324 Dual Layer

Display 1: AOC I2757Fh 27" | Display 2 & 3: LG 24MP57HQ-P 24" | Operating Systems: OS 1: Windows 10 Professional | OS 2: Linux Mint Cinnamon | OS 3: Windows 7 Ultimate x-64 | Antivirus: MS Security Essentials | Firewall: Windows Firewall


#14 MelissaPleases

MelissaPleases
  • Topic Starter

  • Members
  • 537 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Now in the Heartland of the USA
  • Local time:09:47 PM

Posted 25 July 2014 - 08:53 AM

@old rocker: I followed your suggestion, and found a ton of stuff that's no longer a part of my system. I uninstalled evrything that was greyed out.


Snowden03.png

~   Notorious Thread Killer   ~
Case: CoolerMaster Storm Trooper Full ATX | Motherboard: GIGABYTE GA-Z170X | CPU: Intel Core i7-6700K 8M Skylake Quad-Core | GPU: MSI Radeon R9 390X 8GB 512-Bit | PSU: EVGA 80 PLUS GOLD 850 W | RAM: Corsair Vengeance DDR4 SDRAM [4x8GB] Audio: Integrated Creative Sound Core 3D 5.1 | Internal Storage: Samsung 2 TB HDD | Seagate 1 TB HDD | Samsung 500GB SSD [x2] | Mushkin 500GB SSD | External Storage: Seagate 2TB | Optical Drive: Lite-On iHAS324 Dual Layer

Display 1: AOC I2757Fh 27" | Display 2 & 3: LG 24MP57HQ-P 24" | Operating Systems: OS 1: Windows 10 Professional | OS 2: Linux Mint Cinnamon | OS 3: Windows 7 Ultimate x-64 | Antivirus: MS Security Essentials | Firewall: Windows Firewall





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users