Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Help Setting Up DD-WRT e1000 Router for Home Network


  • Please log in to reply
19 replies to this topic

#1 bonnie848

bonnie848

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 22 July 2014 - 02:58 PM

My son installed dd-wrt software on our e1000 router. I just had a cable guy here who thinks the network is not setup correctly, but couldn't give me more information than that. I have a wireless laptop computer, wireless desktop computer, 1 wireless printer, 1 wireless print server, cable phone, a roku box, and a Kindle (wifi).

 

We've had trouble with the roku box since this new software was installed on the router. We tried a couple of times to setup port-forwarding but each time we use the IP address of the device in the setup, the address changes. The cable guy says my laptop for example, is set to obtain IP address automatically, while the router is set for DHCP with starting IP address, and 30 maximum users. There were static DNS addresses which the cable guy talked me into removing. I wrote down the numbers that were in there just in case.

 

I was wondering if there was anyone out there who knew about this and could help me get it setup properly while also explaining to me what we're doing,



BC AdBot (Login to Remove)

 


#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,267 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 PM

Posted 22 July 2014 - 03:09 PM

If you are using DHCP, adding the IP of the device for port forwarding won't work, as the device will be assigned a new IP address every time it boots up and reconnects. Try assigning static IP addresses to each device.

 

See step #4: http://www.flashrouters.com/blog/2012/09/14/how-to-use-port-forwarding-with-dd-wrt-routers-dd-wrt-tutorial/



#3 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 22 July 2014 - 05:37 PM

Okay, I tried to do this by first following the instructions for setting up a static DHCP from the link inside of your link which goes to: http://www.dd-wrt.com/wiki/index.php/Static_DHCP

 

I used my laptop's hostname, MAC Address, stayed outside of the DHCP range of addresses (192.168.1.169~198) and used 192.168.1.214 in the static leases section. I rebooted the computer and the router, and ended up losing my connection on my laptop. I had to go back in and remove the services > static leases section. This is the problem with trying to follow these directions. Everything is presented piecemeal and I have not been able to find the beginning steps. I thought maybe this link was help, but there must be a step missing. There must be something else I need to set on the computer, maybe? The other thing I'm wondering about is how I'll be able to find all this information on other devices like Roku box, printer, etc.



#4 sflatechguy

sflatechguy

  • BC Advisor
  • 2,267 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 PM

Posted 22 July 2014 - 07:18 PM

If you are using static DHCP on the router, you need to make sure your devices are still configured to get their IP addresses from DHCP. How you configure that depends on the device, but most are automatically configured that way. To check in Windows: http://windows.microsoft.com/en-us/windows/change-tcp-ip-settings#1TC=windows-7

 

You also need to make sure you entered the MAC address properly, as well as the computer/device name. If the device has an Ethernet port and WiFi, there will be two MAC addresses, one for the Ethernet port and one for the WiFi. Make sure you are using the correct address based on your connection.

 

To find the MAC address on a Kindle, Menu>Settings>Menu>Device Info.

To find the MAC address on a Roku box: http://support.roku.com/entries/221238-Where-can-I-find-the-wireless-MAC-and-or-wired-MAC-addresses-of-my-Roku-digital-video-player-

 

I don't know what kind of cable phone, printer or print server you are using. Try checking the documentation that came with those devices, or looking at the back, similar to where it's found on the Roku box.

 

In addition, you need to save after each new entry is added to the Static DHCP page. Just adding them all and then saving will erase all but the last entry.

 

If you are using static DHCP, you also need to ensure that the Universal Plug N Play feature on the router is turned off.



#5 AngryRaisin

AngryRaisin

  • Members
  • 235 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Orange County, CA, US
  • Local time:08:32 PM

Posted 23 July 2014 - 01:15 AM

after you set your static ip's in the router, your laptop ip needs to be refreshed you can drop into a command prompt and run: ipconfig /renew  OR  restart your computer. Sometimes the router needs to be restarted as well.

 

You might be better off picking up a cheap new router - DD-WRT is fun for people who like to play with the added functionality - not so fun for normal people.


Edited by AngryRaisin, 23 July 2014 - 01:16 AM.


#6 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 23 July 2014 - 03:47 PM

Wow! Thanks for your quick responses. I think what was key was to reboot both the router and the device after setting the address static. I setup two computers, and two kindles so far, and everything seems to be working well. I used the router address for the DNS. Is that okay (I seem to remember reading that somewhere). I haven't attempted to setup the printers or Roku yet. The Roku  is connected using Nano Powerline so this gets a little confusing. Do I use the MAC address on the powerline as well as setup an address for the Roku?



#7 sflatechguy

sflatechguy

  • BC Advisor
  • 2,267 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 PM

Posted 23 July 2014 - 04:17 PM

Glad that was helpful and you got at least some of the devices connected.

 

Yes, you will want to set the default gateway as your DNS server on all devices. In the router, you can either use the ISP's default DNS servers, or add your own. You can experiment with that on the router to see which configuration is the most reliable and the fastest.

 

As for the Nano Powerline, the MAC address should be on the back of the adapter, on the product label. If you are going to use static DHCP, you will have to set the Roku and printers up the same way you set up the other devices, otherwise your port forwarding probably won't work.



#8 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 23 July 2014 - 05:41 PM

Thanks for your help again Sflatechguy.

 

So the ISP default DNS servers are entered in the DHCP server part of the router, correct?

 

I'll probably try to setup the printer with the internal wifi first and see how that goes before messing with the Roku. I may have more questions for you when I get there.



#9 sflatechguy

sflatechguy

  • BC Advisor
  • 2,267 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 PM

Posted 23 July 2014 - 07:33 PM

No, not in the DHCP server section. There is a separate section for DNS configuration. Your ISP has probably already pushed out their DNS IP address to your router. But if you want, you can add and/or edit those settings to use other DNS servers instead.

 

More info here: http://www.question-defense.com/2008/12/29/add-static-dns-entries-to-dd-wrt-router-firmware

 

And you're welcome.


Edited by sflatechguy, 23 July 2014 - 07:34 PM.


#10 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 24 July 2014 - 06:29 AM

Okay, I followed the instructions in the link you supplied, substituting my ISP's DNS numbers for the router addresses. But when I ping the router from command window, it comes back with cannot find host router. Did I do something wrong?



#11 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 24 July 2014 - 06:35 AM

Just looking at this again. I copied and pasted these lines and then changed the DNS addresses to my ISPs addresses.

 

address=/host.domain.com/secondary.domain.com/192.168.1.10< changed this
address=/router.domain.com/wrt54g.domain.com/192.168.1.1< and this
 
but I see this says wrt54g and I have an e1000. Should I edit that as well?
Also my primary (how I get into my router) is 192.168.1.10 if I need to use these addresses, should I switch them?
 
 


#12 sflatechguy

sflatechguy

  • BC Advisor
  • 2,267 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 PM

Posted 24 July 2014 - 11:24 AM

Before we proceed, a brief tutorial on DNS is probably in order. DNS is basically the telephone directory of the Internet. When you type a Web address into a browser, your device will send out a DNS query to find out the public IP address that is associated with that Web address. The DNS server that holds the authoritative records for that Web address will send the IP address back to your device, and your device will then request the Web page from that IP address.

 

So because your router is only serving as the DNS server for your local network, it needs the IP addresses of one or more public DNS servers in order to properly route traffic between your router and the Internet. If you are going to replace the DNS servers used by your ISP, you need to use something other than your router; for instance, you could use Google's public DNS servers, whose IP addresses are 8.8.8.8 and 8.8.4.4 .

 

That said, you would need to add the DNS address of the public DNS server to the end of the second line, and you would need to add multiple entries for each DNS server you want to use. And since you are using an e1000, you will want to change the wrt54g to something else.

 

Unfortunately, there is no easy way to change your DNS settings in dd-wrt. If you aren't comfortable using the command line, you may want to just stick with the ISP's default DNS servers.



#13 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 24 July 2014 - 11:44 AM

"That said, you would need to add the DNS address of the public DNS server to the end of the second line, and you would need to add multiple entries for each DNS server you want to use. And since you are using an e1000, you will want to change the wrt54g to something else."

 

Okay, so where exactly do I do this?

Should I change the wrt54g to e1000?

 

I told you that I added the ISP DNS addresses to the Additional DNSMasQ Options box.

And on my Setup > Basic Setup > Network Setup > Router IP > Local DNS I have 0.0.0.0

For all of the Setup > Basic Setup > Network Setup > Static DNS 1...3 I have 0.0.0.0

 

My ISP gave me the two addresses they use, but where do I put them?

 

Is the command line option something difficult to use?



#14 sflatechguy

sflatechguy

  • BC Advisor
  • 2,267 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:32 PM

Posted 24 July 2014 - 12:20 PM

Yes, change that to e1000, if you are using the command line, which is more difficult. The graphic user interface is much easier to work with, so I recommend you stick with that.

 

In the Local DNS setting, enter the IP address of your router. In the Static DNS setting, enter the IP addresses of your ISP's DNS servers, or any other public DNS servers you may wish to use.

 

Using 0.0.0.0 in both cases will simply route DNS queries to an unspecified address -- basically, nowhere.

 

Hope that helps.



#15 bonnie848

bonnie848
  • Topic Starter

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Local time:11:32 PM

Posted 24 July 2014 - 01:31 PM

Okay, so should I use my ISP or Public DNS addresses in the Additional DNSMasQ Options box or my router address? And if my router address= 192.168.1.10 should that be the primary or secondary, and what would the other be (192.168.1.1?)?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users