Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Installing mint 17 in a uefi system


  • Please log in to reply
10 replies to this topic

#1 heyyou325

heyyou325

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:33 PM

Posted 22 July 2014 - 10:23 AM

I've had another thread on this http://www.bleepingcomputer.com/forums/t/541175/uefi/, but slowly have been figuring things out.  Mint forums have a good tutorial on this  http://forums.linuxmint.com/viewtopic.php?f=42&t=163126.  I have a used gateway NE56R41u laptop with 500gb storage, 4 gb ram, 2.2 ghz dual core intel pentium processor, with windows 8.1 and uefi on.  I've disabled secure boot, and turned off fast boot.  Now my problem is after I install mint, and try to restart, the computer won't shutdown.  It gets to where the dvd drive opens, then doesn't progress past there.  I've tried leaving the dvd in and closing the drive and still nothing.  Shut the power off, and it doesn't go ahead and install.  Nothing new added to the partitions.  One time I left it set that way for 45 minutes, and over an hour the next while I've watched the news, nothing.  Is there a way to force the computer to finish shutting down and restarting.  

 

My partition table is:     

Partition           File system        Label             Size                  Used             Unused           Flags

 

/dev/sda1            ntfs                recovery       400,000 mi b    237.53MiB      162.47MiB       hidden,  diag

 

/Dev/sda2            fat32              ESP              300.00MiB         52.58MiB      247.42MiB        boot

 

/dev/sda3            unknown                             128.00MiB                  --                  --              msftres

 

/dev/sda4            ntfs                Gateway        205.08GiB          31.77GiB     173.31GiB        msftdata

 

/dev/sda7            ext4               swap              3.99GiB             136.30MiB       3.86GiB      

 

/dev/sda 8             ext4                                    11.72GiB           345.73MiB      11.38GiB

 

/dev/sda9            ext4                                      10.74GiB           327.61MiB      10.42GiB

 

/dev/sda10          ext4                                      10.74GiB           327.61MiB      10.42GiB       

 

/dev/sda11          ext4                                      10.74GiB           327.61MiB      10.42.GiB

 

/dev/sda12          ext4              home              195.73GiB              3.25GiB      192.48GiB

 

/dev/sda5            ntfs                                      450.00MiB          308.85MiB      141.15MiB          hidden, diag

 

/dev/sda6            ntfs        Push button reset    15.76GiB           12.84GiB            2.92GiB          hidden, diag

  I'm putting mint on sda8, home on sda12, and of course boot is sda2.  Windows works fine after all is said and done.  And the partitions I want to use are maked as I want them before I say install.  If I'm not mistaken, nothing should change until after the restart.  After I start the computer back up, doing a restart doesn't help.  Any help is appreciated.



BC AdBot (Login to Remove)

 


#2 heyyou325

heyyou325
  • Topic Starter

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:33 PM

Posted 22 July 2014 - 05:26 PM

I got the computer to restart by pressing alt ctrl  sysrq  and typing REISUB  where the shutdown was stopped.  Mint is now installed, (extra used space on sda8, root, and sda12 home)  But the boot menu doesn't show mint.  When I try to run the 64 bit boot repair disk which I just downloaded and burned, it doesn't start.  So far the only disk I have that will is mint.  Do I need to stop for about a week and a half while I order disks, or is there something else I can try.  I've been following   http://forums.linuxmint.com/viewtopic.php?f=42&t=163126   and have efi on, secure boot off, and fast boot off.  I just retried, and mint starts, boot repair, 2 copies of zorin 9, and elementary don't.  That's all the 64 bit disks I have.  Any suggestions.  



#3 Guest_Kaosu_*

Guest_Kaosu_*

  • Guests
  • OFFLINE
  •  

Posted 25 July 2014 - 03:30 PM

I don't fully understand your second message because of how you formatted it. I am going to assume you are using Grub. When you reboot, is Grub loading up with menu entries at all? Grub may not have been correctly installed or configured during the installation process, especially since it didn't go as smoothly as it should have. You may just need to manually reinstall and configure Grub using a LiveCD.

 

1) Mount your drives

sudo mount /dev/sda8 /mnt
sudo mount /dev/sda2 /mnt/boot
sudo mount /dev/sda12 /mnt/home

Create any missing directories using the mkdir command. You will probably need to make the efi directory in /boot after mounting it.

 

2) Chroot into your installation

cd /mnt
sudo mount -t proc proc proc/
sudo mount --rbind /sys sys/
sudo mount --rbind /dev dev/
sudo chroot /mnt /bin/bash
export PS1="(chroot) $PS1"

Now you should be using your Mint installation from the LiveCD. We can attempt a repair here by reinstalling and configuring grub.


3) Install required packages

sudo apt-get install grub dosfstools efibootmgr os-prober

4) Grub Installation

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub --recheck --debug

5) Configure Grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

Now you just need to exit your chroot environment and reboot the computer. Hopefully now you will see a Grub menu with all installed operating systems listed.


Edited by Kaosu, 25 July 2014 - 03:41 PM.


#4 heyyou325

heyyou325
  • Topic Starter

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male

Posted 25 July 2014 - 06:44 PM

I've been in the mint forum above, and and they gave me the information 

 

 

I got the computer to restart by pressing alt ctrl  sysrq  and typing REISUB

   However, I still have the same results.   After  looking at the files running mint live, in the partition I thought I'd installed it in, It shows, the files, but when I click on home, there is nothing else there, no other files.  If I try to open the boot file, bin, dev, etc, and so on, they have files in them.  In the boot file there is an efi file, grub, and 8 other files.  In grub, I have fonts, locale, x86_64-efi, grub.cfg, grubenv, and unicode.pf2.  The first 3 are colored, and the last 3 are not.  There are 281 items in the boot file, and 47.4 MiB in it.   I"m not sure I've made a good install on the home file either, but I might have.  I've ordered some disks from osdisk, in case I had problems with the download, or burn.   Gparted shows sda8 now had 4.17 GiB used instead of 3.45MiB, so some of it is there.  The boot partition sda2 only show 55.92 MiB, up from 52.58 MiB.  I'm not sure, but I think that tells me the grub isn't installed.  Then my home sda12 has 3,27GiB used, the same as before.  Not sure if that should have went up or not.  I'm wondering if the secure boot is turned off, even tho it says it is.  Sometimes, when I try to run a live disk, rescue disk, and zorin I get the message "Atapi CDRom: MATbleepA DVDRam UJ8E1 has been blocked by the current security policy" .  I think that's telling me something is stopping it from running.  Sometimes nothing at all happens.  If I run a live disk from a 32 bit operating system, nothing at all happens.  

   I've been real reluctant to do anything in the terminal for some reason, but I will try if you want.  Or I can wait til I get the disks I ordered.  I'm also thinking I should maybe make sure secure boot is off.  It says it is, I just rechecked.  And, do I need to mount the drives, except maybe sda2, as they are all flagged as they should be.  



#5 Guest_Kaosu_*

Guest_Kaosu_*

  • Guests
  • OFFLINE
  •  

Posted 26 July 2014 - 11:44 AM

I've been in the mint forum above, and and they gave me the information 

 

 

I got the computer to restart by pressing alt ctrl  sysrq  and typing REISUB

   However, I still have the same results.   After  looking at the files running mint live, in the partition I thought I'd installed it in, It shows, the files, but when I click on home, there is nothing else there, no other files.  If I try to open the boot file, bin, dev, etc, and so on, they have files in them.  In the boot file there is an efi file, grub, and 8 other files.  In grub, I have fonts, locale, x86_64-efi, grub.cfg, grubenv, and unicode.pf2.  The first 3 are colored, and the last 3 are not.  There are 281 items in the boot file, and 47.4 MiB in it.   I"m not sure I've made a good install on the home file either, but I might have.  I've ordered some disks from osdisk, in case I had problems with the download, or burn.   Gparted shows sda8 now had 4.17 GiB used instead of 3.45MiB, so some of it is there.  The boot partition sda2 only show 55.92 MiB, up from 52.58 MiB.  I'm not sure, but I think that tells me the grub isn't installed.  Then my home sda12 has 3,27GiB used, the same as before.  Not sure if that should have went up or not.  I'm wondering if the secure boot is turned off, even tho it says it is.  Sometimes, when I try to run a live disk, rescue disk, and zorin I get the message "Atapi CDRom: MATbleepA DVDRam UJ8E1 has been blocked by the current security policy" .  I think that's telling me something is stopping it from running.  Sometimes nothing at all happens.  If I run a live disk from a 32 bit operating system, nothing at all happens.  

   I've been real reluctant to do anything in the terminal for some reason, but I will try if you want.  Or I can wait til I get the disks I ordered.  I'm also thinking I should maybe make sure secure boot is off.  It says it is, I just rechecked.  And, do I need to mount the drives, except maybe sda2, as they are all flagged as they should be.  

 

You didn't really answer the question that I asked in my previous post. When you reboot, is Grub loading up with menu entries at all?

 

The REISUB command is used to force a safe reboot when the system is locked up, so issuing this command during the install process just reboots the machine before the installation is complete. However, issuing this command at the end of the installation (after Mint asks you to eject the CD and press enter) should be safe and not cause any issues with the installation process, as long as Mint does not try to do any post-installation configuration beyond this point. While magic SysRQ commands are useful, I don't recommend a novice user plays with them.

 

Are there folders created in your home directory located on /dev/sda12? I believe Mint automatically creates some directories in your home folder. Not having any files (other than folders) in your home directory after the installation is normal, unless you tried using a pre-existing home directory that had your personal files stored on it.

 

Make sure when looking at your boot directory that you're really looking at /dev/sda2. Based on the files you found in /dev/sda2, it seems like Grub is installed. However, that does not mean Grub was correctly configured during the installation process. Also, if you reboot and don't see a Grub menu at all, then that means the bootloader was likely installed on the wrong drive.

 

The instructions I posted are just a simple way to get back into your Mint installation from a LiveCD so you can reinstall and configure Grub manually. From the LiveCD, all of your drives for the Mint installation should be mounted as I showed you. This just emulates mounting your partitions for the installation to the correct mount points, like what would be done for you during the boot process. Once the drives are all mounted correctly, you can chroot into the actual installation and reinstall Grub.

 

To recap, you will want to do the following:

  • Boot into a LiveCD (Mint Live);
  • Follow my instructions in the post above to the letter. Just copy/paste the commands one at a time;
  • Once you have completed all of the steps, properly exit your chroot environment by typing "exit" and then reboot the computer;

The above instructions will do the following:

  • Mount the Mint installation partitions so you can properly chroot into the environment;
  • Chroot into the Mint Installation so you can work with it as a running system;
  • Verify all packages required to correctly configure Grub are installed;
  • Install Grub to the correct drive (Since /dev/sda2 is now mounted as /boot in your running installation);
  • Configure Grub and automatically detect installed operating systems;

Following these steps will ensure that Grub is installed correctly and has a proper configuration. You should now be able to select between Windows and Mint when you reboot your computer. However, if you are still unable to boot into Mint after following my instructions, you might be better off just reinstalling with a new (verified) CD.

 

Finally, I don't think you can boot into Windows 8 without enabling secure boot. Don't quote me on this since I am not a "Windows guy", but I am pretty sure Windows 8 will expect secure boot to be enabled or it will just fail to boot with a security warning. I am unsure if you can change this behavior by installing Windows 8 with secure boot disabled, but most pre-installed versions of Windows 8 will most likely just fail to boot if you disable secure boot.


Edited by Kaosu, 26 July 2014 - 11:52 AM.


#6 heyyou325

heyyou325
  • Topic Starter

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:33 PM

Posted 26 July 2014 - 01:04 PM

I'm sorry, guess I misunderstood the question.  When I booted up, I didn't have a choice, the computer went straight to windows.  However.  I was just looking around in bios and had the option between first boot in windows, or ubuntu.  I chose ubuntu, and I'm in mint.  No choice yet, but I'm betting I'll have to change it there again to go into windows.  I haven't even had time to look thru the new mint yet.  I'm posting this on it.  After going thru things a bit, I will restart and see what happens.  If it is mint again, I will go into bio and change it.  Then I'll know how.  On my other computer, a 32 bit, I get the choice when I boot, without going into bios.  Sorry again for the confusion.  Still not sure whey the laptop wouldn't turn off either, but Oh well.  I also want to see if my other disks will work with mint, when they wouldn't in windows.  System rescue, boot repair, zorin, and pinguy are all supposed to work with uefi, and I have elementary, and at least one other 64 bit I'm not sure about.  They wouldn't work with windows booting first.  I'll get back when I need help.  Thank you.



#7 heyyou325

heyyou325
  • Topic Starter

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male

Posted 26 July 2014 - 01:32 PM

The laptop started i windows.  Went back into bios and boot and reset the order again.  At least now I know what it will take.  Thanks again for the help.  Restarted again, and I get the boot menu at the beginning like I'm supposed to.


Edited by heyyou325, 26 July 2014 - 01:35 PM.


#8 Guest_Kaosu_*

Guest_Kaosu_*

  • Guests
  • OFFLINE
  •  

Posted 26 July 2014 - 03:02 PM

I'm sorry, guess I misunderstood the question.  When I booted up, I didn't have a choice, the computer went straight to windows.  However.  I was just looking around in bios and had the option between first boot in windows, or ubuntu.  I chose ubuntu, and I'm in mint.  No choice yet, but I'm betting I'll have to change it there again to go into windows.  I haven't even had time to look thru the new mint yet.  I'm posting this on it.  After going thru things a bit, I will restart and see what happens.  If it is mint again, I will go into bio and change it.  Then I'll know how.  On my other computer, a 32 bit, I get the choice when I boot, without going into bios.  Sorry again for the confusion.  Still not sure whey the laptop wouldn't turn off either, but Oh well.  I also want to see if my other disks will work with mint, when they wouldn't in windows.  System rescue, boot repair, zorin, and pinguy are all supposed to work with uefi, and I have elementary, and at least one other 64 bit I'm not sure about.  They wouldn't work with windows booting first.  I'll get back when I need help.  Thank you.

 

I think you may have installed Mint using a CSM/Legacy mode to run the installer. Doing this means you installed Mint in BIOS mode, so this explains why you are being sent straight into Windows instead of being prompted by Grub. When you select the operating systems from the BIOS, you're likely just selecting between Windows in EFI mode and Mint in BIOS mode.

 

The installation should have went like this:

  1. Load Mint in EFI mode;
  2. Run the installer and select "something else" to manually partition;
  3. Create your root, home and swap partitions. Select their mount points from the drop-down menu on the creation screen;
  4. Select your boot partition and choose "EFI Boot Partition" from the drop-down menu;
  5. At the bottom there should be a drop-down menu used to install the bootloader on a specific device. Select /dev/sda2 (Your EFI Boot Partition);
  6. Let the installer run and reboot when needed;
  7. Modify your BIOS settings to boot from the correct location;

The above would have installed Mint in EFI mode and Grub should be display instead of booting straight into Windows. Additionally, you could have manually created your partitions before running the installer if you like, but just make sure to set the correct mount points in the installer itself before proceeding.

 

You either made one of the following mistakes:

  1. Mint was installed in BIOS-mode
  2. You didn't install the bootloader on the correct device (The instructions I have already given you in a previous post should fix this issue)

Both of these issues can be fixed post-installation. However, you might find it easier to just reinstall Mint with the correct configuration. You could also just keep this configuration and switch between operating systems using your BIOS.


Edited by Kaosu, 26 July 2014 - 03:34 PM.


#9 heyyou325

heyyou325
  • Topic Starter

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:33 PM

Posted 26 July 2014 - 03:11 PM

OK, thanks for the help.  Everything seems to be working right now.  I have the boot menu before it boots and everything.  I could have messed up installing the boot loader, but I know it was installed in efi mode, the second time on.  I made numerous installations before I found it in the bios in the beginning.  After changing the boot order a couple of times, everything works fine.  Except in windows it shows secure boot is off, and in the bios, or uefi I should say I think, it says it is on.  But it works.  I can also access my other live disks thru mint.  Not with boot up.  The install file is there, so I think they are install-able.  I've been trying to set up mint to play with since my last posting.  



#10 Guest_Kaosu_*

Guest_Kaosu_*

  • Guests
  • OFFLINE
  •  

Posted 26 July 2014 - 03:48 PM

OK, thanks for the help.  Everything seems to be working right now.  I have the boot menu before it boots and everything.  I could have messed up installing the boot loader, but I know it was installed in efi mode, the second time on.  I made numerous installations before I found it in the bios in the beginning.  After changing the boot order a couple of times, everything works fine.  Except in windows it shows secure boot is off, and in the bios, or uefi I should say I think, it says it is on.  But it works.  I can also access my other live disks thru mint.  Not with boot up.  The install file is there, so I think they are install-able.  I've been trying to set up mint to play with since my last posting.  

 

Yeah, you probably just installed the boot loader to the wrong location from the sound of it. 

 

Are you getting the "Secure Boot isn't configured correctly" watermark? If you're not too worried about fixing the issue, you can easily remove the annoying watermark using the following update: http://support.microsoft.com/kb/2902864



#11 heyyou325

heyyou325
  • Topic Starter

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:33 PM

Posted 26 July 2014 - 04:03 PM

I'm not sure what is meant by watermark.   I've read that in other places too.  I haven't got any messages about secure boot.  So far, and I'm not too concerned yet, I'm wondering about why when I look at secure boot thru control panel it says it's off, and when I go into bios (uefi) it says it's on.  Legacy would not work, for installing mint, and it took me a couple tries to see the very bottom line under where it said boot in efi.  Then mint installed, I just needed to get into the boot to set an order for it to boot.  I think.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users