Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Log in reset.


  • Please log in to reply
6 replies to this topic

#1 altonius

altonius

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 20 July 2014 - 09:44 PM

So, when I installed Lubuntu 12.04 on my netbook, I chose to login automatically; no password.

I have my wife's grandson visiting soon (15 yrs old), and given his history of behavior from last year, I deem it necessary to enforce some computer discipline! 

It was real easy to set parental control on my Windows laptop but Lubuntu doesn't seem to have that facility. I tried, using the "users and groups" category, to change the set-up to needing the password to gain access to the system. It won't let me do that. It will let me change the admin. password, but that's all.

Any ideas? Or do I have to reinstall?

Appreciate any info, thanks.



BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,920 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:02:50 AM

Posted 21 July 2014 - 11:02 PM

Try this.

auto login - How to disable autologin in Lubuntu? - Ask ...

Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#3 altonius

altonius
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  
  • Local time:11:50 AM

Posted 22 July 2014 - 01:36 PM

G'day, NickAu1, I followed the links you posted. Couldn't get it to work. In "Users and Groups" where it says "Password: Asked on login", it's greyed out. It's really no big deal, I'll just make sure the grandson doesn't get his grubby, teenage hands on the machine!

So, thanks and goodonyer, mate!



#4 Guest_Kaosu_*

Guest_Kaosu_*

  • Guests
  • OFFLINE
  •  

Posted 22 July 2014 - 06:46 PM

1) Open up /etc/lightdm/lightdm.conf

sudo nano /etc/lightdm/lightdm.conf

2) Look for the line with autologin-user=yourusernamehere

[SeatDefaults]  
greeter-session=unity-greeter  
user-session=ubuntu  
autologin-user=altonius

3) Modify the autologin-user=yourusernamehere line to look like this:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
autologin-user=

Tip: Leaving the field blank after "=" will disable automatic login.

 

4) Save the file by hitting ctrl+x. You should see a message like:

Save modified buffer (ANSWERING "No" WILL DESTROY CHANGES) ?

Your response should be to type "y" (without the quotes) and hit enter twice.

 

5) Reboot your computer

 

You should now see a new menu that has a username and password field.



Edited by Kaosu, 22 July 2014 - 06:57 PM.


#5 altonius

altonius
  • Topic Starter

  • Members
  • 57 posts
  • OFFLINE
  •  

Posted 23 July 2014 - 02:15 PM

Hey Kaosu, this is what I get when entering "sudo nano /etc/lightdm/lightdm.config

[SeatDefaults]
autologin-guest=false
autologin-user=al
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=lightdm-gtk-greeter
user-session=Lubuntu

 

I erased "al" from "autologin-user=" and got nothing. There was also no way to save anything. Thanks anyway. 



#6 Veitch

Veitch

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:50 AM

Posted 23 July 2014 - 02:35 PM

There was also no way to save anything.

Of course it has no effect if you don't save it. Either you forgot the sudo or you don't know how to use nano.

If you forgot sudo, do
sudo nano /etc/lightdm/lightdm.conf
(whatever you preferred editor is)

nano saves your file if you press Ctrl and X to exit, then it asks you if you want to save and you press Y

Edited by Veitch, 23 July 2014 - 02:38 PM.


#7 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:05:50 PM

Posted 24 July 2014 - 03:52 AM

Here is a picture of the message you should see (at the bottom of the Terminal window), when you hit Ctrl+x after editing the file.

(''Ctrl+x'' means hold down the ''Ctrl'' button on the keyboard, and while holding it down press the ''x'' button)


snapshotKubuntu11_zpsed05f499.jpeg

Edited by Al1000, 24 July 2014 - 03:56 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users