Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Task Scheduler Corrupt?


  • Please log in to reply
2 replies to this topic

#1 BrucieK56

BrucieK56

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 19 July 2014 - 12:26 PM

I bought a new computer (two months old) that runs Windows 7 Professional (64-bit), and, after customizing it a bit to suit my needs, I'm now having a bit of trouble with the Task Scheduler. I do NOT get error messages when I open it; and, according to the Task Status list (in the middle pane), it SAYS it's performing the tasks successfully. And I even see the hard drive's little red light blinking when a scheduled task is being performed. But I can't be sure the tasks are really being performed -- b/c the one I care about the most (the automatic creation of System Restore Points) doesn't seem to be working: When I run the System Restore GUI, none of the new System Restore Points allegedly "created successfully" by the Task Scheduler are listed -- just the ones I'd made manually. I downloaded a (great) 3rd-party Restore Point creator that does this task for me automatically, but I'd still like to get to the root of my Task Scheduler problem. Among its errors:

 

1) When I click on Display All Running Tasks in the far right pane of Task Scheduler, I get the message, "Task Scheduler service is not available.  Task Scheduler will attempt to reconnect to it."

 

2) When I click on certain individual tasks in the Task Scheduler Library (far left pane), I often get a blank screen in the middle pane, where the detailed data should be.

 

I've tried numerous solutions proposed online, including deleting certain files lists in the registry. On my computer, the key at:

             HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows

             NT\CurrentVersion\Schedule\TaskCache\Tasks

lists 94 Tasks (!)...

and the key at

             HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows

             NT\CurrentVersion\Schedule\TaskCache\Tree

lists 23 tree files.

             But none of my attempted "fixes" corrects the problem.

 

I've read about five dozen online tech board entries about this, and still can't figure it out; and I've been on the phone with Microsoft three times, and they, too, are clueless about it. Meantime, I don't have any System Restore Points from before the problem began. Ordinarily, I'd just reinstall Task Scheduler from a distribution disk -- or from my wife's computer, which also runs Windows 7 Professional -- but Task Scheduler isn't a stand-alone file that can be copied -- it's a "snap-in" for the Microsoft Management Console (MMC). So I don't know how to replace it.

Finally -- if it's any clue -- the problem seemed to have started around the time I installed Microsoft Security Essentials (which I have since removed), which was also the time I backed up my entire computer onto an external drive.
 

So...any suggestions/responses to the above?



BC AdBot (Login to Remove)

 


#2 dicke

dicke

    Paraclete


  • Members
  • 2,189 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Charlotte, NC
  • Local time:03:12 AM

Posted 19 July 2014 - 03:46 PM

Where did you get security essentials and why did yo delete it?

Also, what is your current security program?

Thanks


Stay well and surf safe [stay protected]

Dick E


#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,545 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:12 AM

Posted 19 July 2014 - 04:38 PM

Perhaps...one of your "customizing" efforts resulted in critical files being deleted or damaged.  It would not be a bad idea to review/reverse those...or reinstall.

 

Is SP1 installed, along with current critical updates?

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users