Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Saving file sometimes makes the file read only


  • Please log in to reply
4 replies to this topic

#1 GoshenBleeping

GoshenBleeping

  • Members
  • 264 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:16 PM

Posted 13 July 2014 - 07:43 PM

System: Windows 7 Home Premium
 
Scenario # 1: I open a Word document. The document is not read only. I save the document - no problem. But occasionally when I save the document, the document suddenly becomes read only and I need to go to the document's properties and change the permission so that the document is no longer read only.
 
Scenario # 2: A folder contains 20 files, none of which are read only. I move the files to another folder - this works fine. But occasionally when I do this, one or two of these files will have their permission changed to be read only, and again I need to go to the file's properties and change the permissions so that the files are no longer read only
 
Why does this happen?


BC AdBot (Login to Remove)

 


#2 kent.miles

kent.miles

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 13 July 2014 - 09:16 PM

What version of word are you using? Where is the file path you are saving and opening files from?



#3 GoshenBleeping

GoshenBleeping
  • Topic Starter

  • Members
  • 264 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:16 PM

Posted 14 July 2014 - 03:07 PM

Sorry, I should have added this info to the original post:

 

Word 2010 (Microsoft Office Home and Student 2010)

Folder - can be any folder, but typically this is on my D drive where I have my personal files. This problem occurs independent of the folder.

 

And I have been keeping up with the latest Microsoft updates.



#4 kent.miles

kent.miles

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:10:16 AM

Posted 14 July 2014 - 04:35 PM

Sounds like folder permission setting.

A few reasons why this could happened are these causes: patching the system, upgrading from one version of Windows to another, and saving files to the top-level directory (C:\). Microsoft knows this is an issue, but for some reason the company doesn’t call it a bug.

 

According to Microsoft, "The Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows (for example, My Documents, Favorites, Fonts, Downloaded Program Files), or a folder that you customized by using the Customize tab of the folder’s Properties dialog box.”

 

Say you save your word document into 'my documents' which windows explorer's path is typically C:\Users\(your user name)\Documents. That file folder maybe set to read only. You would have to change the attribute of that entire folder to read/write permissions.

 

  1. Click Start, click Run, type cmd, and then press Enter. (If the Run command is not listed on the Start menu, Click Start, click All Programs, click Accessories, and then click Run.)
  2. To remove the Read-only attribute, at the command prompt type the following command: "attrib -r drive:\<path>\<foldername>" without the quotation marks :)

Also User Account Control aka UAC could be causing the problem. I am a strong beleiver in security and UAC is all about system security. It prevents programs like virus from running and it logs security issues for us. It can also cause problems like the one we are facing. I would run a test and disable UAC and see if that resolves our problem. Here is a how to:

 

http://windows.microsoft.com/en-us/windows/turn-user-account-control-on-off#1TC=windows-7

 

If the above did not solve the issue let me know and I will walk you through creating a new user profile to see if your windows user profile is corrupt.

 

Thanks,

 

Kent M

 

 

 

 



#5 hamluis

hamluis

    Moderator


  • Moderator
  • 56,115 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:16 PM

Posted 14 July 2014 - 06:01 PM

FWIW:  I agree with MS...Windows typically ignores the "read-only" attribute.  I've only found it operative in two circumstances:

 

a.  Files which may be copied;/moved from a CD/DVD.

b.  Some system files.

 

Louis

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users