Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

MSI laptop won't charge for anything


  • Please log in to reply
2 replies to this topic

#1 WyattConlaed

WyattConlaed

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:46 AM

Posted 08 July 2014 - 02:47 PM

Hello. This has likely been asked before, but I'm getting really irritated and need the help. I have a MSI A6200 laptop, and a little while ago it stopped charging when plugged in. I tried taking the battery out and powering up, nothing. I tried shaking the machine to see if the power jack was loose, not the problem. I tried ordering a replacement power cord in case the original cord was messed up somewhere, nothing. I'm worried that it might be the motherboard, but does anyone else have any other ideas of what it might be, bar soldering any parts because I don't have access to the technology?

BC AdBot (Login to Remove)

 


#2 Quevvy

Quevvy

  • Members
  • 172 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:46 AM

Posted 08 July 2014 - 04:10 PM

Hello. This has likely been asked before, but I'm getting really irritated and need the help. I have a MSI A6200 laptop, and a little while ago it stopped charging when plugged in. I tried taking the battery out and powering up, nothing. I tried shaking the machine to see if the power jack was loose, not the problem. I tried ordering a replacement power cord in case the original cord was messed up somewhere, nothing. I'm worried that it might be the motherboard, but does anyone else have any other ideas of what it might be, bar soldering any parts because I don't have access to the technology?

 

Have you tried opening up your laptop to check the connections of the power jack? This might help you pinpoint the problem. Simply opening up and checking connections can be very helpful. (For instance, my brother's laptop fan wasn't working, and it was simply unplugged. (Not sure how that happened though…))

 

If you have any electrical testing equipment, such as a multimeter, you could try testing the separate parts of the charging setup (the cord, the jack, the battery, etc.).

 

I had a similar issue with my Dell laptop, and Dell support said it might be a motherboard problem, but then it was fixed after they replaced the battery and the charging cord. If you still have a warranty, contact MSI.



#3 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,116 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:06:46 AM

Posted 12 July 2014 - 07:24 PM

The battery won't charge and the laptop works off the adapter usually means the battery is bad. I have seen (mostly in Sony viao's) incorrect bios versions and Laptop management software causing problems with charging.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users